Notifications
Clear all

Need help: filament is not coming out  

  RSS
Nahuel Carou
(@nahuel-carou)
Active Member
Need help: filament is not coming out

Hello, my name is Nahuel, i have assembled an MK3s, without MMU. It prints very good, but when thr filament runs out of if i want to change the colour, when i press "eject filament", then the filament stays in the extruder, while the printer display says: "remove the filament immediately".! 

I solve this by extruding manually with the option "color is still not uniform" and pushing down with new filament, so that the new color pushes the old rest of remaining filament and gets extruded.

Pilament is PLA, OWL one, Prusament filament settings, i use the prusa slicer in simple mode. Optic sensor is on.

What can be wrong? I did already linear calibration and idle tension calibration.

Can I use  better workaroud as what i am now doing?

if you need more infirmation, or to test something just tell me.

 

Thanks in advance 

 

Nahuel Carou

Posted : 25/07/2019 3:43 pm
Dave Avery
(@dave-avery)
Honorable Member
RE: Need help: filament is not coming out

on a plain MK3S eject filament ejects the filament as far as it can ( till it's out of the bondtech gears)  then it displays the message for you to manually lift it out of the extruder. when you autoload a new filament it will extrude a bit which may or may not be enough to fully purge the old color. usually a second extrude will purge the hotend. a lot depends on the colors being changed , switching from black will take more extrusion to run clean 

Posted : 25/07/2019 3:56 pm
Nahuel Carou
(@nahuel-carou)
Active Member
Topic starter answered:
RE: Need help: filament is not coming out

Thanks for answering. but: Ejecting the filament is what is not working. The filament is not being ejected. Thats the problem.

Waiting for more anwers....

 

Nahuel 🙂

 

Posted : 25/07/2019 4:09 pm
Dave Avery
(@dave-avery)
Honorable Member
RE: Need help: filament is not coming out

eject should wait for preheat to filament temp and then back out the filament about 5cm (2in). the filament wil still be loose in the extruder but not in the bondtech gears.

Posted : 25/07/2019 4:38 pm
Nahuel Carou
(@nahuel-carou)
Active Member
Topic starter answered:
RE: Need help: filament is not coming out

To better understand my problem, I have just made a video: 

https://1drv.ms/v/s!AiosMpZ8SRYd1CBSsKNKwHzRWVib  

The filament is being too much consumed, so there is no option to be pulled out. 

 

Thanks! I wait for you answers, 

Nahuel 🙂

 

Posted : 25/07/2019 5:31 pm
Dave Avery
(@dave-avery)
Honorable Member
RE: Need help: filament is not coming out

sounds like your IR sensor is not working correctly, it should stop the print with filament still in the bondtech gears so they can back it out

Posted : 25/07/2019 7:02 pm
--
 --
(@)
Illustrious Member
RE: Need help: filament is not coming out

By your description, you 1) are not using Filament Runout Detection or 2) the filament is curved from the spool and is catching inside the extruder when passes the detector.

For 1) Turn the filament Sensor to ON.

For 2) There isn't a lot that can be done to prevent this.  Bent filament at the ends of spools is common place and unpredictable. Some ends are semi-straight, others have L shaped bends that are certain to catch inside the extruder and can't be unloaded.   Those types I cut the filament above the Bondtech gears and pull it down and out through the idler door. And the other half up from the extruder.

 

Posted : 25/07/2019 9:17 pm
jimplested
(@jimplested)
New Member
RE: Need help: filament is not coming out
Posted by: @tim-m30

By your description, you 1) are not using Filament Runout Detection or 2) the filament is curved from the spool and is catching inside the extruder when passes the detector.

For 1) Turn the filament Sensor to ON.

For 2) There isn't a lot that can be done to prevent this.  Bent filament at the ends of spools is common place and unpredictable. Some ends are semi-straight, others have L shaped bends that are certain to catch inside the extruder and can't be unloaded.   Those types I cut the filament above the Bondtech gears and pull it down and out through the idler door. And the other half up from the extruder.

 

situation 2 is what Im getting on my machine.  if I snip the filament, it ejects fine.  if it naturally runs out, the filament gets stuck and has to be pulled out the side or snipped above the gear and I push the new filament down and force the old out the nozzle.  

 

Posted : 25/04/2020 3:20 am
Share: