Notifications
Clear all

MMU2 single won't resume after pause  

  RSS
Roger
(@roger-3)
Active Member
MMU2 single won't resume after pause

I'm using Slicer 2.2.0, MMU2 1.0.6 and 3.8.1 firmware which is all the latest revisions.

I've created a part which has an nut embedded in it, and added the pause at the appropriate layer. I can see the pause showing on the layer bar, and the estimated print time shows Color 1 - 2m (2m) and Color 1 -> Pause 5m (7m)

So clearly the Slicer is doing what I've asked.

Remember, I'm using the MMU2 in single filament mode, so maybe this is where the problem is.

When printing, it pauses correctly and prints the message to the screen that I've typed for when the pause happens. I then fit the nut and use the menu to resume the print. I presume this is how it's supposed to work?

I can see that it's showing the correct amount of time remaining and it heats up, goes to print and then immediately parks and repeats the message as if it's just reached the pause.

 

In other words, it won't skip past the pause and resume on the next line. It would appear that the program doesn't move on to the next line when it pauses, so resume just pauses again.

 

Is this problem unique to MMU2 firmware, or is this a problem across the board? Maybe I'm not using the right procedure for resuming the print?

 

Any help would be much appreciated.

Posted : 09/05/2020 8:23 pm
ts
 ts
(@ts)
Active Member
RE: MMU2 single won't resume after pause

Similar story here:

I printed with 3 filaments on a mmu2s with a MK2.5s. 

Slicer 2.2.0, MMU2 1.0.6 and 3.8.1 

It does not restart after the print, but if you repeat the restart procedure 7 times (yes, every time i tried i had to do it 7 times) it resumed printing.

(like the walls of Jericho 🙂 ). Still in my case after parking the nozzle returns to place it should print but then retracts in the parking possion and writes that the printer is paused.

 

Meanwhile it oozed a little on the print, which is not good.

i copied the gcode in a analyzer ( i do not know much about gcodes) but just found 1 M601 command,

would be great to  know how to solve this!

 

...
Posted : 22/05/2020 2:17 pm
Roger
(@roger-3)
Active Member
Topic starter answered:
RE: MMU2 single won't resume after pause
Posted by: @thomas-s13

Similar story here:

I printed with 3 filaments on a mmu2s with a MK2.5s. 

Slicer 2.2.0, MMU2 1.0.6 and 3.8.1 

It does not restart after the print, but if you repeat the restart procedure 7 times (yes, every time i tried i had to do it 7 times) it resumed printing.

(like the walls of Jericho 🙂 ). Still in my case after parking the nozzle returns to place it should print but then retracts in the parking possion and writes that the printer is paused.

 

Meanwhile it oozed a little on the print, which is not good.

i copied the gcode in a analyzer ( i do not know much about gcodes) but just found 1 M601 command,

would be great to  know how to solve this!

 

I'm glad it's not just me then. What amazes me is that there are thousands of printers out there, so why hasn't someone noticed this? It seems to me that 99% of users just use the basic functions, and that's it.

Anyway, I've checked the gcode the slicer is generating, and it's definitely only got one pause command, so the issue is with the printer firmware.

Posted : 25/05/2020 3:30 pm
ts
 ts
(@ts)
Active Member
RE: MMU2 single won't resume after pause

@roger-f5

I think because this is a recently implementet feature-and not so much used yet ( pause print with multimaterial). I guess it is a bug.

I did not have the same problem with color change (but other ones).

...
Posted : 26/05/2020 3:21 pm
Neophyl
(@neophyl)
Famed Member
RE: MMU2 single won't resume after pause

Known issue with 3.8.1 the resume doesn’t work correctly. Not limited to mmu. Fixed in 3.9.0. 

Posted : 26/05/2020 3:51 pm
ts liked
ts
 ts
(@ts)
Active Member
RE: MMU2 single won't resume after pause

Thanks Neophyl,

problem solved!

...
Posted : 30/05/2020 1:52 pm
Roger
(@roger-3)
Active Member
Topic starter answered:
RE: MMU2 single won't resume after pause

Agreed, I've just tried this and it resumes correctly. However, it doesn't display the message that you put in the slicer. That's just a nicety though, but if it's a feature, it should work.

Posted : 30/05/2020 2:12 pm
Share: