Notifications
Clear all

M109 Sxxx waits even when nozzle is hotter  

  RSS
Krzysztof Bednarski
(@krzysztof-bednarski)
New Member
M109 Sxxx waits even when nozzle is hotter

Hey, so i wanted to modify starting G-code to help myself when printer is cold to reduce ooze before it warms up. But seems like this solve this issue creating new one.... When printer is hot it is waiting until extruder reaches 160 from lets say 230 which again is generating some ooze. As far as i know it should be M109 R that is waiting even when cooling... 

Starting g-code looks like this:

; Set initial warmup temps
M117 Nozzle preheat
M140 S{if printer_model=~/.*MK3S.*/}[first_layer_bed_temperature]{else}{max(first_layer_bed_temperature[0],80)}{endif}  ; set bed PINDA warmup temp
; Nozzle warmup before home to avoid driving hardened ooze into PEI surface
M104 S160 ; set extruder no-ooze temp
M109 S160 ; wait for extruder no-ooze warmup temp before mesh bed leveling, cool hot PINDA
; Home

Prusa mk3s+ firmware: 3.10.0-4481

Does anyone know what should i do differently? 

 

 

Posted : 19/10/2021 9:07 am
bobstro
(@bobstro)
Illustrious Member
Has been discussed before, this seems to be Mk3 behavior for now

There is a rather long thread on this topic herethat might be interesting. tl;dr - we're stuck with this behavior for now at least. You can put in a comment to support existing github open issues, but that's about it. The Prusa gcode documentation isn't particularly helpful.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 19/10/2021 8:03 pm
towlerg
(@towlerg)
Noble Member

Yes it's weird, I've noticed same running more vanilla Marlin.

Posted : 20/10/2021 3:02 pm
Share: