IR filament sensor went bad?  

  RSS
xseggs
(@xseggs)
New Member

Apologies if this has cropped up before, but I googled extensively and was not able to come up with anyone having the same problem I was having.

I stupidly miscalibrated my printer (Mk3S), which caused the print to lift and adhere to the print head, which then pumped plastic up inside of the extruder. This meant I had to rebuild the extruder after purchasing a new hotend since it was all caked in plastic. This is actually the second time this has happened, I got this printer at Christmas last year and have only ever done 1 successful print, on December 26th.

Anyways, following the rebuild and firmware update which went fairly smoothly, I noticed it wouldn’t autoload. So I went through the usual troubleshooting steps, including the ones listed in the official Prusa guide (I did not do the part alteration, but only because the issues I found made me pretty sure it was an issue with the sensor, not the lever). This led me to discover that the sensor state in the support menu was always 0, no matter what. The “sensor version” also on the support menu was originally “unknown”, and then following the firmware update became “.3 or older”. It is the red pcb printed with v.4, so that is incorrect.

I checked the board connection and saw it was getting +5v, and the continuity in the cable was fine, however no matter what I tried the OUT/middle pin on the sensor never changed from 0V output. I tried putting filament in, actuating the lever manually, and even tried an Allen key in the notch the lever normally goes. If I remember the documentation correctly, the sensor outputs +5v passively, and then 0V once it detects filament. Do I have a bad sensor, or am I missing something?

 

edit: added paragraphs so it was less of a wall of text

This topic was modified 1 month ago 2 times by xseggs
Posted : 09/08/2020 2:31 am
xseggs
(@xseggs)
New Member

All voltage/continuity measurements done with a multimeter

Posted : 09/08/2020 2:33 am
chadebrown
(@chadebrown)
New Member

I had the same problem after I built mine, a printed ir sensor spacer https://www.prusaprinters.org/prints/25728-prusa-mk3s-ir-sensor-spacer-set

and it fixed it. Try taking the cover off the sensor, insert your filament and slowly unscrew the sensor while watching its state, if starts detecting the filament the spacer may help

Posted : 19/08/2020 6:32 am
Share:

Please Login or Register