Notifications
Clear all

Heating Disabled by safety timer  

  RSS
Marius Chirita
(@marius-chirita)
Eminent Member
Heating Disabled by safety timer

Hello guys,

I have a prusa MK3S+ connected to a raspberry pi 4 with octoprint and I keep getting this error "Heating Disabled by safety timer" on the printer screen and another error on the octoprint page : Too many consecutive timeots. Printer still connected and alive.

The printer can run without problems a week or a few days of continuous printing and then it would fail for no reason. I have another printer connected the same way and never had a problem.

 

Any idea what the problem can be ?

...
Posted : 16/09/2021 9:01 am
cwbullet
(@cwbullet)
Illustrious Member
Occasionally

I have not figured it out yet.  I think it is a bug.  It happens from time to time.  I have no idea why.  I think it is in octoprint because I don’t get it outside of Octoprint.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 16/09/2021 10:27 am
fuchsr
(@fuchsr)
Noble Member

I'm missing something... Is this happening in the middle of a print? Because otherwise it's a normal safety precaution of the printer is sitting idle at print temperature for a while.

Posted : 16/09/2021 10:45 am
cwbullet
(@cwbullet)
Illustrious Member
Error

 

Posted by: @fuchsr

I'm missing something... Is this happening in the middle of a print? Because otherwise it's a normal safety precaution of the printer is sitting idle at print temperature for a while.

That is when has happened to me.  I walk away while it is printing and come back to the error.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 16/09/2021 10:51 am
fuchsr
(@fuchsr)
Noble Member

Haven't seen this myself, so I'm just speculating.… Maybe some connection error and disconnect of Octoprint, so the printer is sitting at operating temperature without getting any commands sent, until the safety timeout kicks in?

Posted : 16/09/2021 11:07 am
Marius Chirita
(@marius-chirita)
Eminent Member
Topic starter answered:
error

Yes, it stops in the middle of the print. I think the printer is loosing connection with the octoprint. I did try different USB ports on the raspberry pi but still does it. I just replaced the 2A power supply with a 3A one and ordered new shorter usb cables. will keep you updated

Posted by: @fuchsr

I'm missing something... Is this happening in the middle of a print? Because otherwise it's a normal safety precaution of the printer is sitting idle at print temperature for a while.

 

...
Posted : 16/09/2021 11:27 am
Share: