Notifications
Clear all

[Solved] Having trouble updating to the latest firmware.  

  RSS
ioneng
(@ioneng)
Active Member
Having trouble updating to the latest firmware.

I'm trying to update my mk3s with prusaslicer runinng on windows 10, but it keeps timing out on the com port connection:

===========================================================

avrdude-slic3r -v -p atmega2560 -c wiring -P COM4 -b 115200 -D -U flash:w:0:F:\Downloads\prusa3d_fw_MK3S_3_8_0_2684.hex:i

avrdude-slic3r: Version 6.3-20160220-prusa3d, compiled on May 20 2019 at 18:52:49
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

Using Port : COM4
Using Programmer : wiring
Overriding Baud Rate : 115200
avrdude-slic3r: stk500v2_recv(): timeout
avrdude-slic3r: stk500v2_getsync(): timeout communicating with programmer
avrdude-slic3r: Could not open port: COM4

avrdude-slic3r done. Thank you.

=======================================================

So I'm on firmware 3.7.2 at the moment. I updated it from 3.7.1 using prusaslicer the same way I'm doing now. 

I can print with pronterface on the same com port. I can print with octopi. When I tried to update with the firmware updater plugin for octoprint , it also timed out.

I've only been using the printer for a couple of months so I'm still kinda new at it all. Does anyone have any idea what could be the cause of this?

 

 

Posted : 07/09/2019 12:53 pm
ioneng
(@ioneng)
Active Member
Topic starter answered:
RE: Having trouble updating to the latest firmware.

I got it working after following suggestions on this discussion:

https://stackoverflow.com/questions/19645441/avrdude-stk500v2-receivemessage-timeout

Basically I clicked on the flash button in Prusaslicer immidately after I pressed reset button on the printer. I have no idea why this works but if you have the same problem, give this a try.

After flashing and the printer reboots, Prusaslicer will complaine that it lost connection with COM port, but this is ok. Firmware has already been flashed.

Posted : 09/09/2019 5:59 am
Share: