Flashing failed  

  RSS
leonardo.s4
(@leonardo-s4)
Active Member

Hi. I just completed the upgrade from MK3 to MK3S and installed the MMU2S. Upon starting the printer, the display showed "External SPI flash W25X20CL not responding." I tried to install the latest firmware but the flashing failed (see log below). The printer display then went back to show the same error message. 

Any idea what's going on and how to fix this issue?

Thanks

 

avrdude-slic3r -v -p atmega2560 -c wiring -P COM3 -b 115200 -D -U flash:w:0:C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex:i

avrdude-slic3r: Version 6.3-20160220-prusa3d, compiled on Apr 14 2019 at 10:31:07
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

Using Port : COM3
Using Programmer : wiring
Overriding Baud Rate : 115200
AVR Part : ATmega2560
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00
flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : Wiring
Description : Wiring
Programmer Model: AVRISP
Hardware Version: 15
Firmware Version Master : 2.10
Vtarget : 0.0 V
SCK period : 0.1 us

avrdude-slic3r: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude-slic3r: Device signature = 0x1e9801 (probably m2560)
avrdude-slic3r: safemode: hfuse reads as D0
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: reading input file "C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex"
avrdude-slic3r: writing flash (249692 bytes):

Writing | ################################################## | 100% 47.71s

avrdude-slic3r: 249692 bytes of flash written
avrdude-slic3r: verifying flash memory against C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex:
avrdude-slic3r: load data flash data from input file C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex:
avrdude-slic3r: input file C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex contains 249692 bytes
avrdude-slic3r: reading on-chip flash data:

Reading | ################################################## | 100% 31.97s

avrdude-slic3r: verifying ...
avrdude-slic3r: 249692 bytes of flash verified

avrdude-slic3r: safemode: hfuse reads as D0
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: safemode: Fuses OK (E:FD, H:D0, L:FF)

avrdude-slic3r done. Thank you.

avrdude-slic3r -v -p atmega2560 -c arduino -P COM3 -b 115200 -D -u -U flash:w:1:C:\Users\julia\Downloads\prusa3d_fw_3_7_0_MK3S_1_0_5_MMU2S\prusa3d_fw_MK3S_3_7_0.hex:i

avrdude-slic3r: Version 6.3-20160220-prusa3d, compiled on Apr 14 2019 at 10:31:07
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude-slic3r: prusa_init_external_flash(): MK3 printer emitted incorrect start code: ` `
avrdude-slic3r: arduino_open(): Failed to initialize MK3 external flash programming mode
avrdude-slic3r: Could not open port: COM3

avrdude-slic3r done. Thank you.

 

 

Posted : 26/04/2019 4:27 am
petar.s2
(@petar-s2)
New Member

I'm experiencing the same issue, as of yesterday. Did you solve it? 

Posted : 03/08/2019 11:51 pm
vintagepc
(@vintagepc)
Noble Member

Contact support. A small number of boards did not survive the firmware update and have this "external flash" error. They will either help you fix it or replace the board, if in warranty.

Posted : 04/08/2019 3:06 am
petar.s2
(@petar-s2)
New Member

Chat with support resulted in a discount on a new board, since I'm out of warranty. 

Posted : 04/08/2019 5:21 am
Share:

Please Login or Register