Firmware Update Issue - Checksum Error on verification - Mk3s
 

Firmware Update Issue - Checksum Error on verification - Mk3s  

  RSS
enzopepe
(@enzopepe)
New Member

Hi All, 🙂 

I'm Running Prusa Slic3r v. 2.3.1 on Win 10 1909,
I'm having problems trying to instal firmware v3.9.3 on my MK3S. 😭 

The error occurs in the verification passage,
here below 2 error logs.

Test 01

""Reading | #######################################avrdude-slic3r: stk500v2_recv(): checksum error
########### | 100% 32.55s

avrdude-slic3r: verifying ...
avrdude-slic3r: verification error, first mismatch at byte 0x30f0e
0xce != 0xcf
avrdude-slic3r: verification error; content mismatch

avrdude-slic3r: safemode: hfuse reads as D0
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: safemode: Fuses OK (E:FD, H:D0, L:FF)

avrdude-slic3r done. Thank you.""

 

Test 02

""Reading | ##########avrdude-slic3r: stk500v2_recv(): checksum error
###################avrdude-slic3r: stk500v2_recv(): checksum error
#######avrdude-slic3r: stk500v2_recv(): checksum error
avrdude-slic3r: stk500v2_recv(): checksum error
############## | 100% 33.13s

avrdude-slic3r: verifying ...
avrdude-slic3r: verification error, first mismatch at byte 0xcd0c
0x84 != 0xf2
avrdude-slic3r: verification error; content mismatch

avrdude-slic3r: safemode: hfuse reads as D0
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: safemode: Fuses OK (E:FD, H:D0, L:FF)

avrdude-slic3r done. Thank you.""

at each attempt the error is slightly different.

I Tryed all official procedure (many times) from Here and Here, except the factory reset.

In the end, the printer firmware result installed even if the process failed.
Can I trust this failed update process?
Can I utilize the printer..?
How can I solve the problem..?

Thanks in Advance

Enzo

 

Posted : 26/04/2021 2:24 pm
Clarmrrsn
(@clarmrrsn)
Honorable Member

Enzo, that does not look right to me,  I have not tried flashing my MK3, but strongly suspect the verification should not be getting checksum errors, means something is not right with the flash process.

Did you definately use the correct FW file?   MK3 and MK3s/mk3s+ are different.

Try uninstalling and reinstalling the full prusa driver and software package again, then download the firmware again and use a different USB cable. 

If none of this works, and if no one else can provide any further insight, I would suggest speaking to Prusa Tech support via chat on the EShop.  Could be a hw issue with the board.

Sorry cant be of more help, my mk3s+ came with the latest fw loaded.

Tank you very much!...
Posted : 28/04/2021 9:13 am
enzopepe
(@enzopepe)
New Member

Thank You @clarmrrsn for the reply,
Yes, the procedures used were correct, Software, Drivers, and Firmware file were downloaded and installed many times whit different cables and USB ports.

In the end, I did a "Full Factory Reset" as suggested Here and by Prusa Tech Support by mail.
I thought the original firmware would be restored, but at the end of the procedure the new Firmware v.3.9.3 turns out to be still installed.

Now I'm testing the printer and waiting to report the result to Prusa Tech Support.
Nothing bad I've noticed so far, but I'm worried about the failed update and ability to be able to update again in the future.

Posted : 28/04/2021 11:43 am
Clarmrrsn
(@clarmrrsn)
Honorable Member

Let us know how it works out please.

 

Tank you very much!...
Posted : 28/04/2021 9:55 pm
Share:

Please Login or Register