[Solved] Firmware update fails  

  RSS
robert.a2
(@robert-a2)
Active Member

I have a MK2.5 Prusa but can't update the firmware.

I tried loading the new firmware (prusa3d_win_2_2_6) but when it was finished the printer just had a very load alarm. I tried turning it on and off and the alarm persisted. I re-flashed again but got the same problem. I flashed the previous firmware (prusa3d_win_2_2_4) and it seemed to be fine. I retried the flash with the new firmware with the same result. So, I reloaded the latest software (prusa3d_fw_3_7_1_MK25) and tried the re-flash again with the same result. I went back to the earlier version and it seems to be fine. Can anyone help?

Posted : 23/05/2019 4:24 pm
ron.o
(@ron-o)
Active Member

I'm Confused.

Isn't prusa3d_win_2_2_6 Drivers that you would install on your PC (Personal Confuser) and the file prusa3d_fw_3_7_1_MK25 the Firmware that you would flash to the printer.

Are you using PrusaSlicer (or Slic3R Prusa Edition) to flash, if so how are you flashing something other than a .hex file? win_2_2_6 is an .exe file

Peace, Love & Applesauce....
Posted : 23/05/2019 6:28 pm
robert.a2
(@robert-a2)
Active Member

You are correct.  I was using prusa3d_fw_3_7_1_MK25 to flash the Prusa. But..... I picked the wrong RAMBO board version. I selected version 10a and my board is 13a. Although I haven't had time to try it yet I am sure that will fix the problem. Thanks for keeping my honest. 

Cheers,

Just Bob

Posted : 24/05/2019 4:15 pm
Share:

Please Login or Register