Firmware update causing problems  

  RSS
Bstei18
(@bstei18)
New Member

I've updated my Mk3S to firmware 3.9.3 using the latest Prusa Slicer. The update said it completed successfully but since then the printer has behaved erratically. All of my prints before this completed fine but after the update whenever I turn it on it says its recovering the last print. When I try to unload the filament and I press the knob after heating, it doesn't unload the filament but the carriage assembly goes to the top until I hit the X to stop it. 

There were no power interruptions during flash, I have the printer on a UPS and run the software from a laptop. I've tried flashing an earlier firmware version that says it completed successfully, but the results are exactly the same.

Any help would be appreciated.

Best Answer by karl-herbert:

Posted by: @bstei18

I've updated my Mk3S to firmware 3.9.3 using the latest Prusa Slicer. The update said it completed successfully but since then the printer has behaved erratically. All of my prints before this completed fine but after the update whenever I turn it on it says its recovering the last print. When I try to unload the filament and I press the knob after heating, it doesn't unload the filament but the carriage assembly goes to the top until I hit the X to stop it. 

There were no power interruptions during flash, I have the printer on a UPS and run the software from a laptop. I've tried flashing an earlier firmware version that says it completed successfully, but the results are exactly the same.

Any help would be appreciated.

I have also had this problem and it happened after a power failure. The solution was a factory reset and reflash the firmware.

good luck!

Posted : 19/03/2021 1:50 pm
fuchsr
(@fuchsr)
Honorable Member

I’d get on the chat with Prusa support on their web site. Fastest way to get this resolved. 

Posted : 19/03/2021 3:14 pm
karl-herbert
(@karl-herbert)
Illustrious Member
Posted by: @bstei18

I've updated my Mk3S to firmware 3.9.3 using the latest Prusa Slicer. The update said it completed successfully but since then the printer has behaved erratically. All of my prints before this completed fine but after the update whenever I turn it on it says its recovering the last print. When I try to unload the filament and I press the knob after heating, it doesn't unload the filament but the carriage assembly goes to the top until I hit the X to stop it. 

There were no power interruptions during flash, I have the printer on a UPS and run the software from a laptop. I've tried flashing an earlier firmware version that says it completed successfully, but the results are exactly the same.

Any help would be appreciated.

I have also had this problem and it happened after a power failure. The solution was a factory reset and reflash the firmware.

good luck!

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 19/03/2021 4:37 pm
Bstei18
(@bstei18)
New Member

@karl-herbert

This was the way to go. After the reset, I loaded the new firmware, re-calibrated the printer and it's working fine now. 

Thank You.

Posted : 20/03/2021 9:19 pm
Bstei18
(@bstei18)
New Member

@fuchsr

A factory reset turned out to be the best solution. Thank you for your suggest though, that would have been my next step.

Posted : 20/03/2021 9:20 pm
karl-herbert
(@karl-herbert)
Illustrious Member

@bstei18

...is often the easiest and most effective way, even if you have to recalibrate.

happy printing 👍 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/03/2021 10:19 pm
Share:

Please Login or Register