Encounter degradtion of print quality after upgrading to 3.9.0
 

Encounter degradtion of print quality after upgrading to 3.9.0  

  RSS
HarrySatt
(@harrysatt)
Active Member

Hi there

After upgrade to 3.9.0 I have problems with print quality. f.e. Wall are not properly connected to inner parts and go of. Also top layee is not OK. But step back to 3.8.1 does not bring back old printquality.

Posted : 04/06/2020 3:05 pm
j1m1sh
(@j1m1sh)
Active Member

An issue was logged in github that also stated that reverting to 3.8.1 did not restore print quality.

https://github.com/prusa3d/Prusa-Firmware/issues/2693

Posted : 04/06/2020 3:36 pm
bobstro
(@bobstro)
Illustrious Member
Posted by: @j1m1sh

An issue was logged in github that also stated that reverting to 3.8.1 did not restore print quality.

I just read through that discussion and it seems to have ended up that reverting to 3.8.1 fixed the problem. My takeaway is that we need to re-run the Marlin LA test for 1.5. I've read elsewhere that some of the automatic conversion using LA 1.0 values to LA 1.5 is not working ideally.

I've not had any noticeable issues since upgrading from 3.8.1 myself. Have those of you experiencing the issue either disabled LA (M900 K0) or re-run the Marlin test procedure?

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 04/06/2020 3:48 pm
j1m1sh
(@j1m1sh)
Active Member

I agree that this issue has a lot of speculation and hunches.

I presented the different prints to several TEST persons and they all declared the 3.9.0 as the worst, followed by the downgraded 3.8.1 print and the best was the original 3.8.1. print.

As for me, for the time being, I am sticking with 3.9.0.

But my experience is that the top layer is no where near as smooth as it used to be.  With an octogram spiral top layer, a layer height difference is noticeable.

I do plan on reviewing the printer/filament profiles.  Thanks for the additional suggestion to re-run the Marlin linear advance test.

This post was modified 11 months ago by j1m1sh
Posted : 04/06/2020 4:00 pm
HarrySatt
(@harrysatt)
Active Member
  • I agree that the toplayers are ugly by the best. Is there any possibility to revert back to 3.8. Seems not to be possible. 
  • Regards, Harald
Posted : 04/06/2020 4:30 pm
HarrySatt
(@harrysatt)
Active Member

Have a look. It is not sliced with newer firmware. Do not think this is necessary. Hope that works. Inserting images is not good solved by the best.

Regards, Harald

Posted : 04/06/2020 5:03 pm
j1m1sh
(@j1m1sh)
Active Member

*Update*

It appears to me that that my degradation was caused by the automatic Linear Advance 1.0 conversion.

I use custom filament profiles, and I did not originally update my profile with the new "start_filament_gcode" settings that include the new LA 1.5 settings.

I am seeing much better results after updating my custom printer, print, and filament profiles.

jim

Posted : 07/06/2020 3:07 pm
Share:

Please Login or Register