Autoload filament not working  

  RSS
matthew.s69
(@matthew-s69)
New Member

Hello, I just finished a mk3 kit and everything is working well except the autoload filament command. The filament sensor is working properly and detects runouts but when I press load filament nothing happens. After the “autoloading is active” screen I click the selector wheel nothing happens. Sometimes after a minute or 2 it finally goes through the loading procedure but most of the time nothing happens and I need to use “move axis” to load the filament. The hot end is preheated and I am running the most recent firmware. Anyone else have this issue?

Posted : 08/09/2018 7:19 am
phil.s6
(@phil-s6)
Trusted Member

So, not sure I completely understand, but a couple of point:

1. The filament sensor does NOT work with every filament. If your filament is specifically reflective, transparent, or similar, it may not work and you will have to load manually.

2. If you have autoload filament on, and are using a standard filament, you don't have to press the selector wheel. Make sure you cut the tip of the filament at an angle and then just feed it in the hole at the top of the extruder. The gears should begin grabbing it after it reaches a certain point.

Posted : 08/09/2018 7:25 am
matthew.s69
(@matthew-s69)
New Member

To clarify, I am using the prusa grey pla included in the printer and grey and white pla all with the same results, I am clipping the end on an angle. When I change the filament, I use the unload command and that works normally. I then select autoload filament. The lcd prompts me to click the button and insert my filament, I do that and nothing happens, the extruder motor doesn’t move or make any attempt to move. When I change color mid print it works properly.

Posted : 08/09/2018 7:32 am
RHDreambox
(@rhdreambox)
Honorable Member

If you have configured the printer to automatically load the filament, you do not need to touch the menu at all.
After you have unloaded the old filament, you should only put in the new filament and it will automatically load.
So check the "Settings / F.autoload" menu that autoload is activated.

Bear MK3 with Bondtech extruder...
Posted : 08/09/2018 12:21 pm
Texy liked
robin.a
(@robin-a)
Estimable Member

Are you using the autounload filament command first or trying to load an allreay loaded extruder?

I believe the Z height of the extruder has to be above a set point now to autoload.

Posted : 08/09/2018 1:16 pm
RHDreambox
(@rhdreambox)
Honorable Member

You can change filaments at any height.
With the latest software, the extruder is raised a bit automatically when the old filament is extruded and replaced with the new one.

Bear MK3 with Bondtech extruder...
Posted : 08/09/2018 4:39 pm
blairm
(@blairm)
New Member

@matthew-s69

Did you figure out what was wrong? I'm having the same problem, i'm also using the gray pla included with the kit. It loaded fine when I was doing testing and it was fine for my first few prints. The filament got tangled so I unloaded it and that worked fine, but now that i'm trying to reload it won't work.

Posted : 10/11/2019 8:27 pm
fm1985
(@fm1985)
New Member

I have the exact same problem. I checked my settings and f.autoload is [ON]. It works beautifully when I slice a part that has a color change, but does not work when I select autoload filament, for example before starting a print. I have to go into settings and move the E-Stepper motor. If you can please help me this is really annoying. Thanks and have a wonderful day!

Posted : 18/11/2019 10:46 am
Robert-mm200
(@robert-rmm200)
Noble Member

When you have an autoload / sensor problem, make sure you indicate what printer you have.

MK3 is not the same as MK3S in this area.

Posted : 18/11/2019 5:25 pm
mdaneman
(@mdaneman)
Estimable Member

@fm1985

There may be some confusion here.  All the "Autoload Filament" menu item does is TURN ON autoloading.  You DO NOT need to push it every time you need to load the filament.  All you have to do to load filament is to stick the filament into the extruder and it should auto-detect it and load it.  If that's not working, then you should check that your filament sensor is actually triggering when filament is loaded - that's on the "Support" menu (just scroll down a lot).

Posted : 18/11/2019 5:26 pm
fm1985
(@fm1985)
New Member

My printer is a MK3S.

Thanks @mdaneman. I tried just to stick the filament into the extruder, it didn't work. 

I'm in settings, Sensor state. Looking at IR: 1 ? Is that correct? or am I looking in the wrong place?

Thank you!!!

Posted : 18/11/2019 6:29 pm
mdaneman
(@mdaneman)
Estimable Member
Posted by: @fm1985

My printer is a MK3S.

Thanks @mdaneman. I tried just to stick the filament into the extruder, it didn't work. 

I'm in settings, Sensor state. Looking at IR: 1 ? Is that correct? or am I looking in the wrong place?

Thank you!!!

Yes, that's the correct sensor.  It should change from 1 to zero (or zero to 1, don't recall which) when you insert and remove the filament.  If it's not doing this, then it may need alignment.  Turn off auto-load, remove the sensor cover (top of the extruder - it's held down with one screw), loosen the screw holidng the filament sensor and push it around until you get 1/0 changes for filament inserts/removals, then tighten the screw.  In some cases, I've heard of people having to file down the sensor board or the plastic slot a bit to make it work (I didn't have to do it myself though, I just had to push the board against the left-side of it's slot).  (Then don't forget to re-enable auto-load.)

Posted : 19/11/2019 2:50 am
fm1985 liked
Robert-mm200
(@robert-rmm200)
Noble Member

I actually found a use for the calibration circle. I cut off a bit and put it under the sensor board.

I have had no errors since.

Posted : 19/11/2019 2:56 am
fm1985 liked
fm1985
(@fm1985)
New Member

Thank you @robert-rmm200 and @mdaneman. This is by far the most helpful forum I've ever been in, I am so glad to be part of the Prusa community. Thank you guys!

In case someone has a problem like I had, here is what worked for me:

I turned off Autoload.

I went into the support menu and selected sensor settings as described above. Looking at IR it always showed a 1, which means filament is loaded.  

I removed the sensor PCB and carefully sanded down the side that says GND, since I needed to move the PCB to the left. I also drilled the hole slightly bigger with a 9/64" bit. 

I readjusted the PCB so the IR sensor output stays at 0, which means no filament is loaded.

Then tightened it down and turned autoload back on.

It work beautifully now. Thanks again...

Posted : 19/11/2019 7:42 pm
The Mad Jedi
(@the-mad-jedi)
New Member

Hi All,

Gota take my hat of to this community, like fm1985 said above fantastic forum.
Was experiencing the same problem with the IR sensor registering filament was always loaded so auto load would not work, my issue was not that the IR board needed to be adjusted but a piece of material (probably PLA) got into the space near the leaver meaning it always registered filament was loaded. A small blast of air and everything is working perfect as usual.

Thank You to Everyone

Posted : 22/12/2019 12:22 am
hwa.labout
(@hwa-labout)
New Member

Had the same issue on my brand new i3 MK3s.

The IR sensor was always triggered with output "1".

On Prusa support adviced checked the sensor mechanism, which was working as designed.

Ended up with printing a spacer for under the IR sensor and making the IR cut-out space on the top cap longer for the lifted IR sensor:

https://www.prusaprinters.org/prints/8624-mk3s-ir-sensor-spacer-05-mm/files

Suspect that the IR sensor is too sensitive, IR sensor now switches from "0" to "1" when inserting / removing filament.

All working fine now with autoload on. 😀 

Perhaps a little design flaw.

 

Greetings, Harald

Posted : 24/12/2019 9:40 am
neek
 neek
(@neek)
Active Member

Like you, I also had the issue where IR was always reporting 1 on a brand new MK3S (as of Feb 2020). Your 0.5mm spacer worked perfectly for mine as well. Thanks!

Posted : 13/02/2020 5:29 pm
alexbdex
(@alexbdex)
New Member

@hwa-labout

I'm just adding to the population of autoload failed on build.
Everything else was working as expected, except IR sensor value always 1.
Did both the spacer and making the IR cover cutout space longer as per @hwa-labout and working as expected now.

Posted : 22/02/2020 2:16 am
stratoblanche
(@stratoblanche)
New Member

@hwa-labout Thank you, the spacer fixed my autoload issue.

Posted : 10/03/2020 4:05 pm
bylwrks
(@bylwrks)
New Member

One of our original i3's has a non responsive finda sensor circuit..I have tried everything I can find to do....tested cables swapped out finda boards with a fresh one..blown areas clean of all dust etc., rebooted..after reconnecting and checking for internittent contacts(none). I cannot get any response in Sensor state readout, beyond

'Finda N/A'

'Pinda 0'

'IR 0'

 ....comparing with my other units rule out any inconsistency with assembly...  i nitally I was able to get a response by wiggling RWB wires at the carriage but no more and the plug contacts read continous ...What could I be missing?

Posted : 10/03/2020 7:01 pm
Share:

Please Login or Register