Slic3r Prusa Edition 1.40.1 - FINAL  

Page 7 / 9
  RSS
martin.s97
(@martin-s97)
Active Member



Question about Auto Speeds.
Is this now OK to use with 1.40.1, or should I still use manually set individual feature speeds, what is the current recommendation about Auto ?

I'm trying Auto speeds with the max speed set to my reliable maximum (40mm/s on my Mk I i3) and getting OK prints but the speeds for some features like infill can be painfully slow for no apparent reason. Wondering if it's not recommended yet.

Hi Martin,
which speeds would you like to change? Please specify the material and layer height as well. In general, our profiles are constantly tweaked for the best performance and same goes to the overall Slic3r PE settings, so I'm sure it has some reason. For example slow movements can be caused by a minimal time on a layer, so the material has time to cool down and solidify.

It's a completely DIY Prusa with a Buderschnozzle geared extruder, using Marlin on a Melzi board, and a lot of custom parts, hence I didn't ask about machine specific speeds relating to factory Prusa's as they won't match my machine physics I assumed (maybe wrongly).
The question was to work out why infill on a couple of prints runs at snails pace and gets messy at the start of each infill feature after the perimeters run at a reasonable speed. I'm sure I can fix the issue by setting manual speeds for infill, but I wondered why auto speed is not working like I imagined (did it ever get sorted out after the advice some long time ago to not use it ?).
The layer print time is well above the cooling slow down threshold, so that shouldn't be effecting infill speed.
Layers are 0.2 and using ABS.

Posted : 12/07/2018 2:14 pm
ewald.i
(@ewald-i)
Active Member

For there is no subforum for Slic3r PE, I like to share my thought about printing with PVA+ here.
https://shop.prusa3d.com/en/special/169-primaselect-pva-soluble-support-500g.html#
I made some tests with soluble interface, first with the original settings in Slic3r PE, that did not succeed.
Searching around the Internet I made some settings that gave me a quite decent result:

  • Increasing the PVA+ temperature to 210 °C

  • Increasing the extrusion multiplier for the PVA+ to 1.1

  • Increasing the density of the support (for main support and PVA+, the PVA nees some area to stick to)

  • Lowering the speed for the interface to 15 mm/s

  • Lowering the speed for PLA to 20 (this seems to be needed to get a decent bond between PLA and PVA)
  • Lowering the PLA speed in all makes the print take very long. Only 2 or 3 layer above the interface would be in need to printed slow, the rest could be printed with normal speed.
    As the support (interface) simulates a print bed , the top layer of the interface should be completely closed, else the area to be printed next is not completely flat. Even with pattern spacing "0", there are holes in the interface and BTW: why to print the whole support solid???

    So my question is, for the next version of Slic3r PE, could there be some improvements for printing with PVE+?

    Posted : 12/07/2018 9:38 pm
    jakub.d
    (@jakub-d)
    Member Admin

    Hi Ewald,
    for software issues/improvements you can use https://shop.prusa3d.com/forum/hardware-firmware-and-software-help-f64/

    Regarding the PVA improvements, I will ask our printing gurus 😉

    Assembly manuals / Knowledge Base
    The guy behind Prusa assembly manuals......
    Posted : 13/07/2018 11:52 am
    ewald.i
    (@ewald-i)
    Active Member

    Hello Jakub!

    Thanks for that hint. I'll keep in mind :thumbsup:

    Posted : 13/07/2018 5:28 pm
    roy.e4
    (@roy-e4)
    New Member

    I’ve just received and built my MK3 and printed the whistle. Everything worked great and then...

    I downloaded a Buddha on a leaf from Thingyverse, as I’ve printed this one on my MakerGear M2 and my wife wanted another. This is a detailed print and it requires a lot of support. My maker gear did very well and I was really thinking how good it was going to look on my new Prusa MK3. Well the first thing I couldn’t find was a way to drop a surface to the build plate. The model was obviously scanned and the bottom surface is not parallel to the X-axis. I couldn’t find any way to correct this orientation in Slic3r PE, nor in Prusa Control. I am hoping that I am just missing something and someone here can tell me how to find this function in Slic3r or PC. I ended up downloading the MK3 profile for my Simply3D and slicing from there. The print is about half done, but the supports that were generated are all over the place and messesed up. I am assuming that the standard supports that S3D does are not optimized for the MK3 and I assume that if I were to slice this using the Prusa software it would work properly. I just can’t find the function that would correct the orientation of the model.

    Any help here would be much appreciated.

    Posted : 14/07/2018 12:04 am
    bobstro
    (@bobstro)
    Famed Member

    In Slic3rPE, shapes are always lowered to the bed so the lowest part touches. To cut some off the bottom, select the object and do Object->Cut. You can specify how much to cut, and whether to keep the top, bottom or both pieces. For support, I've had the best luck with a 0.25mm Z distance and 2 interface layers, the rest of the settings default.

    My notes and disclaimers on 3D printing and miscellaneous other tech projects
    He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
    Posted : 14/07/2018 9:55 am
    jakub.d
    (@jakub-d)
    Member Admin


    ...
    So my question is, for the next version of Slic3r PE, could there be some improvements for printing with PVE+?

    It is planned together with MMU 2.0, settings will be tweaked for MMU 1.0 as well

    Assembly manuals / Knowledge Base
    The guy behind Prusa assembly manuals......
    Posted : 14/07/2018 2:10 pm
    barry.s4
    (@barry-s4)
    Active Member

    Would like to see add/remove support option added to Prusa Slic3r program.
    Also would like to see option for Best Printing Orientation for the file.

    Posted : 14/07/2018 10:39 pm
    deyan.d
    (@deyan-d)
    Active Member

    Hi.
    Why i cant click on Layer Editing?

    I've searched for an answer but couldn't find any.

    Posted : 15/07/2018 11:43 am
    gaston.d3
    (@gaston-d3)
    Reputable Member

    Have you enabled that feature? If not, go to Printer Settings tab and check "Enable variable layer height feature".

    I do not know why you have to manually enable it but that is how it worked for me.

    Posted : 15/07/2018 8:38 pm
    deyan.d
    (@deyan-d)
    Active Member

    It is enabled.

    Posted : 19/07/2018 10:34 pm
    MrMik
    (@mrmik)
    Honorable Member


    I think this should help you to allow access to the serial line for a non-root:

    http://quandtum.weebly.com/home/how-do-i-access-my-usb-serial-port-without-root-on-ubuntu-kubuntu

    Thanks, it appears that this worked!

    Here is a copy of the instructions in case the link stops working:

    How do I access my USB serial port without root on Ubuntu / Kubuntu?

    11/7/2014

    You first need to remove the modemmanager as follows:
    sudo apt-get autoremove modemmanager
    Next, you need to add your user to the dialout group as follows:
    sudo adduser username dialout
    Finally, reboot your machine. Now your user should be able to load minicom without root.

    Now, when I plug in the USB cable between Ubuntu laptop and Prusa i3 MK3, nothing happens.
    Before following the instructions above, the screen on the I3 MK3 changed and the extruder fans started to run for about 10-20s when I connected the USB cable.

    Now, the extruder fans only start to run when I flash the firmware.

    I'm still getting some error message at the end, but I think the firmware flash was actually successful.

    avrdude: Version 6.3-20160220-prusa3d, compiled on Jul 5 2018 at 15:47:40
    Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
    Copyright (c) 2007-2014 Joerg Wunsch

    System wide configuration file is "/tmp/.mount_Link tuir1lk/usr/bin/resources/avrdude/avrdude.conf"

    Using Port : /dev/ttyACM0
    Using Programmer : wiring
    Overriding Baud Rate : 115200
    AVR Part : ATmega2560
    Chip Erase delay : 9000 us
    PAGEL : PD7
    BS2 : PA0
    RESET disposition : dedicated
    RETRY pulse : SCK
    serial program mode : yes
    parallel program mode : yes
    Timeout : 200
    StabDelay : 100
    CmdexeDelay : 25
    SyncLoops : 32
    ByteDelay : 0
    PollIndex : 3
    PollValue : 0x53
    Memory Detail :

    Block Poll Page Polled
    Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
    ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
    eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00
    flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00
    lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
    hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
    efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
    lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
    calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
    signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

    Programmer Type : Wiring
    Description : Wiring
    Programmer Model: AVRISP
    Hardware Version: 15
    Firmware Version Master : 2.10
    Vtarget : 0.0 V
    SCK period : 0.1 us

    avrdude: AVR device initialized and ready to accept instructions

    Reading | ################################################## | 100% 0.01s

    avrdude: Device signature = 0x1e9801 (probably m2560)
    avrdude: reading input file "/media/p/Data/3D_printing_stuff/PRUSA_i3_MK3_files/Firmware_i3_MK3/prusa3d_fw_MK3_3_3_1.hex"
    avrdude: writing flash (253630 bytes):

    Writing | ################################################## | 100% 44.94s

    avrdude: 253630 bytes of flash written
    avrdude: verifying flash memory against /media/p/Data/3D_printing_stuff/PRUSA_i3_MK3_files/Firmware_i3_MK3/prusa3d_fw_MK3_3_3_1.hex:
    avrdude: load data flash data from input file /media/p/Data/3D_printing_stuff/PRUSA_i3_MK3_files/Firmware_i3_MK3/prusa3d_fw_MK3_3_3_1.hex:
    avrdude: input file /media/p/Data/3D_printing_stuff/PRUSA_i3_MK3_files/Firmware_i3_MK3/prusa3d_fw_MK3_3_3_1.hex contains 253630 bytes
    avrdude: reading on-chip flash data:

    Reading | ################################################## | 100% 32.47s

    avrdude: verifying ...
    avrdude: 253630 bytes of flash verified

    avrdude done. Thank you.

    avrdude: Version 6.3-20160220-prusa3d, compiled on Jul 5 2018 at 15:47:40
    Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
    Copyright (c) 2007-2014 Joerg Wunsch

    System wide configuration file is "/tmp/.mount_Link tuir1lk/usr/bin/resources/avrdude/avrdude.conf"

    Using Port : /dev/ttyACM0
    Using Programmer : arduino
    Overriding Baud Rate : 115200
    avrdude: prusa_init_external_flash(): MK3 printer emitted incorrect cfm code: `echo: 3.3.1-8`
    avrdude: arduino_open(): Failed to initialize MK3 external flash programming mode

    avrdude done. Thank you.

    ...
    Posted : 20/07/2018 8:12 am
    cindy.h3
    (@cindy-h3)
    Trusted Member

    To get the flash to work in fedora I had to:
    sudo usermod -a -G dialout <username>

    Cheers,
    Jon

    Posted : 21/07/2018 4:48 pm
    gary.t4
    (@gary-t4)
    Eminent Member

    After you setup octoprint in here where is the button located to send sliced file to octoprint ? Thanks Gary

    Posted : 21/07/2018 4:55 pm
    gary.t4
    (@gary-t4)
    Eminent Member

    Hi
    I got the octoprint setup to connect but when I go back to the main screen there is no button to send the file to the printer did I do something wrong ?

    Posted : 21/07/2018 5:18 pm
    michael.p21
    (@michael-p21)
    New Member

    Love seeing all the additional data on my STL after Exporting G-Code. Finally having a n estimated print time is great and pretty spot on. Only wish we could see this info without having to export the g-code. Any way we can get an update so this info will show after slicing?

    ...
    Posted : 21/07/2018 8:38 pm
    bubnikv
    (@bubnikv)
    Member Admin

    > sudo apt-get autoremove modemmanager

    We have requested to blacklist the Prusa3D devices for the modemmanager, it is already in the upstream modemmanager. Now the change need to trickle through the distros.

    ...
    Posted : 21/07/2018 9:17 pm
    bubnikv
    (@bubnikv)
    Member Admin

    > I have noticed that when I re open an AMF file, all of the
    > Print settings,
    > filament settings and
    > Printer settings,
    > on the right of the screen, have been renamed with the AMF filename, and new custom profiles have been created...

    That has been improved in the current alpha, see the change log
    https://github.com/prusa3d/Slic3r/releases/tag/version_1.41.0-alpha2

    ...
    Posted : 21/07/2018 11:15 pm
    bubnikv
    (@bubnikv)
    Member Admin

    > Will you be able to auto save the file gcode filename example- filename-015mm-PET.gcode or filename-005mm-pla.gcode?

    You can use the placeholders and the G-code processing macros in the file export mask

    https://github.com/prusa3d/Slic3r/wiki/Slic3r-placeholders- (a-copy-of-the-mauk.cc-page
    https://github.com/prusa3d/Slic3r/wiki/Slic3r-Prusa-Edition-Macro-Language

    Go to print settings -> Output options, the Output file box, Output filename format. Try

    [input_filename_base]-[layer_height]mm-[filament_type].gcode

    (I am not sure whether filament_type will work, though layer_height should work.

    ...
    Posted : 21/07/2018 11:28 pm
    bubnikv
    (@bubnikv)
    Member Admin

    > I have an issue with Slic3r, that I haven't raised as a bug, as I'm not sure if it's something I'm doing.
    >
    > I had a diagonal flaw appear on a print. The extruder would hesitate for a fraction of a second, and glitch, as though it was catching on something. At first, I thought a piece of PLA had over-extruded, and was catching the nozzle.

    Isn't your problem the same as in https://github.com/prusa3d/Slic3r/issues/831 ?

    There are some numeric issues with the Clipper library Slic3r is based upon, and we need to find a workaround for that. It would help us, if you please attach your data to the issue https://github.com/prusa3d/Slic3r/issues/831 . Thanks.

    ...
    Posted : 21/07/2018 11:34 pm
    Page 7 / 9
    Share:

    Please Login or Register