Notifications
Clear all

New error on startup: External SPI flash W25X20CL...  

  RSS
paul.m27
(@paul-m27)
Honorable Member
New error on startup: External SPI flash W25X20CL...

I just started printing again and made the mistake of updating the firmware on both my mk3s.  My newer/stock mk3s updated just fine.  My older mk3 -> mk3/mmu2 -> mk3s/mmu2s had issues.  

I was able to flash the MMU2 (after realizing it wouldn't work on Mac OS X Catalina and switching computers).  

For the mk3, it successfully wrote and verified something (~250k written/verified, -c wiring on the avrdude-slic3r command line).  It then tried something else (-c arduino? on the avrdude-slic3r command line), but got an error "mk3 printer emitted incorrect start code: `echo: `".  "Failed to initialized MK3 external flash programming mode".  

The printer rebooted and seems fine (support shows new firmware version for both mk3 and mmu2) and it seems to print ok.  However, at every boot I get an error:

"External SPI flash W25X20CL is not responding. Language switch unavailable."

Any clue what is going on?  I'm not going to bother support over the holidays, especially as it seems to be printing fine.  My questions:

- should I be worried?
- is something failing on my board?

Unless I hear otherwise, I'll just make sure my smoke detector is close and continue to print...

Paul

 

Posted : 30/12/2019 10:51 pm
Area51
(@area51)
RE: New error on startup: External SPI flash W25X20CL...

Maybe a factory reset will bring it back: Prusa Factory Reset

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 01/01/2020 4:33 pm
paul.m27
(@paul-m27)
Honorable Member
Topic starter answered:
RE: New error on startup: External SPI flash W25X20CL...
Posted by: @area51

Maybe a factory reset will bring it back: Prusa Factory Reset

I may try that at some point.  However, it’s printing fine from my octopi (single filament, I long ago gave up on the MMU2s) so I’m nervous about changing anything.  I should have learned by now: never update firmware in a working printer unless there is something you need from that firmware update and/or you are fine with losing it...

 

Posted : 02/01/2020 5:03 am
Dave Avery
(@dave-avery)
Honorable Member
RE: New error on startup: External SPI flash W25X20CL...

the external SPI flash is used for multi language support - if you build your own firmware the instructions are to disable multi-language so you don't have to build the language support files that go in the SPI flash

Posted : 03/01/2020 5:55 pm
Share: