Filament runout: Filament jamming in the extruder instead of unloading
 

Filament runout: Filament jamming in the extruder instead of unloading  

  RSS
JDubs
(@james-watriss)
Active Member

I finally got the sensor board shimmed up a bit so that it will recognize when the filament runs out.

As a shakedown test, I ran the batman test print, and just kept cutting the filament about 6" above the extruder.

First time, everything went fine. Printer stopped, told me to unload the filament, filament spat out. No problems.

The next 2 or 3, I had to open up the idler to dig out the filament by hand, using needlenose pliers the first two times. The third time, I just clipped the filament under the idlers, and let the incoming filament shove it through. I resorted to that after discovering that messing around with the extruder mid-print ended up with the extruder getting pushed, which resulted in a layer shift on the print.

Has anyone else had this issue? Doesn't seem like filament runout is going to help much if the extruder jams up anyway, and loses calibration from filament surgery.

Also, is there an easy way to get the machine to run a quick x-calibration after this operation, so I don't completely lose the print if it happens?

 

Posted : 23/10/2020 4:25 pm
louis.j
(@louis-j)
Trusted Member

I had a similar problem. Much frustration.

Removing the sensor and blowing compressed air through all the sensor housing and parts fixed it. It has been working normally for 3 months.

...
Posted : 24/10/2020 12:26 am
JDubs
(@james-watriss)
Active Member

OK, I have continued to tinker with this problem. Here's what I have so far, both a description of the problem for posterity, and an explanation of my work-around in the event that I'm not the only one who has this issue.

Brief summary, because I can't tell if the previous one was clear. And, to be more specific, this is on the MK3S.

-The filament is moving past the ball that actuates the filament sensor, and stops then. So it is still engaged with the gears. When prompted to push the button to unload the old filament, the old filament does NOT  come out. My educated guess, (it's hard to tell, peering through a tiny door into a black interior) is that the filament is hanging up on the inside edge of the hole, above the steel ball.  (The specific part name is Adapter-printer. The sub-assembly with the ball is on the bottom of page 56 of the printed manual, step 7 in chapter 5, "Extruder-body assembly.") Once the filament hits the edge of that hole, it jams, and can't move any further. So, it locks up, and the gears grind the filament.

On previous attempts, I followed the prompts. When the display asked if the filament has been removed successfully, I made the assumption that the machine knows what it's up to, and I answered honestly, and said 'No.' Then I realized I was talking to myself, and used the wheel to select "No" on the screen. After I did that, the machine moved the extruder to the front and center of the machine, and told me to"Please open idler and remove filament manually." I did do, and in doing so the first time, while I was digging the filament out of the confined space with a pair of pliers, I nudged the extruder along the x-axis. That then resulted in a layer shift that corresponded with the distance that the extruder had been moved. So, obviously that's a problem. I don't know how to talk the printer into doing a quick x-axis calibration before it goes back to work, so in the event that this kind of nonsense happens on a real print, I wanted a plan B.

Side note on methodology, I ran a series of the 'batman' test prints, because they're short and sweet, and because I can then throw the batarangs at my kids later. They then take them, and lose them. But in any event, for this test, I kept cutting the filament a few inches above the print, to force a run-out condition. So, thankfully for me, a layer shift on a batarang doesn't hurt anyone.

So, the work-around:

Assuming the filament does NOT eject from the extruder body, which mine simply doesn't do at all anymore...

Step One: When the printer asks you if the unload was successful, you say yes. (Just think of Ghostbusters. When someone asks you if you're a god...) The reasoning is this: The sensor has tripped, but the gears are still engaged with the filament. So it can still be pushed through, if it can't be pushed back out.

Step Two: When the printer asks you to insert new filament, don't. Push the button as if you had, but don't. (I know, I know. Lying is bad. But you've already lied to it once, so you just have to live with your decisions.) When you do, the extruder will drive the remaining chunk of filament through, past the gears. Let it roll.

Step 2.5: (Preparation for step three.) Cut the end of the new filament at 90 degrees.

I know that common wisdom is to cut a bevel on the end when you're inserting new filament. But in this case, that point will deflect off of the remaining filament, and shove to one side, jamming things up again, at which point you'll have to lie some more, go back to the print so you can pause it again, and then unload the jammed, beveled filament. So, as long as you're lying to your machine, continue on your immoral path, and cut a square end on the new filament. It will push solidly on the old filament, and shove it straight through the extruder.

Step 3: When prompted again with the question "Was filament changed successfully," you can go back to being your normal, honest self, and simply answer "Filament not loaded." And then load the new, square-ended filament. And, watch underneath, you should see freshly extruding material. If you don't see that, or don't feel the filament moving through, just try again. It should catch, and push its way through.

At this point, things should have cleared up, and you should be able to let the printer go on doing what it was trying to do before, while you find a way to deal with the aftermath of having brazenly lied to your equipment.

-----

I don't know how they'd rework the design of the Adapter-printer. Maybe adding  a chamfer to the inside of the hole? Adding a small metal tube or top-hat bushing that guides the filament through? I don't know.

I do wish they'd adjust the code around the X-axis on this. If the printer knows you're going to be opening the idler and messing around trying to clear a jam, it should also make the assumption that it needs to do a quick touch-off on left and right stops to double-check the x calibration. I say this with full awareness that I don't know what I'm talking about when it comes to how the x-calibration really works, and I'm assuming that the solution really is that simple. But for me, having seen the layer-shift, and been grateful it was on a print that literally gets tossed anyway, I was glad it wasn't on something I cared about.

I suppose there's something to be said, about how my solution was to lie my way through things when the printer ran into a jam. But then again, if the printer didn't trash my work when I told it the truth, maybe the relationship would be better.

🤐 🙄 

Posted : 24/10/2020 1:17 am
JDubs
(@james-watriss)
Active Member

Afterthought...

One of the possible causes of this issue, I'm down to the last two or three layers on the spool, so the filament may be sprung a bit. I'm thinking about when I first came down to tinker with this tonight, the first time I cut the filament, it spat right out, so maybe hanging down from the spool straightened that segment out a bit, which is why it was able to exit so cleanly.

If it's doing what I think it might be doing, the curly filament might be dragging on one side of the hole on the way in, and curling over, and out of alignment once it's past the hole. As a result, it can't line up with the hole anymore.

On the one hand, that might mean that this issue won't be super-common. On the other hand, if I'm right, it means that I might run into this every time a spool runs out, because that's going to be the curly end that locks up.

 

J

This post was modified 1 month ago by JDubs
Posted : 24/10/2020 1:27 am
Share:

Please Login or Register