Notifications
Clear all

Display gibberish  

  RSS
BobinAtlanta
(@bobinatlanta)
Eminent Member
Display gibberish

Yesterday my display on my Prusa i3 MK3S shows random characters on about a .5 second cycle.  Sometimes it goes to two rows of 20 little dark blocks on a backlit background.  On rare occasions, it gives normal display only to go to the gibberish again.  Octoprint works fine even with nonsense on the screen.  

HELP!  I can not change filament.  

Posted : 25/07/2021 9:59 pm
bobstro
(@bobstro)
Illustrious Member
Check loose cables, contact support via chat

Could just be a loose cable. Look up the assembly manual online for how to check the cables (it's simple). Log on to the online store and contact support via chat. They're very good and should get you sorted out quickly.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 25/07/2021 10:03 pm
BobinAtlanta
(@bobinatlanta)
Eminent Member
Topic starter answered:
Thanks for the suggestion

That is definitely possible.  A few weeks ago i had to change the entire hotted including the thermistor and other cables.  Things are so tight in there, perhaps i wiggled something I shouldn't have.  Will open it up tomorrow.  Will let you know.  Thank you.  

Posted : 26/07/2021 1:56 am
cwbullet
(@cwbullet)
Illustrious Member
Factory reset

You could try a factory reset.  

https://help.prusa3d.com/en/article/factory-reset_2216

--------------------
Chuck H
3D Printer Review Blog...
Posted : 26/07/2021 2:19 am
BobinAtlanta
(@bobinatlanta)
Eminent Member
Topic starter answered:
It worked!

I just opened up the control box and did not remove anything, but rather pressed the ribbon cables to the display extra hard (and often) and it is working perfectly!  Hope it lasts, but i am VERY hopeful.  Thanks for the tip - I will remember to do that if it happens again.  

Posted : 27/07/2021 12:03 am
Share: