XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card
 
Notifications
Clear all

XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card  

  RSS
Jason_A
(@jason_a)
New Member
XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card

I completed the kit build successfully, calibrated the printer successfully, and completed 1st layer calibration successfully, but now I'm trying to print any of the pre-loaded files from the SD card and the printer will not print.

The extruder scrolls to the front right, request I unload the filament (I do that), then it asks me to load the filament (I do that), then the extruder travels to the front left corner, does so motions, then moves back to the front right corner and requests I unload the filament and this cycle repeats over and over without ever printing.  It doesn't matter what file I select on the SD card. It does this for the several I've tried. What is wrong?    Thanks for the help.

Best Answer by Diem:

I suspect your filament sensor...

You can disable the filament sensor, temporarily, from the LCD menu.

Does the printer behave now?  If so go back through the build instructions for the sensor and see if you can spot any slip-ups.

The printer will work perfectly well without the sensor btw, except you must guard against run-outs that will not be detected.

Cheerio,

Posted : 02/07/2021 11:36 pm
Diem
 Diem
(@diem)
Noble Member
RE: XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card

I suspect your filament sensor...

You can disable the filament sensor, temporarily, from the LCD menu.

Does the printer behave now?  If so go back through the build instructions for the sensor and see if you can spot any slip-ups.

The printer will work perfectly well without the sensor btw, except you must guard against run-outs that will not be detected.

Cheerio,

Posted : 03/07/2021 12:21 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card
Posted by: @jason_a

I completed the kit build successfully, calibrated the printer successfully, and completed 1st layer calibration successfully, but now I'm trying to print any of the pre-loaded files from the SD card and the printer will not print.

The extruder scrolls to the front right, request I unload the filament (I do that), then it asks me to load the filament (I do that), then the extruder travels to the front left corner, does so motions, then moves back to the front right corner and requests I unload the filament and this cycle repeats over and over without ever printing.  It doesn't matter what file I select on the SD card. It does this for the several I've tried. What is wrong?    Thanks for the help.

optical Filament Sensor MK3: https://help.prusa3d.com/en/article/filament-sensor-mk3-non-s_2125

IR Filament Sensor MK3S/+: https://help.prusa3d.com/en/article/ir-filament-sensor-calibration-mmu2s_2245

wbr,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 03/07/2021 3:55 pm
Jason_A liked
Jason_A
(@jason_a)
New Member
Topic starter answered:
RE: XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card

@diem

Thanks Diem.  It was a problem with the IR sensor that checks for filament loading. Strange I didn't catch the "sensor failed" message during calibration.  Everything was assembled properly in the extruder and the arm was moving back and forth to block the IR light path when the filament was loaded so the mechanical set-up was correct.

Next I got out my multimeter to check the DC voltage on the IR sensor. No voltage was present so I opened up the EINSY case and unplugged the IR sensor connector from the EINSY board to check voltage there (shutting off power & unplugging the cord in between). That's when I noticed there are two rows of connector pins. Connecting to the hot & ground pins on the bottom row resulted in 5.0 volts DC reading on the multimeter, but the top row (same pins) read 0.0 volts DC so I suspect I had the IR sensor connected to the upper row. 

I went back into the instructions and sure enough it states to connect the IR sensor to the lower row of pins on that orange-outlined connector.  I was getting lazy towards the end of the build and likely just looking at pictures of wiring connectors rather than reading the words for each of the steps so I missed that.

After plugging the IR sensor in the lower row, the filament load step in the calibration was successful and the printer is printing correctly now.  Thanks for the help!

Posted : 03/07/2021 5:37 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: XYZ Calibration & First Layer Cal successful, but i3 MK3S+ won't print a file from SD card

@jason_a

This small extension can make life a little easier:

or Joan's solution:

https://forum.prusaprinters.org/forum/original-prusa-i3-mmu2s-mmu2-user-mods-octoprint-enclosures-nozzles-.../filament-sensor-indicator/paged/4/#post-214072

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 03/07/2021 6:03 pm
Jason_A liked
Share: