X axis lenght error  

  RSS
francescatesei
(@francescatesei)
Active Member

I am experience a new issue on my Prusa. 

Today, after a print failure, the printer has reported these problems:

"Bed leveling failed."

I run a calibration and it has failed it as well,

"some problem encountered, Z-levelingenforced"

then at last it gave me the X axis lenght error. 

Each time I try to calibrate the printer the extruder goes beyond the plate area (see picture).

Has anyone had the same issue before? I run a bed test yesterday, and it was all fine.

Thanks 

 

Posted : 31/07/2020 1:22 pm
peter.m26
(@peter-m26)
Honorable Member

Check your x-axis belt,

if it is too loose or to tight,

if grub screw is loose, not on the flat side,

check also if belt is not rubbing against the sides, move extruder(with power off) left to wright and watch if belt touches the sides,

check wen you move the extruder by hand(with power off), if it moves without sticking somewhere,

check wen all the way to wright and left, if at the backside of extruder, the cables are not hitting the side of the printer.

Every 2(or a little more) rolls of filament you need to put a few drops of on rails, first off course clean the rails, 4x z-axis, 2x y-axis. 2x x-axis.

This post was modified 2 months ago by peter.m26
Posted : 01/08/2020 10:09 am
jerry.s3 liked
francescatesei
(@francescatesei)
Active Member

Thanks Peter, I will try these solutions once I am back at the office. 

Last friday I checked the belt and I moved the extruder with the power off, it was all good. That is why I can't explain why the printer is behaving like this.

I uploaded a video that I took, maybe it will better explain the issue.   

https://forum.prusaprinters.org/wp-content/uploads/2020/08/WhatsApp-Video-2020-08-02-at-10.55.45.mp4

This post was modified 2 months ago by joan.t
Posted : 02/08/2020 12:24 pm
joan.t
(@joantabb)
Veteran Member Moderator

Hi Francesca, 
this problem can occur if the x carriage fails to fully home to the left hand side before starting mesh bed levelling, 

this could be due to a lot of reasons, including faulty  linear bearings, poor lubrication, a faulty idler bearing, overtight belt, overtight idler bearing securing bolt, misplaced bearings in the X axis housing, and over tight rear panel on the X axis

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 02/08/2020 3:15 pm
peter.m26
(@peter-m26)
Honorable Member

The prusa motors for the axis stop if there is to much drag, so there is something wrong.

Posted : 02/08/2020 10:03 pm
francescatesei
(@francescatesei)
Active Member

Thanks all for your help!

At the end I did the PINDA sesor testing, run the Wizard and did the first layer calibration. 

Now it works smoothly 😀 

Posted : 03/08/2020 3:02 pm
regs
 regs
(@regs)
New Member

I am having the same issue.

Printer always worked fine.

Did not use it for a while, wanted to do a print today and I am not able  because I get the x axis length error.

How can you make a PINDA sensor test?

How can I solve, since I did literally nothing since the last print.

Already moved all the parts when printer was turned off, restarted several times, leveled the bed.

When starting a print I get this strange noise (brrrrrr and vibrating belt) on the x axis.

 

Thanks for any help!

 

Posted : 12/08/2020 4:40 pm
francescatesei
(@francescatesei)
Active Member

I am sorry to hear this @regs 

on the ldc screen when you scroll for options, under calibration there should be a PINDA sensor calibration. 

When you do this i suggest you to have the Prusa manual in hand and a flat screwdriver.

you can test the PINDA by placing the flat screwdriver under it. when the 2 surfaces touch each other the red light flashes. that's how I recalibrated the PINDA, then I did frist layer test. 

 

I hope it helps 

Posted : 12/08/2020 4:47 pm
regs
 regs
(@regs)
New Member

Thanks for the instructions.

I finally figured it out, I am a little bit embarrassed 😔 

What I did was cleaning all the rods with a towel, added some of the original lubricant, moved all axis several times 😀 

Posted : 12/08/2020 5:14 pm
Share:

Please Login or Register