[Solved] Unable to Autoload Filament  

  RSS
gmbarton
(@gmbarton)
Active Member

I recently assembled my i3 mk3s printer. Loaded the silver PLA filament and printed the PRUSA sample badge plus a few small parts of my own.

 

Now I want to make a part with PETG. So I heated the nozzle and unloaded the PLA. However, now when I try to load the new filament, nothing happens. I trim the filament end at 45 degrees, then select Autoload. The LCD says "Autoloading filament is active, just press the knob and insert filament". I put in the filament, but nothing happens - extruder gear does not turn. If I press the main control knob again, nothing still happens - it just goes back to the menu where I can select Autoload again.

 

Am I missing something? Is there a different knob I need to press? I try pushing the knob, then inserting filamant, or inserting filament first and then press the knob, but whatever sequence I follow, I am unable to get the extruder gear to turn (so it can pull in the filament).

 

If I select Unload again, I can see the gear turning (to expel the previous filamant which I already removed). But nothing happens when I select Autoload.

 

It seemed to work seamlessly when I initially loaded the PLA. But now on my 2nd filament loading attempt, I can't get it to work.

Posted : 19/03/2020 3:58 am
baezapastor
(@baezapastor)
New Member

I have exactly the same problem!!! I have to load the filament manually: Menu-Configuration-Move axes-Extruder (from -80 to +10) to make sure there are no traces of the previous color. What are we doing wrong? Thank you very much for those who can provide an answer/solution to that issue.

Posted : 20/03/2020 3:31 pm
gmbarton
(@gmbarton)
Active Member

Yes, I have disabled the filament sensor and then do a manual load which is not that much different than automatic filament load.

I found another thread here https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-hardware-firmware-and-software-help/filament-sensor-bug-on-mk3s/#post-200650

I've been commenting on that thread. It appears to be issue(s) with the filament sensor misreading. It could be from the tightness of the screw holding the filament sensor lever, or perhaps needing to shim the tiny sensor board.

I still have not solved it for my situation and hoping that somebody with more experience and expertise will come up with a solution in the other thread.

Posted : 20/03/2020 4:10 pm
nilok
(@nilok)
Estimable Member

Try this:

https://www.prusaprinters.org/prints/25728-prusa-mk3s-ir-sensor-spacer-set

 

Remove the Filament and single screw - then you will see the IR Sensor under the cap.  Power Off the Printer to insert the spacer below the sensor.  The Sensor Menu is under "Support" on the LCD.  It should switch between 0 and 1 when working.

This post was modified 2 months ago 2 times by nilok
Is your printer grinding? Bearings squeaking? Motors smoking?
Step 1) Wash your Steel Sheet
Step 2) Return to Step 1...
Posted : 20/03/2020 4:25 pm
gmbarton liked
bigchevy66
(@bigchevy66)
New Member

@nilok

Thank you, this worked perfectly. I used the .5mm shim.

Posted : 20/03/2020 11:06 pm
gmbarton
(@gmbarton)
Active Member

Thanks nilok!

I was skeptical since I had already tried a 0.5mm spacer which did not solve the problem. After printing this set, I tried several combinations. The 0.5 + 0.2 nearly worked, but was not 100% reliable. Then the 1.0mm was too thick and always showed 0. So I rounded the lower edges and sanded a miniscule amount from the rougher side of the 1.0mm spacer with 600 grit sandpaper. That seemed to do the trick and it is now switching reliably from 0 to 1 as the filament is inserted.

This post was modified 2 months ago by gmbarton
Posted : 21/03/2020 5:43 pm
Bison25
(@bison25)
New Member

Have same Issue - just completed the build this afternoon - already printed the whistle and currently printing the Batman badge.

So I will try the 0.5mm shim as mentioned above - everything else works perfectly other than autoload. Getting the Z-Value correct initially was a pain but now its right its printing like a Charm......how exciting!

 
Posted : 24/03/2020 10:46 pm
Share:

Please Login or Register