Notifications
Clear all

Self test Y axis Length error  

  RSS
Symphy
(@symphy)
New Member
Self test Y axis Length error

Hi, I recently built my MK3 kit and I'm having problems getting it up and running.

When I first started the printer it did not greet me with the wizard, instead it just said it needed calibration. I then did a factory reset to get to the wizard, and went trough the self test, where it failed on the Y axis, with the error Y axis length.
I've contacted support and they are trying to figure out what the problem could be, but it's taking a while, so I thought I would ask for suggestions here.

When I assembled the Y-axis the first time the resistance when moving the bed was more then I expected, and it did not sound smooth, so I made a video:
I've since lubed them, and swapped the bearings and rods around, and it's a lot smoother.

I've tested the bearings individually on the smooth rods now(without the bed frame attached), and found out that the bearings move smoothly on the left rod but not on the right(where there is only one bearing).
I've then tried swapping one of the left bearings with the right one, and I still got the same (still not moving smoothly on right rod), so I would think the right smooth rod is bad?
I made a video showing this:

I've tried running the XYZ calibration (a suggestion by customer support), but it fails on the third calibration point (rear right).
I've made a video that shows the XYZ calibration, where the Y-axis moves to far forward during the third point, and is skipping steps:

Here is a list of things I've tried so far:

  • I've checked that nothing is interfering with the movement of the Y-axis.
  • I've adjusted the position of the motor pulley multiple times, and ensured it is not slipping.
  • I've checked the idler pulley, it moves smoothly.
  • I've tried different belt tensions. At the moment X = 267 and Y = 284. However Y belt is really tight. It's almost like a bass/guitar string (don't know if this is how tight it should be). But customer support told me to tighten it until i reach about 280.
  • I've reassembled the Y-axis multiple times, last time I swapped the positions of the bearings and the rods. This seems to have smoothed the travel of the Y-axis while the belt is detached.
  • I've checked each bearing, and as far as I can see no balls are missing, and I'm 100% sure I did not lose any during assembly and reassembly.
  • I've checked that the bearings are oriented correctly.
  • I've lubed the bearings.
  • I've checked if everything is level.
  • I've swapped the Y-axis stepper motor with the extruder motor.
  • I've ignored the error, and tried the XYZ calibration, where it failed on the third bed marking (rear right).
  • I've tried with a earlier version of the firmware(V3.1.3) and I'm currently on V3.3.0.
  • I'm currently waiting for new bearings, but they wont arrive until next week, so any suggestions for things I could try are welcome.

    Posted : 09/07/2018 11:40 pm
    thrawn86
    (@thrawn86)
    Honorable Member
    Re: Self test Y axis Length error

    well it sounds like you've done your homework...I can't think of anything else but it IS very sensitive during the length checks. I've even had a small bit of blue tape cause it to fail.

    Posted : 10/07/2018 8:05 am
    thomas.l49
    (@thomas-l49)
    Active Member
    Re: Self test Y axis Length error

    Did you figure this out? I am having the same problem

    Posted : 10/08/2018 8:08 am
    JoanTabb
    (@joantabb)
    Moderator
    Re: Self test Y axis Length error

    Good morning Thomas,
    I think this message is in the wrong forum see https://shop.prusa3d.com/forum/assembly-and-first-prints-troubleshooting-f62/x-axis-length-fail-t23459.html

    regards Joan

    I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
    Posted : 10/08/2018 12:58 pm
    Kyle
     Kyle
    (@kyle-3)
    Eminent Member
    Re: Self test Y axis Length error

    Hey OP did you find any solid answers? I'm in the same boat on a new build. My Y fails but my bearings and rods are sliding smooth.

    Posted : 03/09/2018 4:55 pm
    Share: