Prusa I3 Mk3 Kit - First layer calibration issues and uneven printing
 

Prusa I3 Mk3 Kit - First layer calibration issues and uneven printing  

  RSS
darrel.l
(@darrel-l)
New Member

I apologize in advance for the length of this post, but I want to be as detailed as possible.

I’ve been trying to dial in the Z axis adjustment for about 10 days, and I cannot get it right. The printer passes all calibration testes without issue and reports that the axes are perpendicular.

When printing the first layer calibration (Z Offset is .707), there is a noticeable difference in the width of the lines. I measured the width of the upper and lower vertical printed lines with a micrometer, and these are the results in millimeters: Top Left: .45, Top Right: .80, Bottom Left: .53 and Bottom Right: .63.

When printing Jeffjordan’s calibration gcode ( https://shop.prusa3d.com/forum/prusa-i3-kit-building-calibrating-first-print-main-f6/life-adjust-z-my-way-t2981.html ) with the same Z offset, the bottom right of the square has a few raised areas that normally indicate that the nozzle is too low, and in the top left there are gaps between the lines, indicating that the nozzle is too high. Again, no change to the Z offset was made during the print.

I went into the Calibration menu and configured the bed level correct settings to the following: Left -50, Right +50, Front 0, Rear +20 and then recalibrated the printer. This will get the first layer to a printable state after calibration (but not perfect, the printed line width still varies) and I normally can get a *good print after the recalibration, but after the print is done, the first layer will be off again and I have to recalibrate.

(* Good meaning a good completed print. But, for example, the print height of a flat object will differ along the length and width. The larger the print, the greater the variance. I’m not expecting it to be perfect, but I would think it should be closer than what I’m currently getting.)

Here is a list of the things I have tried/reviewed to solve the issue:
• Make sure heat bed is properly mounted
• Make sure Y Axis rods are properly seated and secured
• Adjust PINDA probe height, factory reset and re-calibrate. I’ve done this several times. Right now, the PINDA probe is .9 mm off if the print surface measured with a feeler gauge.
• Clean and oil all of the rods and threaded rods
• Made sure the Z screw covers were not too tight
• Swap the two trapezoidal lead screw nylon nuts between the Z axis motors. When swapped and with the both M3 screws in the nuts as weight, they spun freely all the way to the bottom of the lead screws.
• Tried different firmware versions with a factory reset and calibration after flashing. I’m currently using 3.1.2 RC1. I’ve tried 3.1.1, 3.1.1 RC3, 3.1.1 RC4, 3.1.1 RC5.

As far I can tell, the bed is level and flat. I do not believe that the issue is structural. The right motor does seem a little noisier that the left, but I do not know if that is normal.

This is my first 3D printer, so it may be my inexperience, but I’m at my wits end. I would guess that I either have an issue with the Z Axis motor(s), the PINDA probe or the RAMBo board.

Any suggestions to help me resolve the issue would be greatly appreciated.

Posted : 01/03/2018 11:03 am
thrawn86
(@thrawn86)
Honorable Member

I went through a lot of these same issues, although I was able to see a few sections of the bed that were not level. For me, adhesion was never a problem and prints would eventually turn out okay, but first layer quality suffered drastically and was an issue on thin, flat parts.

ultimately I explored two different options:

1 - Flash the Hyperfine firmware and manually tune all cali points instead of trusting mesh leveling. It works, but its a pain.

2 - Accept the lower first layer quality and attempt to tune it out (more base layers, etc). Also, print with a raft or print with lower layer heights (seems much less prone to rippling).

At this point I think I still prefer manual leveling, but mine is printing quite well finally.

Posted : 01/03/2018 8:19 pm
darrel.l
(@darrel-l)
New Member

Thank you for the response.

I installed the firmware as you recommended and followed the instructions on how to complete the hyperfine calibration. However, it did not solve my issue. Each time the mesh leveling routine occurs, the Z axis offset and bed leveling correction requires adjustment.

Here are the instructions I followed: https://shop.prusa3d.com/forum/prusa-i3-kit-building-calibrating-first-print-main-f6/hyperfine-bed-leveling--t4330-s110.html#p41311

During my first attempt, once I printed a perfect center circle, I continued per the instructions for the rest of the gcode squares. After I dialed in each location, I adjusted the bed level correction. Then, I printed the "All" gcode which prints the center circle and all of the squares. Before this printed, I performed a mesh bed level. After the calibration, the center circle did not print correctly and the "A" square did not adhere to the print bed and the PLA attached itself to the nozzle.

My original Z offset from my first calibration mentioned above was -0.722. I wanted to print several of the center gcode objects without changing any settings to show the issue. I dialed in the center Z offset again and this time it was -0.705. In the picture below, you can see (barely, sorry, the silver PLA is shiny), the first circle printed as close to perfect as I can get. The other three circles were printed a short time later in quick succession, and as you can see, they printed a little different each time.

When you print any of the calibration gcodes, it raises the Z Axis to 100 mm, so I do not think it's the PINDA thermal issue I've read about, although I do think the PINDA probe may be at fault.

Again, any suggestions would be appreciated.

Posted : 07/03/2018 9:23 am
michael.a35
(@michael-a35)
Trusted Member

I’m away on business but brought my printer to kill time. This is a big issue for me as well. I have all settings set to zero except for back which is maxed out at +50 and the print didn't change at all.

Posted : 09/03/2018 10:35 am
aaron.s5
(@aaron-s5)
Noble Member


I’m away on business but brought my printer to kill time. This is a big issue for me as well. I have all settings set to zero except for back which is maxed out at +50 and the print didn't change at all.

Try doing a "Factory Reset" -> "Delete all Data"

Then re-do the XYZ calibration, and the Live Z adjustments.

I had a case where something was corrupted in data, and it made the Live Z not work correctly - I am guessing it was mesh correcting strange.

Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage or loss. If you solve your problem, please post the solution…...
Posted : 10/03/2018 4:37 pm
Crunch
(@crunch)
Estimable Member

It has been discussed here as well as a patch to correct https://shop.prusa3d.com/forum/original-prusa-i3-mk3-f30/1st-layer-problems-in-depth-look-at-software-pinda-t14815.html

The Latest Firmware can be found here https://github.com/prusa3d/Prusa-Firmware/releases
Open Firmware Issues https://github.com/prusa3d/Prusa-Firmware/issues...
Posted : 10/03/2018 8:00 pm
darrel.l
(@darrel-l)
New Member

Art - I saw this yesterday and was about to update this post with that information but you beat me to it.

This exactly describes the issues I am having with my Mk3. I would encourage anyone having similar issues to read the entire post (link below). Hopefully, Prusa will implement the firmware changes quickly.

https://shop.prusa3d.com/forum/original-prusa-i3-mk3-f30/1st-layer-problems-in-depth-look-at-software-pinda-t14815.html

Posted : 11/03/2018 2:18 am
benjamin.g11
(@benjamin-g11)
Active Member

how do we know when the updates are live?

Posted : 04/04/2018 7:27 pm
erlich yuval.v
(@erlich-yuval-v)
Active Member

hey guys,
anyone here fixed that problem? i have the same... left side the print not stucked.. right side just fine...
didn't found the problem... 🙁

Posted : 19/12/2018 10:25 pm
LA 3D Printer Repair
(@la-3d-printer-repair)
Trusted Member


hey guys,
anyone here fixed that problem? i have the same... left side the print not stucked.. right side just fine...
didn't found the problem... 🙁

Obvious answer if things were running ok in the past is to run Calibrate Z to ensure your X-Axis didn't get accidentally moved, the pre-print Calibrate Z will attempt to compensate for a small offset, but it never huts to ensure "squareness" by simply running a Calibrate Z to ram the X to the top to force it straight...

Hope that helps, but you should also make sure you're running a new firmware if you haven't upgraded in a while, lots of improvements in 3.5.1!

Posted : 21/12/2018 12:21 am
erlich yuval.v
(@erlich-yuval-v)
Active Member

Thanks. Somehow this time the bed leveling process helped me. Everything is great 🙂

Posted : 21/12/2018 6:54 am
Share:

Please Login or Register