New MK3S - Staircasing/Y Axis Issue  

New Member

Good Afternoon Everyone!

First time posting. I have a new I3 MK3S, which was ordered as a kit and assembled. After testing everything yesterday, I decided to try my first print and it was a success. However, now that I have tried a longer print (4h and the 2h Buddy print) and both have ended up with a massive staircase effect. Below I will list all the things I have done and tried:

Updated to newest firmware

Checked belt tension (268, 271)

Checked X and Y access motors according to troubleshooting guide (hold with pliers, attempt to move axis, no movement)

Rods are not scratched as they are brand new

Nothing is blocking the movement of the axis

Printer is in Normal mode, not Stealth

Print Speed was set by PrusaSlicer, or whatever was in the gcode for Buddy on the SD card, so whatever the default speed is


The only other issue I'm having is during the preheat, there is an excessive amount of filament that is extruding, though this may be normal. This is only my 2nd 3D printer and my first one was a bit of a "piece" so this is my first quality printer to say the least. Any assistance would be thoroughly appreciated. I'm excited to get this up and running properly. 

Thank you for your time! 


Posted : 17/12/2019 7:09 pm
New Member

[video width="1280" height="720" mp4=""][/video]


Video of operation to see if maybe someone can spot something

Posted : 17/12/2019 7:50 pm
Dave Avery
Honorable Member

check the "crash" counters - if you are getting crashes your Y axis is either binding or the extruder is actually crashing into the print

Posted : 18/12/2019 12:14 am
New Member


I will check this as soon as I get home. I'm assuming crash counters are in the LCD menu?

Posted : 18/12/2019 12:23 am

Please Login or Register