[Solved] MK3S+ PSU does not turn on - first assembly  

  RSS
PT3D_enthusiast
(@pt3d_enthusiast)
New Member

Hello All,

It saddens me that my first post is to immediately ask for help, however, that is what I need 😐 .

I have finished assembly of the MK3S+ and connected it to a power socket to initiate calibrations and nothing started.

Summary of situation:

  • MK3S+ is connected to a working power socket;
  • Power button on the back of the PSU is on;
  • Green LED on the PSU (behind PRUSA cover) is off - never seen it on;
  • LCD screen is off - never seen it turn on;
    • I have seen it flicker on Youtube videos due to movement of base / extruder but I have not been able to replicate this.
  • Fuses on both the PSU and electronics box are OK;
  • I do not have a multimeter - only basic tools available, screwdrivers, etc;

Any insights / tips on this issue would be greatly apreciated!

Thanks for reading.

Posted : 02/01/2021 11:01 pm
Jerry
(@jerry)
Trusted Member

Make sure the plug is all the way in the plug on the psu. Mine a bit hard to get in and I had the same issue. Mine takes a very firm push.

Posted : 02/01/2021 11:36 pm
PT3D_enthusiast
(@pt3d_enthusiast)
New Member
Posted by: @jerry

Make sure the plug is all the way in the plug on the psu. Mine a bit hard to get in and I had the same issue. Mine takes a very firm push.

Thanks for the tip.

I have checked and, unfortunately, this is not the issue in my printer.

I am going to try to connect to support through chat.

Posted : 03/01/2021 4:24 pm
Diem
 Diem
(@diem)
Reputable Member

@pt3d_enthusiast

The psu seems to be OK 'thogh if you can borrow a meter it would be worth checking.

But; basic recheck:

Disconnect from mains power and then go through the connections one by one and check you have them correct.  Some sockets are mechanically similar and some plugs can be inserted upside down...

Hth, Cheerio,

Posted : 03/01/2021 5:46 pm
PT3D_enthusiast
(@pt3d_enthusiast)
New Member

After going through Livechat support we noticed that I had actually inversed all polarities of power cables in the electronics board - I was working with it inversed at the time. 😓 

Thankfully nothing seems to have been damaged by this.

Thanks to everyone that took the time to read this.

Posted : 03/01/2021 6:18 pm
Share:

Please Login or Register