IR Sensor on MK3S not functioning proper  

  RSS
Brankomer
(@brankomer)
Eminent Member

I've installed the MK3S upgrade from Prusa with printed parts, and the autoload and IR sensor is not functioning. After following the instructions on the website, everything was ok, the sensor recognised filament when passing through. The problem is when I put back the C1 part, the sensor systematically goes on "1", whether there is a filament or not. What shall I do?

This topic was modified 2 years ago by Brankomer
Posted : 20/06/2019 1:09 pm
Miguel
(@miguel-6)
Eminent Member

Several of us had the same problem, there are several possible solutions

  • Put a little piece of plastic under one side of the sensor in order to move it a little. If it's already mounted it the easiest option and if it works you don't have to work much
  • Cut a little bit the extruder plastic part. If you have the piece disassembled this is probably the best option
  • Print a new lever or lime a little bit the one you already have

There's two threads with info about it

https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-assembly-and-first-prints-troubleshooting/filament-sensor-ir-problem/

https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-assembly-and-first-prints-troubleshooting/prusa-mk3s-ir-sensor-lever-issue/

Posted : 21/06/2019 10:36 am
Brankomer
(@brankomer)
Eminent Member

Thanks for you answer. I first tried the second solution, but I didnt succeed, then I put a small piece of plastic under the sensor. But I dont think it's normal to have this issue, because I ordered the printed parts for the mk3s upgrade from Prusa. It should not have a problem of dimensional nature as it wasnt printed by me.

Posted : 21/06/2019 2:06 pm
JMAC liked
JMAC
 JMAC
(@jmac-2)
Trusted Member

Thanks for this.  I made the MK3S upgrade, but was never able to get the sensor to properly function.  I just kept it in “Off”.  Tried all the other suggestions with no success, and then used your suggestion of the piece of plastic under sensor, and this allowed proper sensing.  The added part is just under the mounting screw for the sensor board, and results in a partly elevated board positioning.  My parts were self-printed, so perhaps my parts were not accurately printed, but not sure.... 😀 😀 😀 

...
Posted : 22/06/2019 11:29 am
holmes4
(@holmes4)
Estimable Member

My sensor was working fine with the Prusa-supplied extruder printed parts. I then printed a modified one and found that the flag part (the one with the small magnet) hit the top of the sensor board when activated so it could not interrupt the IR. There was a protrusion on top of this piece (original) that I cut a small bit off, and the flag then went in all the way. 

Unfortunately, while it worked fine in testing, once I reassembled the extruder it no longer worked (was always reading 1), so I have more work to do.

Posted : 22/06/2019 9:15 pm
Paul_GD
(@paul_gd)
New Member

I fixed that exact issue with it always reading 1 by simply filing a bit off the lever. When you add the motor it kinda pushed the lever a tiny bit, which can be enough for the sensor to get triggered

Posted : 30/06/2019 4:03 pm
holmes4
(@holmes4)
Estimable Member
Posted by: Paul_GD

I fixed that exact issue with it always reading 1 by simply filing a bit off the lever. When you add the motor it kinda pushed the lever a tiny bit, which can be enough for the sensor to get triggered

Yep - that did the trick! Thanks!

Posted : 05/07/2019 12:46 am
jason.k24
(@jason-k24)
Eminent Member

Wow this thing is a POS, how could they think this assembly was going to work, after reading this post i can def see my machine is doing exactly what others are doing and basically in the on position all of the time because as soon as i put the sensor in, it triggers the autoload preheat. The part def moves freely and I can bounce it back and forth with the ball by inserting some filament but it def doesn't get enough out of the way when filament is removed. I just spent 3 hrs putting this thing back together and I be damned if I am taking it back apart right now to cut some plastic off as a might work solution.  

Posted : 06/07/2019 5:16 pm
--
 --
(@)
Illustrious Member

A few have added 0.2mm shims to force the IR sensor board into an optimum position. With no filament, and watching the LCD, add shims until the sensor shows a 0 to 1 transition, then remove a shim.  Test inserting filament, and it should now work reliably. 

Posted : 06/07/2019 6:57 pm
VictoryRice
(@victoryrice)
New Member

In case others find it helpful, here's what I did to fix my issue. In my case the IR sensor was detecting filament even when there was none.

1. Open extruder assembly by following steps 1 and 2 here: https://help.prusa3d.com/article/43mduc4zdn-ir-sensor-troubleshooting

2. On LCD, go to Support > Sensor info and look at IR value (either 1 or 0)

For me, IR was stuck on 1. So I took a thin file (you could use the kind on a nail clipper if you don't have one) and filed down the bump on the lever shown in the red circle below:

File only a little off at a time, and insert filament to see if you've got it. Bear in mind that reattaching the extruder motor can further push the lever, and the smallest of movements can make a huge difference here. So in your testing, put the motor back on (hold in place firmly, no need to screw it in yet) and test the filament going in, while looking at the IR reading on the LCD.

I actually over-filed it, and the IR sensor then read zero even with filament in. So, I cut a very small square of rigid plastic and super glued it to the face of the lever that contacts the steel ball (indicated by the red arrow above). Think thinner than a credit card, I used plastic from the bag some filament came vacuum sealed in -- such a small thickness made a huge difference here. It now works perfectly.

Basically, the tolerances are very exact here is what I conclude.

 

Posted : 07/11/2019 7:10 pm
You liked
iluvsa
(@iluvsa)
New Member

I recently had issues with this with the IR sensor reading a constant "1" in the Support-Sensor Info menu (in firmware 3.8), whether or not there was filament loaded. Before trying the above, which could be a second option, you could also try backing off the top two screws holding the extruder assembly together on the back of the extruder by the tiniest amount (like 1/4 of a turn). Mine were snugged down so tight that I think it was interfering with the ability of the ball lever to move freely. A way to check the correct tightness is that the extruder door (mine is held by one screw under spring tension, earlier version have two screws) should flap back and forth very easily when not screwed in -if there is resistance in the door swinging those back screws are probably too tight. Just another thing to try if this doesn't work I would move to shaving the lever as detailed above!  

Posted : 22/11/2019 4:47 am
HeneryH
(@heneryh)
Estimable Member

Thank you to whoever point me to this thread.

I had a build error upon initial build where I had a cable install error.

I diagnosing, I took the print head apart per the Disassembly/IR-diagnostic instructions and made sure everything worked and and the IR sensor was properly toggling from 0/1 and back.

After reinstalling everything and realized my filament autoloader didn't work.

I set that aside for a bit.  Just came back and realized the sensor wasn't working 🙁

This thread pointed me to the shim fix.  I took some of that pre-print filament marking strip as a shim.

That worked.

I wish the design was a little more robust here.

Posted : 25/06/2020 3:58 pm
PRINT 09 s.r.o.
(@print-09-s-r-o)
New Member

Mám novou tiskárnu. Složil jsem ji, proběhly všechny testy a kalibrace OK a při prvním tisku chce neustále měnit filament. Podle rád výše jsem se dostal k sektoru IR a ten mi stále ukazuje 0. I když s ním pochybuju ručně, pořád je tam 0. Zapojení obou konektorů je správné. Co může být příčinou? 

Posted : 29/06/2020 6:55 pm
Share:

Please Login or Register