Gap Fills Issue  

  RSS
Rocky79
(@rocky79)
Active Member

Hello,

Does anyone know what settings I should change to fill those gaps?. Or at least make it look better

My settings are below. 

 

# generated by PrusaSlicer 2.3.0+ on 2021-05-07 at 15:33:37 UTC
avoid_crossing_perimeters = 0
avoid_crossing_perimeters_max_detour = 0
bed_custom_model =
bed_custom_texture =
bed_shape = 0x0,250x0,250x210,0x210
bed_temperature = 60
before_layer_gcode = ;BEFORE_LAYER_CHANGE\nG92 E0.0\n;[layer_z]\n\n
between_objects_gcode =
bottom_fill_pattern = monotonic
bottom_solid_layers = 4
bottom_solid_min_thickness = 0.5
bridge_acceleration = 1000
bridge_angle = 0
bridge_fan_speed = 100
bridge_flow_ratio = 0.95
bridge_speed = 30
brim_width = 3
clip_multipart_objects = 1
color_change_gcode = M600
colorprint_heights =
compatible_printers_condition_cummulative = "printer_notes=~/.*PRINTER_VENDOR_PRUSA3D.*/ and printer_notes=~/.*PRINTER_MODEL_MK3.*/ and nozzle_diameter[0]==0.4";"nozzle_diameter[0]!=0.8 and ! (printer_notes=~/.*PRINTER_VENDOR_PRUSA3D.*/ and printer_notes=~/.*PRINTER_MODEL_MK(2.5|3).*/ and single_extruder_multi_material)"
complete_objects = 0
cooling = 1
cooling_tube_length = 5
cooling_tube_retraction = 91.5
default_acceleration = 1000
default_filament_profile = "Prusament PLA"
default_print_profile = 0.15mm QUALITY @MK3
deretract_speed = 0
disable_fan_first_layers = 1
dont_support_bridges = 1
draft_shield = 0
duplicate_distance = 6
elefant_foot_compensation = 0.2
end_filament_gcode = "; Filament-specific end gcode"
end_gcode = G4 ; wait\nM221 S100 ; reset flow\nM900 K0 ; reset LA\n{if print_settings_id=~/.*(DETAIL @MK3|QUALITY @MK3|@0.25 nozzle MK3).*/}M907 E538 ; reset extruder motor current{endif}\nM104 S0 ; turn off temperature\nM140 S0 ; turn off heatbed\nM107 ; turn off fan\n{if max_layer_z < max_print_height}G1 Z{z_offset+min(max_layer_z+30, max_print_height)}{endif} ; Move print head up\nG1 X0 Y200 F3000 ; home X axis\nM84 ; disable motors
ensure_vertical_shell_thickness = 1
external_perimeter_extrusion_width = 0.45
external_perimeter_speed = 25
external_perimeters_first = 0
extra_loading_move = -2
extra_perimeters = 0
extruder_clearance_height = 20
extruder_clearance_radius = 45
extruder_colour = ""
extruder_offset = 0x0
extrusion_axis = E
extrusion_multiplier = 1
extrusion_width = 0.45
fan_always_on = 1
fan_below_layer_time = 100
filament_colour = #FF8000
filament_cooling_final_speed = 3.4
filament_cooling_initial_speed = 2.2
filament_cooling_moves = 4
filament_cost = 24
filament_density = 1.24
filament_deretract_speed = nil
filament_diameter = 1.75
filament_load_time = 0
filament_loading_speed = 28
filament_loading_speed_start = 3
filament_max_volumetric_speed = 15
filament_minimal_purge_on_wipe_tower = 15
filament_notes = ""
filament_ramming_parameters = "120 100 6.6 6.8 7.2 7.6 7.9 8.2 8.7 9.4 9.9 10.0| 0.05 6.6 0.45 6.8 0.95 7.8 1.45 8.3 1.95 9.7 2.45 10 2.95 7.6 3.45 7.6 3.95 7.6 4.45 7.6 4.95 7.6"
filament_retract_before_travel = nil
filament_retract_before_wipe = nil
filament_retract_layer_change = nil
filament_retract_length = nil
filament_retract_lift = nil
filament_retract_lift_above = nil
filament_retract_lift_below = nil
filament_retract_restart_extra = nil
filament_retract_speed = nil
filament_settings_id = "Prusa PLA - First_220-70"
filament_soluble = 0
filament_spool_weight = 230
filament_toolchange_delay = 0
filament_type = PLA
filament_unload_time = 0
filament_unloading_speed = 90
filament_unloading_speed_start = 100
filament_vendor = Made for Prusa
filament_wipe = nil
fill_angle = 45
fill_density = 10%
fill_pattern = gyroid
first_layer_acceleration = 1000
first_layer_bed_temperature = 70
first_layer_extrusion_width = 0.4
first_layer_height = 0.25
first_layer_speed = 20
first_layer_temperature = 220
full_fan_speed_layer = 4
gap_fill_speed = 40
gcode_comments = 0
gcode_flavor = marlin
gcode_label_objects = 1
high_current_on_filament_swap = 0
host_type = octoprint
infill_acceleration = 1000
infill_anchor = 2.5
infill_anchor_max = 12
infill_every_layers = 1
infill_extruder = 1
infill_extrusion_width = 0.45
infill_first = 0
infill_only_where_needed = 0
infill_overlap = 25%
infill_speed = 80
inherits_cummulative = "0.20mm QUALITY @MK3";"Prusa PLA";
interface_shells = 0
ironing = 1
ironing_flowrate = 15%
ironing_spacing = 0.1
ironing_speed = 12
ironing_type = top
layer_gcode = ;AFTER_LAYER_CHANGE\n;[layer_z]
layer_height = 0.2
machine_limits_usage = emit_to_gcode
machine_max_acceleration_e = 5000,5000
machine_max_acceleration_extruding = 1250,1250
machine_max_acceleration_retracting = 1250,1250
machine_max_acceleration_x = 1000,960
machine_max_acceleration_y = 1000,960
machine_max_acceleration_z = 200,200
machine_max_feedrate_e = 120,120
machine_max_feedrate_x = 200,100
machine_max_feedrate_y = 200,100
machine_max_feedrate_z = 12,12
machine_max_jerk_e = 4.5,4.5
machine_max_jerk_x = 8,8
machine_max_jerk_y = 8,8
machine_max_jerk_z = 0.4,0.4
machine_min_extruding_rate = 0,0
machine_min_travel_rate = 0,0
max_fan_speed = 100
max_layer_height = 0.25
max_print_height = 210
max_print_speed = 200
max_volumetric_speed = 0
min_fan_speed = 100
min_layer_height = 0.07
min_print_speed = 15
min_skirt_length = 4
notes =
nozzle_diameter = 0.4
only_retract_when_crossing_perimeters = 0
ooze_prevention = 1
output_filename_format = {input_filename_base}_{layer_height}mm_{filament_type[0]}_{printer_model}_{print_time}.gcode
overhangs = 1
parking_pos_retraction = 92
pause_print_gcode = M601
perimeter_acceleration = 800
perimeter_extruder = 1
perimeter_extrusion_width = 0.45
perimeter_speed = 45
perimeters = 2
physical_printer_settings_id =
post_process =
print_host =
print_settings_id = 0.20mm QUALITY @MK3 - Variable Height
printer_model = MK3
printer_notes = Don't remove the following keywords! These keywords are used in the "compatible printer" condition of the print and filament profiles to link the particular print and filament profiles to this printer profile.\nPRINTER_VENDOR_PRUSA3D\nPRINTER_MODEL_MK3\n
printer_settings_id = Original Prusa i3 MK3
printer_technology = FFF
printer_variant = 0.4
printer_vendor =
printhost_apikey =
printhost_cafile =
raft_layers = 0
remaining_times = 1
resolution = 0
retract_before_travel = 1
retract_before_wipe = 0%
retract_layer_change = 1
retract_length = 0.8
retract_length_toolchange = 4
retract_lift = 0.4
retract_lift_above = 0
retract_lift_below = 209
retract_restart_extra = 0
retract_restart_extra_toolchange = 0
retract_speed = 35
seam_position = nearest
silent_mode = 1
single_extruder_multi_material = 0
single_extruder_multi_material_priming = 0
skirt_distance = 2
skirt_height = 3
skirts = 1
slice_closing_radius = 0.049
slowdown_below_layer_time = 15
small_perimeter_speed = 25
solid_infill_below_area = 0
solid_infill_every_layers = 0
solid_infill_extruder = 1
solid_infill_extrusion_width = 0.45
solid_infill_speed = 80
spiral_vase = 0
standby_temperature_delta = -5
start_filament_gcode = "M900 K{if printer_notes=~/.*PRINTER_MODEL_MINI.*/ and nozzle_diameter[0]==0.6}0.12{elsif printer_notes=~/.*PRINTER_MODEL_MINI.*/ and nozzle_diameter[0]==0.8}0.06{elsif printer_notes=~/.*PRINTER_MODEL_MINI.*/}0.2{elsif nozzle_diameter[0]==0.8}0.01{elsif nozzle_diameter[0]==0.6}0.04{else}0.05{endif} ; Filament gcode LA 1.5\n{if printer_notes=~/.*PRINTER_MODEL_MINI.*/};{elsif printer_notes=~/.*PRINTER_HAS_BOWDEN.*/}M900 K200{elsif nozzle_diameter[0]==0.6}M900 K18{elsif nozzle_diameter[0]==0.8};{else}M900 K30{endif} ; Filament gcode LA 1.0"
start_gcode = M862.3 P "[printer_model]" ; printer model check\nM862.1 P[nozzle_diameter] ; nozzle diameter check\nM115 U3.9.3 ; tell printer latest fw version\nG90 ; use absolute coordinates\nM83 ; extruder relative mode\nM104 S[first_layer_temperature] ; set extruder temp\nM140 S[first_layer_bed_temperature] ; set bed temp\nM190 S[first_layer_bed_temperature] ; wait for bed temp\nM109 S[first_layer_temperature] ; wait for extruder temp\nG28 W ; home all without mesh bed level\nG80 ; mesh bed leveling\nG1 Y-3.0 F1000.0 ; go outside print area\nG92 E0.0\nG1 X60.0 E9.0 F1000.0 ; intro line\nG1 X100.0 E12.5 F1000.0 ; intro line\nG92 E0.0\nM221 S{if layer_height<0.075}100{else}95{endif}\n\n; Don't change E values below. Excessive value can damage the printer.\n{if print_settings_id=~/.*(DETAIL @MK3|QUALITY @MK3).*/}M907 E430 ; set extruder motor current{endif}\n{if print_settings_id=~/.*(SPEED @MK3|DRAFT @MK3).*/}M907 E538 ; set extruder motor current{endif}
support_material = 0
support_material_angle = 0
support_material_auto = 1
support_material_buildplate_only = 0
support_material_contact_distance = 0.1
support_material_enforce_layers = 0
support_material_extruder = 0
support_material_extrusion_width = 0.35
support_material_interface_contact_loops = 0
support_material_interface_extruder = 0
support_material_interface_layers = 2
support_material_interface_spacing = 0.2
support_material_interface_speed = 100%
support_material_pattern = rectilinear
support_material_spacing = 2
support_material_speed = 50
support_material_synchronize_layers = 0
support_material_threshold = 55
support_material_with_sheath = 0
support_material_xy_spacing = 50%
temperature = 210
template_custom_gcode =
thin_walls = 1
threads = 8
thumbnails =
toolchange_gcode =
top_fill_pattern = monotonic
top_infill_extrusion_width = 0.4
top_solid_infill_speed = 40
top_solid_layers = 5
top_solid_min_thickness = 0.7
travel_speed = 180
use_firmware_retraction = 0
use_relative_e_distances = 1
use_volumetric_e = 0
variable_layer_height = 1
wipe = 1
wipe_into_infill = 0
wipe_into_objects = 0
wipe_tower = 1
wipe_tower_bridging = 10
wipe_tower_no_sparse_layers = 0
wipe_tower_rotation_angle = 0
wipe_tower_width = 60
wipe_tower_x = 170
wipe_tower_y = 125
wiping_volumes_extruders = 70,70
wiping_volumes_matrix = 0
xy_size_compensation = 0
z_offset = 0

Posted : 07/05/2021 4:41 pm
Neophyl
(@neophyl)
Famed Member

Why are you posting a list of settings ?  Just save your project from slicer using file>save project and zip it up into an archive and attach it here. That way anyone can open it and slice with exactly the same settings you are using and with the model exactly as you have it. It’s the best way to debug issues. 

Posted : 08/05/2021 12:44 am
--
 --
(@)
Illustrious Member

Line 37.5 is the problem.

j/k ... Neophyl has a point. This isn't a Linux board where 10,000 lines of text is impressive. Save your setup as a project file, .3MF format. Zip the file into an archive. Then drag it to the open forum text box on your browser, the box turns blue to let you upload the file. Zipped files are allowed, bitmaps like jpegs, pngs, but not stl or 3mf, unfortunately.

This post was modified 1 month ago 2 times by --
Posted : 08/05/2021 4:13 am
Rocky79
(@rocky79)
Active Member

Ok, thanks. I wasn’t sure what’s the best way to share.

Here is the project file. Face_Gaps.3mf

Looking forward to your feedback. 

Posted : 08/05/2021 6:52 am
Dan Rogers
(@dan-rogers)
Prominent Member

Was that a picture of your bottom layer?  If it was, to get those gaps closed, you need to lower your Z until all of the bits are smooth and squished together with no lines showing.

 

Posted : 08/05/2021 7:53 am
bobstro liked
Neophyl
(@neophyl)
Famed Member

I'd agree with Dan that its the usual issue with either an improper live z height calibration or your print sheet needs properly cleaning to get rid of all the oils and grease.  From your picture you can see where perimeters on the first layer are sticking out into the hexagon holes or otherwise not adhered to the bed.

While personally I would put your first layer height back to the 0.2 default instead of 0.25 that shouldn't really effect adhesion.  Also put your first layer back to default too, at least until you sort out your bed adhesion.  If you haven't already use the procedure from here to calibrate your first layer
https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-assembly-and-first-prints-troubleshooting/life-adjust-z-my-way/   

I printed your part from the attached 3mf and except for flipping it over to remove the overhanging slope and turning off ironing and it printed out fine on my mk3.  No gaps in the bottom beyond what I would expect.  

A couple of notes on some of your modified settings though -

-Your pla first layer temp is very high.  Put it back to defaults.  This looks like another attempt to get your first layer to stick properly.  More temp can help sometimes but wont fix an underlying problem with live z or oils/greases contaminating your sheet.

-there is zero point in having ooze prevention enabled in your settings as that is for multi extruder setups and so will do nothing for you.

-you might want to reduce your elephants foot compensation down to 0.1 or even 0.  While it might mean you have to remove a slight bit post printing the fact its moving those perimeters in closer to your holes and making the gapfill even thinner might help once you have your basic problem under control.

 

Posted : 08/05/2021 10:59 am
Rocky79
(@rocky79)
Active Member

@dan-rogers

Thanks dan. I will try it out. 

Posted : 08/05/2021 4:20 pm
Rocky79
(@rocky79)
Active Member

@neophyl

Thank you that is very helpful. I will try adjusting the Z height and follow your suggestions.

Btw, I don’t have an issue with adhesion. It sticks well. 

 

Posted : 08/05/2021 4:32 pm
--
 --
(@)
Illustrious Member

A couple of things.

First, why did you set support print speed to 100%  -- I can't see any reason to do that, not is it helpful.

Second - you've set layer 1 width to 0.40 mm - a very bad idea - and again there is no reason to do that and did I say it is a bad idea?

Third - you've set layer 1 height to 0.25 mm - a very very bad idea - and almost guarantees bad prints.

Oh - and fifth - why set infill so low on that part? 10% will cause problems in strength and interlayer infill.

This post was modified 1 month ago 4 times by --
Posted : 08/05/2021 7:06 pm
--
 --
(@)
Illustrious Member

And - the fourth was Ooze prevention only works on printers with multiple extruders - which the Mk3 isn't. 

There are other settings that don't make sense, so I have to ask why you are changing all these settings? What prompted you to deviate from defaults?

 

As for Z-offfset - that looks fine to my eye; the issue others are seeing are due to the height being wrong and under-extrusion caused by the wrong width.

This post was modified 1 month ago by --
Posted : 08/05/2021 7:13 pm
Rocky79
(@rocky79)
Active Member

@tim-2

First Regarding the support speed.

That is the default on my end. I didn’t change it. What should it be? 

Second - you've set layer 1 width to 0.40 mm - a very bad idea

The gap between the first passes were wide on the first layer. Once I changed the layer width, it brought them together. Maybe that’s also related to the Z being not close enough to the bed. 

Third - you've set layer 1 height to 0.25 mm - a very very bad idea

Not really, See attached. Printed with 0.25 layer height and 0.4 layer width. 

why set infill so low on that part? 10% will cause problems in strength and interlayer infill.

I know, these are test prints, the final version will be printed with 15% I even printed down to 5%. 

fourth was Ooze prevention only works on printers with multiple extruders

I didn’t know. I will reset it to default. 

Posted : 08/05/2021 8:11 pm
--
 --
(@)
Illustrious Member

@rocky79

Yep - that is not a good layer one.  You really should use the defaults and you'll save yourself a crap load of pain in the coming weeks and months.

On the other hand, experimenting and learning what doesn't work can also be fun.

Posted : 08/05/2021 10:16 pm
Rocky79
(@rocky79)
Active Member

I went back to default settings and I have adjusted the live Z. It still needs minor adjustment. 

What do you guys think? I still have gaps here and there.

Is there a way to fill those gaps? 

Thanks

Adjusted Layer Height[/caption]

This post was modified 1 month ago 2 times by Rocky79
Posted : 08/05/2021 11:11 pm
--
 --
(@)
Illustrious Member

Simple answer, no. Sharp corners and crevices will almost always have open spots.  By carefully calibrating Linear Advance, and Extrusion Multiplier, you can get closer. But the end point will be overfilled spots and underfilled spots.

Prusa has more to say here:

https://help.prusa3d.com/en/article/linear-advance_2252/

ps: another way to think about it is you are using a round nozzle to fill a square hole, but the filler is not liquid, it's malleable plastic that will never flow into corners.

This post was modified 1 month ago 3 times by --
Posted : 09/05/2021 3:05 am
--
 --
(@)
Illustrious Member

As an aside - the PLA you are using has a pigment that flows around in the melt - sorta like metal dust on water. That makes the bright and dark zones you see that accentuate the extrusions. Other filaments don't have this 'feature' and can make rather nice looking parts that don't highlight FFM/FDM printing foibles.

These are typical no effort prints off my printer. Point and shoot using defaults. The lioness required some hand selection of support points, and clean up (wood fiber filament is messy); the nose cone and vise are pretty much slice/print/done - all are copies of other peoples designs.

This post was modified 1 month ago by --
Posted : 09/05/2021 3:16 am
Ringarn67 liked
Swiss_Cheese
(@swiss_cheese)
Prominent Member

@rocky79 

 

Try this

 

Face_only_Swiss.3mf

 

Good Luck

 

Swiss_Cheese

The Filament Whisperer...
Posted : 09/05/2021 3:54 am
Rocky79
(@rocky79)
Active Member

@tim-2

Nice prints. I am using Prusa Filament. 

Posted : 09/05/2021 4:16 am
Rocky79
(@rocky79)
Active Member

@swiss_cheese

Thanks for the suggestions. I see the changes you made. 

You added top surface ironing. I am only concerned about the first layer, not the top layer. 

I also saw you changed the horizontal minimum shell thickness to 0.6mm. How will this affect the first layer gaps?

Thank you

 

Posted : 09/05/2021 4:21 am
Share:

Please Login or Register