Bed leveling issue (right side higher)  

Page 1 / 2
  RSS
physikal
(@physikal)
New Member

Is it normal to have to use the bed leveling correction under the calibration menu? My right side of my bed is higher than my left, so if I use live z and set it to where the right side isn't over squished, then the left side isn't squished enough.

I have tried re-tightening the bed in the order they recommend in the assembly instructions.
Adjusted the smooth rods on Y axis to see if that would help
Re-ran calibration 10-15x

Everything I have tried doesn't seem to produce any results, so unfortunately I am using the bed level correction settings.

Is there something else I should try?

Posted : 13/08/2018 8:12 pm
curtis.c2
(@curtis-c2)
Honorable Member

any chance you're running octoprint (or usb tethered) and you could give us the G80 output from terminal?

Testing the P.I.N.D.A. probe readings in PronterFace

In the last test, we will check the real values of the P.I.N.D.A. probe readings.
For the sake of consistent measurements, please perform the tests under identical conditions.

Connect the printer according to the USB and Pronterface guide.
Ensure the nozzle is clean and the print surface is clear of any obstructions.
Issue a "G80" command this will start the mesh bed leveling process.
Once the process is complete, send a "G81" command, this will report out the interpolated Z values for a 7 x 7 array that composes the mesh bed.
Repeat the process at least 3 times.
Compare data points for each reported 7 x 7 array.

You want to make sure there are no significant deviations (>0.2) between measurements. Keep in mind that the numbers in the matrix have their pre-defined positions, so always compare the numbers in the same positions.

If you were not able to resolve the problem, then contact our support at info@prusa3d.com (include some photos of the P.I.N.D.A. probe cable), and our team will help you out.

Posted : 14/08/2018 4:27 am
christian.b13
(@christian-b13)
Eminent Member

I have exactly the same issue... and i did bed levelinf with Springs in toder to get the variance down to 0.03-0.05... but everything to the left (past the first line of measurement pints in Y ) is always higher... no matter what are my bed variance...

something is definitely wrong in how the spftware handles this area i think... i got a bed replacement as well as a new carriage ..didnt help...

here are some photos https://imgur.com/a/WCCqdzo

Posted : 15/09/2018 12:06 am
nghia.t
(@nghia-t)
New Member

Hi,
I got exact the same issue, please let me know if you the solution/fix for it.
Thanks!

Posted : 24/11/2018 11:58 pm
chocki
(@chocki)
Prominent Member

I have the same, I have been trying to fix this for days now, multiple calibrations, adjustments using G80 G81, factory resets, even re flashing firmware, but still the same problem, the right side is squished down, in my case front middle and front right are squished the most.
I've even bought a digital dial gauge with a resolution of 0.001mm and ordered some springs and will be levelling the bed with the gauge, not G80 G81, then I will see what the printer says.
It almost seems like it is looking at some sort of compensation look up table, but the table is wrong.
The PINDA appears to be compensating for a non level bed since when I adjust the front right up or down, it compensates, but continues to squish this more than the rest, and it's consistent, I'll give it that!, I just wish I could turn the automatic bed levelling off!.

Normal people believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet....
Posted : 25/11/2018 1:05 am
peter.m26
(@peter-m26)
Honorable Member

Manually with nob, go with z axis to the top, left and wright side should hit top at the same time.
Check if your bed is flat with a flat piece of metal.

Lubricate all axis, check for lose bolts , belts, etc.

Calibration, always with heated bed, 60 or 90 degrees!!!!!
Every steel plate could be different, if you have more then 1.

Then start z calibration.(you could do this more then 1 time, after each time do a 1 layer print , to see if it flat, and that you can compare ),

If this does not work , do xyz calibration. Do a 1 layer print, to compare.
Do a z calibration again, en print a 1 layer print.

I had this fail after printing 24 ours in a day for 3 -4 months, then suddenly 1 layer was not good,
it was maintenance problem, search with google for a plan , which maintenance is needed.
if you print all day long, you need every week to clean rods and put oil on the rods, and every month check bolts, and feel on all parts of printer if something is loose, like the extruder was loose by mine.

Posted : 25/11/2018 1:36 pm
chocki
(@chocki)
Prominent Member

Well, I have rebuilt my printer, checked and lubricated and the bearings slide on the rods, fitted springs under the bed except for the middle where a fixed spacer is used then used a gauge to level the bed and get it level within 0.005mm across the whole bed and when I run G80 G81 I get the following:
-0.06667 -0.07556 -0.07944 -0.07833 -0.07222 -0.06111 -0.04500
-0.06546 -0.06269 -0.05821 -0.05204 -0.04417 -0.03460 -0.02333
-0.05991 -0.05833 -0.05590 -0.05259 -0.04843 -0.04340 -0.03750
-0.05000 -0.06250 -0.07250 -0.08000 -0.08500 -0.08750 -0.08750
-0.03574 -0.07519 -0.10802 -0.13426 -0.15389 -0.16691 -0.17333
-0.01713 -0.09639 -0.16247 -0.21537 -0.25509 -0.28164 -0.29500
0.00583 -0.12611 -0.23583 -0.32333 -0.38861 -0.43167 -0.45250
which if you check shows a really nice flat bed except for the front middle and front right (Front and rear are mirrored, so it looks like the back drops down, but it ids in fact the front).
But the bed is flat, yet the printer thinks it is not so is compensating for this and lowering the head for the front middle and front right.
I think there is something seriously wrong with the firmware.

Normal people believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet....
Posted : 25/11/2018 7:38 pm
Tim
(@tim-m30)
Illustrious Member

On my Mk3, left right X-Axis level is a manual adjustment of the two lead screws, and nothing to do with the bed itself. The software can compensate some by raising the extruder as it moves across the bed, but I'm guessing there is a limit; and doing this adjust in software turns a vertical square surface into a rhombus.

Front rear leveling is a different, more complex issue.

It is always wise to get more than one opinion......
Posted : 25/11/2018 8:39 pm
gregory.s4
(@gregory-s4)
Active Member

Just to pile on, I am having almost the exact same issue. And it is also my front-right primarily.

Posted : 29/11/2018 4:05 pm
EagleRock
(@eaglerock)
Active Member

I'm having the same issues here, i got my bed level to 0.018mm but when i print i have a low spot on the top left corner of the middle of the bed.. would love to understand the issue..

Posted : 30/11/2018 10:59 pm
steffen.f
(@steffen-f)
New Member

Hey there,

I am having the same issue right now with my new i3mk3 kit I assembled on Wednesday.

After trying several adjustments from handbook and co. I reached out to customer support on this today and just wanted to let you know how we approached it. Unfortunately (spoiler alert) we weren't able to figure it out either. This is my first 3D printer and so I had a lot of questions and they were all answered, but nonetheless the issue couldn't be solved.

First off we tried adjusting the bed (right side lower, left higher, front lower etc.) with little effort. I then printed a testfile from thingiverse and ran into the same issues as before: Bed adhesion is excellent in the front left area and not very good on other areas of the bed. During this process I exchanged several photos and a video with the customer service, to make sure I am getting stuff done correctly.

I checked to have my printer leveled out with a spirit leveler (adding cardboard under the left feet until it was "perfect") to rule out this might be the issue - didn't help. I then rechecked if the y-carriage is sliding nicely when not attached to the motor/belt - which it did (could do better, but it slides well enough).

To sum things up here's what I'll do before reaching out to customer support again (unless someone here posts a better approach). This is what customer support recommends (I know the first one is a pain):
- Check Frame assembly again (measure rectangles, crookedness of any assembled part and screw tightly against a perfectly flat surface)
- Check Y-Carriage in disassembled and assembled state (crookedness? Tension of screws etc.)
- Check Heatbed for crookedness and correct assembly again

- Do a factory reset
- Flash Firmware with older 3.4.1 (I updated to 3.5.0 after initially firing up the machine).

So I guess it would be interesting to know what firmwares you guys use and if any of you had a wobbling during assembling of the frame (mine was not more than 1mm or so, but my desk might not be a perfectly flat surface so I'll give that one a try, even if it means disassembling all of the electronics.)

If you guys have any other recommendations or a solution I'll happily approach it differently. Since chocki seems to do this with a lot more science to it, I just hope it's a firmware thingy and they can solve it software-ish, somehow. Fingers crossed!

But since this seems to address several users by now, I am sure a fix will be found. Last resort for me would be to return the machine and reorder another, assemble that and hope for it to be "perfect" (I mean at least I have to be able to print at all!!) 😀

Cheers people,
Steffen

Posted : 01/12/2018 6:34 pm
jan.k137
(@jan-k137)
New Member

Hey all!

I recieved my Mk3 kit yesterday and immediately started the buliding process. I must say everything went quite smoothly. I followed the instructions religiously and only used the tools that came with the kit etc.
Getting the bloody Nylon filament in the hole cost me some nerves, but i survived.

Just, i had exactly the problem you described. After a couple calibrations, the right front side was reliably higher (extremely good adhesion) than the rest of the bed (barely sticking to the bed)

I did the simple thing and it seems to work: I sanded down the spacers between carriage and heated bed

I used 320 grit sandpaper, and sanded down the spacers were the bed was to high. It takes a lot of time and i used a digital caliper to make sure i don't sand too much in one pass.

My spacers were 5.5 mm and some i had to sand down to 5.25 mm. I did it with a lot of iterations and at least 10 Z-Axis calibrations to check the progress and make sure I'm going in the right direction.

Now the adhesion looks good and i think I'll actually keep the printer. The silence and the removable/heated bed are a great upgrade to my trusty ultimaker original ;D

Hope this helps! Happy printing!

Posted : 06/12/2018 9:35 pm
Tim
(@tim-m30)
Illustrious Member

Bed twist, Y-Axis rods not parallel, Z-Axis not perpendicular to Y-Axis, and X-Axis not parallel to the bed are all symptoms of an inexpensive printer frame. Add the fact the PINDA can't measure the left side of the bed, and calibration isn't done for that area (according to G81 output)... well, pretty clear the problems can stack up.

In my attempts to master this, I'm almost convinced the firmware depends on things being out of square and flexed for it to work properly.

It is always wise to get more than one opinion......
Posted : 07/12/2018 9:16 am
guy.k2
(@guy-k2)
Noble Member

I would recheck both the y-axis rods and the x-axis. The standard instructions may leave you out of perpendicular and non-parallel.
There is slop in the mounts that can leave you about 0.2 mm out of alignment in any axis.

WITH POWER OFF!!!

Y-axis Rod Alignment (with head bed installed)
1. Check Y is perpendicular to X
Lower Z to bring print head near to heat bed. Looks straight down from above the x-rods. Move Y to bring one of the printed x-axis lines into visual alignment with the x-rods. Move your HEAD a little back and forth on Y axis. This should make the x-rods visually occult the printed line. Both the left and right ends of the printed lines should occult the same amount if the Y axis is correctly perpendicular to x rods.

If Y is not perpendicular, loosen all four Y rod holders, but don't take out the screws completely.
Move the LEFT side Y-rod's front and back ends to bring the head bed's printed line into perfect parallel to the x-rods.
Tighten down the LEFT side Y-rod holders (front and back), but leave the right side y-rod holders loose.

2. Make Y-rod spacing identical at both front and back. You will need a caliper to do this accurately.
With the left side Y-rod mounts secured and right side mounts loose, move the Y-carriage back and forth (slowly) to begin aligning the rods. Move the carriage all the way FORWARD and press down CENTER of the carriage with about two pounds force as up tighten the front right Y-rod holder.

Move carriage backwards just far enough to reach the front end of the y-rods. Measure the distance between the y-rods with your caliper. Lock caliper distance.

Move carriage all the way forward. Then use caliper to set rear y-rod spacing to exactly the same and tighten the rear right y-rod holder.

At this point your y-rods should be parallel with each other and perpendicular to the x-rods. Recheck and repeat until you get this right.

X-Axis - Get X-rods level with print bedl
Move print head to left end of bed. Manually turn both left and right z-screws to get nozzle height one thickness of paper above left end bed.
Move print head to right end of bed. Be cautious not to dig nozzle into bed as you do so. Rotate ONLY the right z-screw to make nozzle one thickness of paper above right end of bed. Your x-rods should now be parallel to head bed.

Loosen and retighten left and right Z-screw T-Nut bolts to neutralize tension.

This should leave you with pretty square physical build.

Power up and repeat wizard calibration.

Posted : 12/12/2018 1:13 am
cody.h5
(@cody-h5)
Active Member

I would like to follow up on this and see if anyone can report back a solution. I too have the exact same issue. I printed fine from July till October. Didn't touch my printer until Thanksgiving weekend and did firmware updates. Now when I print the bottom right corner, (front right, closest when ur looking) is now closer to the nozzle than the top left is. I never moved my printer and have physically gone through every screw to check for anything being loose. I contacted support and included images and they replied with it looks good from what I see but you need to lower live Z. I cannot lower my Z otherwise the front right will be smooshed into oblivion just so the top left could be correct.

I replied back to support clarifying this since nothing appears to be loose or off and calibration tests all pass fine. The reply I got was "just to inform you there is a bed level correction feature in the calibration menu." ... Very not our problem type of response. Granted it is the holidays and he could have taken time away from family to actually send that reply which is actually nice. I was just expecting more support and looking here I see all these other people who seem to have the same issue. It's really weird we all have it in the same spot.

So I am looking to see if you guys managed some better support or found your own solution.

I am going to setup octoprint and I found some plugins to help give me bed level numbers so I can try to make sense of what's going on.

Posted : 28/12/2018 8:03 pm
cody.h5
(@cody-h5)
Active Member

So I got Octoprint up and running with the Prusa MeshMap and every bed level check reports different outputs. I don't even know how it can be that inconsistent. I don't know if it's related as well but my machine has an electrical current sound that emits out of the power supply and the controller box that is just ridiculously loud. It used to just click constantly as it heated the build plate, but that went away in the last firmware update, and now along with this bed level issue I have the electrical current noise. It sounds like flowing water through a pipe and is hard to capture on camera because it sounds like ambient static noise.

Here are 3 outputs performed back to back and all results came out different

Recv: Measured points:
Recv: 0.17667 0.19556 0.17889 0.12667 0.03889 -0.08444 -0.24333
Recv: 0.19907 0.18737 0.14533 0.07296 -0.02973 -0.16276 -0.32611
Recv: 0.21130 0.17456 0.11159 0.02241 -0.09300 -0.23464 -0.40250
Recv: 0.21333 0.15713 0.07769 -0.02500 -0.15093 -0.30009 -0.47250
Recv: 0.20519 0.13508 0.04360 -0.06926 -0.20350 -0.35912 -0.53611
Recv: 0.18685 0.10842 0.00934 -0.11037 -0.25072 -0.41171 -0.59333
Recv: 0.15833 0.07713 -0.02509 -0.14833 -0.29259 -0.45787 -0.64417

Recv: Measured points:
Recv: 0.18583 0.20130 0.18185 0.12750 0.03824 -0.08593 -0.24500
Recv: 0.20565 0.19306 0.15049 0.07796 -0.02454 -0.15701 -0.31944
Recv: 0.21537 0.18009 0.11836 0.03019 -0.08444 -0.22552 -0.39306
Recv: 0.21500 0.16241 0.08546 -0.01583 -0.14148 -0.29148 -0.46583
Recv: 0.20454 0.14000 0.05179 -0.06009 -0.19565 -0.35488 -0.53778
Recv: 0.18398 0.11287 0.01735 -0.10259 -0.24694 -0.41571 -0.60889
Recv: 0.15333 0.08102 -0.01787 -0.14333 -0.29537 -0.47398 -0.67917

Recv: Measured points:
Recv: 0.20167 0.22778 0.21472 0.16250 0.07111 -0.05944 -0.22917
Recv: 0.20815 0.21575 0.18662 0.12074 0.01813 -0.12122 -0.29731
Recv: 0.20593 0.19624 0.15211 0.07352 -0.03953 -0.18703 -0.36898
Recv: 0.19500 0.16926 0.11120 0.02083 -0.10185 -0.25685 -0.44417
Recv: 0.17537 0.13479 0.06390 -0.03731 -0.16885 -0.33070 -0.52287
Recv: 0.14704 0.09285 0.01020 -0.10093 -0.24051 -0.40857 -0.60509
Recv: 0.11000 0.04343 -0.04991 -0.17000 -0.31685 -0.49046 -0.69083

The final one had a total bed variance of .919 mm

Posted : 30/12/2018 4:19 am
F0x06
(@f0x06)
New Member

Exactly the same issues here, built my kit 1 month ago, managed to have an acceptable first layer, but issues on front and right.

Posted : 30/12/2018 7:25 pm
zbross
(@zbross)
New Member

I can chime in that I've had similar issues. I started my own thread with all of the things I've tried at https://shop.prusa3d.com/forum/assembly-and-first-prints-troubleshooting-f62/bed-leveling-tried-everything--t26849.html .

Posted : 31/12/2018 12:54 am
cody.h5
(@cody-h5)
Active Member

I have spent the last couple days trying to get it working. Support seems to be silent, hopefully it's just because of the Holidays. I have octopi running with Prusa Mesh Leveling and have run probably 50 different permutations. The advanced bed level correction still doesn't get me in range. I can go -50 on the left and 50 on the right which in theory should bring the left up and lower the right, except report still comes out to .977 bed level variance. I took the right sides smooth rod mounts under the bed off and filed them down, so in theory this should drop that side of the bed and yet still doesn't help. After doing this though, I felt I may have screwed myself because I was physically changing the pieces and if it ends up being some firmware/miscalculation or something then I would have a harder time getting it to go back the other direction now. So I decided not to sand anymore off, and instead used some shims to raise the rail on the left side. Combining the decrease on the right, and the increase on the left, ontop of the advanced bed level correction, still gives the same variance ranges. I don't know if it's because the pinda probe and it doesn't really matter for the bed, since the math would come from the prob detecting the surface and adjusting for it, but seems like many people have the issue in the same spot. Really wish I could get a response from support other than to try live Z adjusts. I am at a loss now and it's very frustrating. Kind of a very expensive paper weight unless I wanted to show off crappy prints that i can make. I have about 30 of changes terminal exports saved and the heatmaps. Just not sure if I should keep heading down the road of modifying pieces which so far seems like a waste of time and could potentially cause bigger issues on the long term.

Posted : 31/12/2018 1:32 am
Tim
(@tim-m30)
Illustrious Member

I just came across this issue myself. A filament sensor crash dumped a bunch of saved constants and the automatic bed leveling would go through the motions but not do any correction when printing. Recovery required a full recalibration (running the Wizard). Things seem to be working again. If I see the issue again I will reset the EINSY to factory.

FW v3.5.1 - filament sensor detects no filament (full roll of Prusa White installed) ... pressing the button at the "reheat and continue" prompt resulted in a rather interesting full crash of the FW - garbage on the display, etc. Power cycle to recover from the crash, but printer was no longer operating as expected. Recal seems to have fixed it, but I'm dubious.

It is always wise to get more than one opinion......
Posted : 31/12/2018 5:41 pm
Page 1 / 2
Share:

Please Login or Register