nach Hardwareupgrade unterschiedliche Hardwareerkennung / Kalibrierung in Abhängigkeit mit MMU2/ohne
 
Notifications
Clear all

nach Hardwareupgrade unterschiedliche Hardwareerkennung / Kalibrierung in Abhängigkeit mit MMU2/ohne  

  RSS
Eisi
 Eisi
(@eisi)
New Member
nach Hardwareupgrade unterschiedliche Hardwareerkennung / Kalibrierung in Abhängigkeit mit MMU2/ohne

Hi,

ich habe meinem I3 einen IR Filamentsensor upgrade auf aktuelle 4.1 rev spendiert und eine Super Pinda, Firmware ist die aktuellste.

Nun ist mir folgendes Verhalten aufgefallen in Abhängigkeit ob MMU2 angeschlossen ist oder nicht nach factory reset.

- MMU2 nicht angeschlossen: IR Sensor wird als 4.1 rev erkannt.

-MMU2 nicht angeschlossen: IR Sensor wird als 0.3 oder älter erkannt.

Nach der Feststellung habe ich einen factory resett durchgeführt und den Assistenten ohne MMU2 gestartet.

Kalibrierung etc. inkl. first Layer war mit MMU2 durchgeführt.

Also in der Runde ohne MMU2 der XYZ Kalibrierung keine großartige Beachtung geschenkt und der Kollege fährt so tief, dass er mit der Düse das Bett trifft.

Wie kann das sein, dass der Drucker je nach MMU2 Anschluss einen unterschiedlichen Sensor erkennt?

Und wie kann das sein, dass es Differenzen in der XYZ Kalibrierung gibt, obwohl hardware zwischen den Durchgängen unberührt?

 

Grüße

 

Posted : 19/07/2021 5:58 pm
JustMe3D
(@justme3d)
Estimable Member
Antwort

Firmware der MMU2 hast Du auch aktualisiert? Wenn die so alt ist, daß sie den Sensor noch gar nicht kennt......

I try to give answers to the best of my ability, but I am not a 3D printing pro by any means, and anything you do you do at your own risk....
Posted : 19/07/2021 6:43 pm
karl-herbert
(@karl-herbert)
Illustrious Member
nach Hardwareupgrade unterschiedliche Hardwareerkennung / Kalibrierung in Abhängigkeit mit MMU2/ohne

 

Posted by: @eisi

Hi,

ich habe meinem I3 einen IR Filamentsensor upgrade auf aktuelle 4.1 rev spendiert und eine Super Pinda, Firmware ist die aktuellste.

Nun ist mir folgendes Verhalten aufgefallen in Abhängigkeit ob MMU2 angeschlossen ist oder nicht nach factory reset.

- MMU2 nicht angeschlossen: IR Sensor wird als 4.1 rev erkannt.

-MMU2 nicht angeschlossen: IR Sensor wird als 0.3 oder älter erkannt.

Nach der Feststellung habe ich einen factory resett durchgeführt und den Assistenten ohne MMU2 gestartet.

Kalibrierung etc. inkl. first Layer war mit MMU2 durchgeführt.

Also in der Runde ohne MMU2 der XYZ Kalibrierung keine großartige Beachtung geschenkt und der Kollege fährt so tief, dass er mit der Düse das Bett trifft.

Wie kann das sein, dass der Drucker je nach MMU2 Anschluss einen unterschiedlichen Sensor erkennt?

Und wie kann das sein, dass es Differenzen in der XYZ Kalibrierung gibt, obwohl hardware zwischen den Durchgängen unberührt?

 

Grüße

 

...und was Du noch beachten solltest: Es besteht ein Unterschied in der FW vom MK3 zum MK3S. Wenn Du einen IR-Sensor (keinen optischen) verbaut hast, solltest Du den Drucker und die MMU2 auf die S Version upgraden.

IR-Sensor

https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-general-discussion-announcements-and-releases/original-prusa-i3-mk3s-vs-mk3-important-links/

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 19/07/2021 6:50 pm
Eisi
 Eisi
(@eisi)
New Member
Topic starter answered:
Passend

Passt alles SW-technisch. Ich war ja vorher auch auf stand mk3s sorry war vielleicht schlecht ausgedrückt.

Mich packte nur jetzt in der Elternzeit der Reiz zu basteln als Maschinenbau Ing. Arbeitsentzug quasi 😆 

 

IR sensor vor Update ältere Revision, angezeigt als rev 0.3 oder älter. Welche genau müsste ich jetzt das gute Stück raus kramen und gucken.

Alte Rev war mit mmu2 oder ohne kein unterschied logischerweise. Erkennung als 0.3 oder älter, da Funktionsweise bei älteren Revisionen ja identisch (Spannungszustände je nach Zustand)

Bauteil upgrade 1: IR auf aktuelle Revision 0.41. Wird ohne mmu2 korrekt erkannt. Mit mmu2 wird er als 0.3 o.ä. erkannt. Der Drucker lädt allerdings auch kein filament zum Checken der Schaltzustände 🤔 .

Vorher pinda v2 aktualisiert auf SPINDA. 

SPINDA am Drucker korrekt justiert mit selbstgedruckter Lehre.

Achskalibrierung lief ohne Probleme. First layer Z Kalibrierung für Prusa Smooth PEI bei 0,972mm für perfektes erstes layer. (IR war seit ner Woche verbaut und korrekt erkannt (auch ohne mmu2 im System die IR Kalibrierung durchgeführt)

Nach upgrade zu SPINDA dachte ich mir dann doch mal nen factory reset machen, falls die Erkennung nicht on the Fly passiert.

Reset mit mmu2 wieder Erkennung IR 0.3 o.ä.

Mmu2 abgeklemmt factoryreset, IR Erkennung mit händischer Auslösung beim Selbsttest korrekt auf 0.41.

Jedoch fährt der Drucker bei Achskalibrierung plötzlich ins Heatbed, irritierender Weise.

Software ist auf beiden korrekt und aktuell. Mmu2 1.0.6 und Drucker auf mks 3.10

Grüße

Posted : 19/07/2021 7:33 pm
Share: