Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler
 
Notifications
Clear all

Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler  

  RSS
Bu66as
(@bu66as)
Eminent Member
Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

Hallo, da ich über die Suche keine Passende Lösung gefunden habe frage ich hier noch mal an, da auch Prusa selber mir aktuell nur einen Kostenpflichtigen Support anbietet, wo ich denn MK3s mit MMU2s einschicken muss und dann wieder einen Kostenvoranschlag bekomme und ich dann entscheiden kann ob oder ob nicht, dazu kommen noch die Versandkosten hin und zurück.

Dazu muss ich Erwähnen das das Board schon mal getauscht wurde und der Drucker von jetzt auf nachher schon mal diesen Fehler Zeigte ohne mein zutun.

Ich suche jetzt eine Lösung wie ich denn W25X20CL SPI-Flash wieder zum Leben erwecken kann!

Eventuell mit einem Arduino per ISP-Connection oder vielleicht direkt Flash des Chips, nur dazu suche ich gerade Hinweise, Tips, Erfahrungen oder der gleichen. Ich denke das ich nicht der einzige mit diesem Problem bin und das der ein oder andere do schon so seine Erfahrungen gemacht hat und vielleicht auch mit Erfolg!

Ich danke euch schon mal für eure Hilfe!

MBG

Posted : 27/06/2021 10:19 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler
Posted by: @bu66as

Hallo, da ich über die Suche keine Passende Lösung gefunden habe frage ich hier noch mal an, da auch Prusa selber mir aktuell nur einen Kostenpflichtigen Support anbietet, wo ich denn MK3s mit MMU2s einschicken muss und dann wieder einen Kostenvoranschlag bekomme und ich dann entscheiden kann ob oder ob nicht, dazu kommen noch die Versandkosten hin und zurück.

Dazu muss ich Erwähnen das das Board schon mal getauscht wurde und der Drucker von jetzt auf nachher schon mal diesen Fehler Zeigte ohne mein zutun.

Ich suche jetzt eine Lösung wie ich denn W25X20CL SPI-Flash wieder zum Leben erwecken kann!

Eventuell mit einem Arduino per ISP-Connection oder vielleicht direkt Flash des Chips, nur dazu suche ich gerade Hinweise, Tips, Erfahrungen oder der gleichen. Ich denke das ich nicht der einzige mit diesem Problem bin und das der ein oder andere do schon so seine Erfahrungen gemacht hat und vielleicht auch mit Erfolg!

Ich danke euch schon mal für eure Hilfe!

MBG

Servus,

welche Board Revision hast Du? Ist der Flash Speicher intern verbaut oder zusätzlich aufgesteckt? Die Rev.10.a Boards haben eine zusätzlichen Steckplatz dafür vorgesehen (LCD). Ab 1.1a ist dieser 2Mb Speicher auf dem Einsy verbaut.

Falls Du schon über die 1.1a verfügst, würde ich mal alle LCD relevanten Leitungen, Steckplätze überprüfen. Wenn dies alles in Ordnung ist, könntest Du noch versuchen die deutsche FW zu flashen (ohne Multilanguage). Vorher evtl. einen Factory Reset durchführen.

Gutes Gelingen,

Schöne Grüße,

Karl

 

 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 1:43 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler
Posted by: @karl-herbert
Posted by: @bu66as

Hallo, da ich über die Suche keine Passende Lösung gefunden habe frage ich hier noch mal an, da auch Prusa selber mir aktuell nur einen Kostenpflichtigen Support anbietet, wo ich denn MK3s mit MMU2s einschicken muss und dann wieder einen Kostenvoranschlag bekomme und ich dann entscheiden kann ob oder ob nicht, dazu kommen noch die Versandkosten hin und zurück.

Dazu muss ich Erwähnen das das Board schon mal getauscht wurde und der Drucker von jetzt auf nachher schon mal diesen Fehler Zeigte ohne mein zutun.

Ich suche jetzt eine Lösung wie ich denn W25X20CL SPI-Flash wieder zum Leben erwecken kann!

Eventuell mit einem Arduino per ISP-Connection oder vielleicht direkt Flash des Chips, nur dazu suche ich gerade Hinweise, Tips, Erfahrungen oder der gleichen. Ich denke das ich nicht der einzige mit diesem Problem bin und das der ein oder andere do schon so seine Erfahrungen gemacht hat und vielleicht auch mit Erfolg!

Ich danke euch schon mal für eure Hilfe!

MBG

Servus,

welche Board Revision hast Du? Ist der Flash Speicher intern verbaut oder zusätzlich aufgesteckt? Die Rev.10.a Boards haben eine zusätzlichen Steckplatz dafür vorgesehen (LCD). Ab 1.1a ist dieser 2Mb Speicher auf dem Einsy verbaut.

Falls Du schon über die 1.1a verfügst, würde ich mal alle LCD relevanten Leitungen, Steckplätze überprüfen. Wenn dies alles in Ordnung ist, könntest Du noch versuchen die deutsche FW zu flashen (ohne Multilanguage). Vorher evtl. einen Factory Reset durchführen.

Gutes Gelingen,

Schöne Grüße,

Karl

 

 

Hallo Karl,

leider kann ich es dir nicht sagen, da wo normaleiweise die Version stehen sollte ist nur ein kleiner Code mit dem ich nix anfangen kann, das Board ist jetzt aktuell ein halbes Jahr verbaut und der Drucker insgesamt ca. 1 Jahr alt.

Die LCD Verkabelung habe ich schon untersucht und auch damals auf verdacht erneuert, ich denke nicht das es daran liegt, auch jetzt nicht, da alles fest drinnen sitzt so wie es soll!

Wie bekomme ich eine FW ohne Multilanguage, nur mit Deutsch auf denn Drucker und was Passiert mit dem SPI-Flash?

Ich danke dir für die Tipps und weitere Hilfe!

MBG Micha

Posted : 27/06/2021 2:14 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

Welche Version brauchst Du (MK3 V3.10.0)?

Ich könnte Dir eine Deutsche FW.hex compilieren und dann könntest Du mal testen.

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 3:31 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

Ich stell Dir mal die aktuellste FW 3.10.0 für den MK3 rein. die gezippte Datei enthält die Multilang. und die deutsche Firmware hex Datei. Versuch es mal mit der etwas kleineren deutschen Version:

MK3-FW-3_10_0

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 4:12 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Ja genau die MK3s+ V3.10.0 ist aktuell auf dem Drucker drauf und hat dann zwischen dem Druck Wechsel diesen Fehler wieder einmal gebracht und nun ständig, alles wie Prusa Support gesagt schon gemacht und getan aber ohne Erfolg!

Es nervt mich richtig ab, das so ein teurer Drucker ohne ein zu tun einfach einen Fehler wirft und dieser nicht wieder gelöst werden kann ohne das Board zu tauschen oder denn Drucker einzuschicken auf Kosten der Kunden!

Es wäre super von dir wenn du mir eine Firmware compilieren könntest, habe es gerade selber schon versucht, aber scheitere irgendwie immer am compilieren der Sprachen!

Gruß Micha

Posted : 27/06/2021 4:13 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

Danke, war wohl ein wenig zu langsam!

Wenn der Aktuelle Druck fertig ist, hoffe diesmal das er durchläuft dann werde ich das gleich mal ausprobieren!

This post was modified 3 months ago by Bu66as
Posted : 27/06/2021 4:17 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

Achtung! Es besteht ein erheblicher Unterschied zwischen der MK3 und MK3S/+ Firmware.

Ich habe Dir die MK3 (nicht MK3S+) Variante compiliert und reingestellt. Falls Du die MK3S+ (ohne MMU2S) benötigst, kann ich das gerne auch noch machen.

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 4:31 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

Hier noch die MK3S/+ Variante: MK3S-FW-3_10_0

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 4:47 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Könntest du mir vielleicht erklären wie man so eine DE HEX herstellt, das mit der Normalen HEX Datei bekomme ich alles schon hin, nur das nicht wenn ich EN gegen DE ersetzen will dann geht nichts mehr?

Gruß Micha

Posted : 27/06/2021 4:51 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

Ich mache solche Sachen grundsätzlich mit meinem Linux Laptop. Du musst im Prinzip "nur" die passende *.h aus dem varainzs Ordner selektieren, als Configuration_prusa.h in den Firmwareordner kopieren und dieser Anleitung folgen:

https://github.com/prusa3d/Prusa-Firmware (BUILD Linux). Das Prozedere lässt sich natürlich auch auf einem Windows System durchführen.

Wie gesagt, ich verwende für alle Arbeiten rund um den Drucker, Octoprint, Arduino und Raspberry meinen handlichen Linux Laptop (Ubuntu 20.10 - Groovy Gorilla).

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 5:05 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Die Seite habe ich schon sehr gut durch, habe es unter Windows, sowie unter Debian 10 und 11 am laufen!

Nur das mit denn Sprachen wollte nicht so wie ich will, aber das mit der Datei aus dem Ordner variants und dann im Firmwareordner in Configuration_prusa.h umbennen ist mir neu und werde ich definitiv ausprobieren, aber nicht mehr heute. Da ich morgen wieder bei Zeiten raus muss, werde ich das am Nachmittag alles Ausprobieren und Testen und danach Berichten.

Bis dahin danke ich Ihnen Schon mal und wünsche noch einen schönen restlichen Sontag Abend.

Beste Grüße Micha

Posted : 27/06/2021 5:44 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

Danke - wünsche natürlich auch noch einen schönen Sonntag Abend und gutes Gelingen beim Experimentieren!

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/06/2021 6:04 pm
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Hallo, sorry das ich erst jetzt wieder schreibe!

Mir ist beim Testen das PTFE am Extruder Verstopft und beim zerlegen dann noch die Heizpatrone die Kabel abgebrochen!

Prusa kann natürlich keinen Ersatz liefern, nur ganze Baugruppe, daraufhin habe ich jetzt mir eine 60 Watt Heizpatrone Bestellt wo ich das Kabel trennen kann!

Wenn es da ist werde ich weiter mit der Firmware testen und dann berichten!

MBG Micha

Posted : 06/07/2021 8:27 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

E3D Heizpatronen und weiteres E3D Zubehör sind vielerorts erhältlich, das musst Du nicht bei Prusa kaufen. 60 Watt könnten grenzwertig sein. Ich drucke PEEK (bis 410 Grad C.) mit einer 50 Watt Patrone (vernickelter Kupferblock, Titan Heatbreak, Hartmetalldüse).

Viel Spass beim Experimentieren 👍

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 06/07/2021 9:29 am
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Ich habe dazu auch gleich folgendes dazu geordert:

  1. Bi-Metall Heatbreak
  2. Kupferblock Vernickelt
  3. 2x MKS-MOSFET, einmal für Bed und einmal für Hotend

Was ich noch machen will ist ein PT-100 zu integrieren!

Da Prusa ja jetzt keinen Support mehr geben will ohne was dafür zu bekommen, wo ich dachte das ich 2 Jahre Gewährleistung habe, kann ich denn Drucker jetzt auch richtig Modifizieren wie ich das möchte!

Posted : 06/07/2021 11:36 am
Bu66as
(@bu66as)
Eminent Member
Topic starter answered:
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@karl-herbert

Hi Karl, mein Drucker läuft seit einer Stunde wieder, bin gerade dabei denn First Layer zu kalibrieren und bin mit der 60 Watt Heizpatrone aktuell zufrieden, da jetzt Heizbed und Hotend nicht mehr über das Board direkt laufen, sondern extern über ein MOSFET laufen habe ich auch keine bedenken mit denn 60 Watt Leistung, was mich noch aktuell Stört ist das das Heizbed so lange braucht bis es auf Temperatur ist.

Ich bin jetzt am überlegen nicht noch eine Heizmatte Zusätzlich unter das Heizbed zu kleben um da mehr Power zu haben, habe aber hier i Forum bisher nicht wirklich was brauchbares darüber gefunden, nur das es einen Bedbooster geben soll, aber auch über diesen habe ich bisher nur gelesen aber den Thread nicht gefunden!

Die Firmware werden ich wenn ich morgen dazu komme dann noch mal angehen und dir dann darüber berichten!

MBG Micha

Posted : 09/07/2021 1:15 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Externer SPI-Flash W25X20CL/xFLASH antwortet nicht - Fehler

@bu66as

Wie lief das mit dem FW compilieren? Läuft das nun so wie es sollte?

Der "bedboost" ist eine Entwicklung von Holger, welche ich mir nachgebaut habe. Dies habe ich allerdings nur gemacht um damit PEEK drucken zu können. Veröffentlicht ist dieser Mod nicht, da man einiges zu tun hat (zusätzliches 5V/75W Netzteil, kleine Platine/Relaisschaltung zum zu- und abschalten anfertigen, neue Leitungen verlegen, Einsy modifizieren....). Das Aufheizen auf 150 Grad C. (obersts Limit) dauert damit ca. 8-9 Minuten.

Eine zusätzliche Heizmatte anzubringen - meinst Du damit diese Silikonheizmatten? Dafür würdest Du eine zusätzliche Steuerung benötigen und der Thermistor müsste auch neu kalibriert werden. Die Haftung bzw. Stärke der Magnete könnte evtl. nachlassen.

Mit ist niemand bekannt der das beim MK3 in dieser Form umgesetzt hätte.

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 09/07/2021 2:59 pm
Share: