OctoPrint - tipy a problémy  

Page 4 / 6
  RSS
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Cauky vsem. Nezkousel uz nekdo novejsi RPi ? Zero se mi zda hodne pomaly, hlavne start. Dival jsem se jak to maji reseny u jinych tiskaren a bez problemu pouzivaji verze 3, 4, nebo treba Orange apod. Propojeny do tiskarny to maji pres USB, klasicky LAN pres UTP a napajeni zdrojem 5V ze zasuvky. Zkusil bych to, ale netusim jak a jestli vubec si to bude rozumet s Prusou a pokud to nepojede, tak pro to nebudu mit vyuziti. Dik.

Posted : 08/08/2019 1:20 pm
jakub.michal
(@jakub-michal)
Active Member

Zdravím všechny. Koupil jsem tiskárnu od kamaráda. Je to i3 MK3s. Měl to připravené na octoprint. Rozhodl jsem se to rozchodit, ale... Zkoušel jsem jít (několikrát) podle návodu https://help.prusa3d.com/article/Loz15FAgEk-octo-print-raspberry-pi-zero-w?code=400&failed=1&reason=Multilingual+is+not+enabled+on+this+account#how_to_install_raspberry_pi_zero_w_to_your_mk3

Ale výsledek je vždy stejný. Dostanu se do fáze, kdy se octoprint snaží spojit s tiskárnou a vyhodí chybu, že nemůže najít správný baud rate. Má někdo nějaký nápad?

Posted : 11/08/2019 1:33 pm
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Cauky. Nestahuj original Octoprint, ale upraveny Prusaprint.zip . Dale je dulezite editovat textovy soubor s SSID a Password (octopi-wpa-supplicant.txt). Tam davej pozor na hastagy, ty musis smazat a taky jaky mas zabezpeceni site WPA, WEP,... Jine figle tam nejsou. Horsi je zprovoznit to vzdalene. Nikde jsem nenasel "funkcni" postup jak to udelat bez verejne IP. Zadne virtualni adresy, nebo DNS apod nefunguji. Jedine, co se mi povedlo, bylo totalni zacykleni routeru a jeho reset. Jeste ze jsem si predem udelal zalohu nastaveni...

Dale jsem prisel na to, ze jakmile se pokusim nainstalovat jakykoliv plugin do raspberry, tak po vypnuti tiskarny zmizi. Je to jedna velka zahada a uz mi po tydnu laborovani dochazi trpelivost. Teoreticky mi jde pouze o sledovani tisku. Ovladat to nepotrebuji, protoze stejne nez se nahraje soubor k tisku, musí se rucne spustit ohrev trysky a bedu, jinak bude hlava jezdit po desce a nic z ni nepoleze. To taky nikde neni napsany...

Nebylo by vubec spatny, kdyby to prusovic tym dotahl do konce, ale toho se asi nedockame.

Posted : 15/08/2019 6:45 pm
jakub.michal
(@jakub-michal)
Active Member

Díky za reakci.

Teď jsem to zkusil nainstalovat a výsledek...

Unhandled communication error

There was an unhandled error while talking to the printer. Due to that OctoPrint disconnected. Error: No more baudrates to test, and no suitable baudrate found.
Posted : 15/08/2019 9:29 pm
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Tak to zkusime z druhe strany. Kdyz se pripojis k routeru, vidis v Client List, ze je octopi pripojena? Pokud ne, vloz sem ten soubor s konfiguraci pripojeni k netu. Dale kdyz zapnes tiskarnu, blika/sviti kontrolka na Pi? Pokud ne, vyndej ji a pripoj na obyc 1A nabijecku od telefonu abys zjistil funkcnost. Davej pozor na ktery konektor to pripojis. Je u nej napsano PWR (tusim, ze je to ten krajni). Pak se zase podivej do routeru, jestli ji tam uvidis. Pokud se ti to venku z tiskarny k siti pripoji, tak zkus zkontrolovat spravnost zapojeni a propajeni GPIO konektoru na Pi. Hlavne jejich pozici (musi byt vsazene az od druhe rady!!!).

Dale mozna hloupa otazka, ale povolil jsi v menu tiskarny RPi na ON ?

Posted : 16/08/2019 6:30 am
jakub.michal
(@jakub-michal)
Active Member

Jo do wifi ji dostanu bez problémů. Přes Putty jsem i nastavoval věci v PI. To všechno je v pohodě. Bohužel když se snažím připojit s Octo/Průša printem k tiskárně, nemůže najít spravnou komunikační rychlost (tvrdí). Konektor jsem zkoušel přepájet, ale pořád stejný. Port mám zapnutý. Když tisknu a zkusím se připojit, zastaví se tisk, ale tiskárna nic nehlásí...

Trápím se už snad 3 týdny a nic

Posted : 16/08/2019 9:32 am
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Ja pouzivam primo webovou aplikaci Octoprint. Nahore zadás IP tiskárny a melo by ti najet prihlaseni. Tam se sice nejaky hodnoty nastavuji, ale melo by to jet v defaultu, respektive nic jsem nemenil. Co konkretne pres putty nastavujes?

Jeste me napadlo, zkus natvrdo pridelit v routeru IP adresu tiskarny, aby se ti nemenila. Nejlepe tu, kterou si Pi samo vygeneruje. Je to boj, ostatne jako s jakymkoliv jinym open source. Nez se to vyladi, trva to. A az se to podela, tak clovek zapomene, jak to vlastne nastavil a vsechno zacne znovu. 🤣 

Posted : 16/08/2019 10:01 am
jakub.michal
(@jakub-michal)
Active Member

Octoprint dám v pohodě, připojím, otevřu, nastavím... Tady není problém. Ale octoprint s tiskárnou nee...

Posted : 17/08/2019 2:17 pm
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Ted tomu nerozumim. Co zadavas kdyz spoustit Octoprint? IP adresu na ktery se ti hlasi Pi, nebo jen octopi.local? Na LCD tiskarny se ti ukaze IP adresa? Protoze pokud ano a dostanes se na octoprint pres IP adresu RPi, tak je jasny, ze tiskarna s Pi komunikuje. V Octoprintu zkontroluj jestli mas nastaveno na serial portu /dev/ttyAMA0 a na baudrate 115200. A hned pod tim by mel byt profil tve tiskarny (ja mam Prusa MK3S), ten se vytvari pri prvnim spusteni/registraci Octorpintu.

Posted : 17/08/2019 5:01 pm
matou.b
(@matou-b)
Active Member

Co jsem pochopil, nejde mu propojit octoprint a tiskárnu. Já měl stejný problém, ale u mě pomohlo to přepájet. 

Jakub-michal

Můžeš udělat foto celé desky a toho co ti to ukazuje?

Posted : 17/08/2019 5:48 pm
jakub.michal
(@jakub-michal)
Active Member

Posted : 17/08/2019 8:15 pm
jakub.michal
(@jakub-michal)
Active Member

Sice se to poskládalo v opačném pořadí, ale... Na routeru vidím adresu octopi. Mám ji fix. Local nefunguje. Otevře se a dám connect. Snaží se najít baudrate a výsledek je chyba... Ještě něco? 

Posted : 17/08/2019 8:17 pm
matou.b
(@matou-b)
Active Member

Jak říkám, měl jsem úplně stejný problém, ale vyřešilo to pořádné přepájení všech konektrů, povolení přímo v nastavení a od té doby šlape jako hodinky. :/ 

Možná zkusit ještě jednou pořádně dopájet, nebo zkusit aktualizaci systému OctoPrint. 

Posted : 17/08/2019 9:15 pm
Bouri
(@bouri)
Trusted Member

Nejsem si jist, zda je nastavení ZeroW podobné jako u RPi3 nebo zda jsi ho už nedělal, či je vůbec potřeba (v aktuální chvíli jsem mimo tiskárnu) - včera jsem řešil u RPi3 nekomunikující UART (prakticky stejný problém, jako u tebe, jen na úplně jiném projektu) a tam byl problém, že v config.txt (na SD kartě sektor BOOT, který je viditelný ve Windows) chybělo "dtoverlay=pi3-disable-bt", tedy deaktivování Bluetooth modulu a tím se pro uživatele uvolnil UART na GPIO konektoru.

Posted : 20/08/2019 7:01 am
jakub.michal
(@jakub-michal)
Active Member

Tak ani to...

Originál je tam

dtoverlay=pi3-miniuart-bt
Connecting to: /dev/ttyAMA0Changing monitoring state from "Offline" to "Opening serial port"Connected to: Serial<id=0xb04b9950, open=True>(port='/dev/ttyAMA0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitorChanging monitoring state from "Opening serial port" to "Connecting"There was a timeout while trying to connect to the printerChanging monitoring state from "Connecting" to "Offline"Connection closed, closing down monitor
Posted : 20/08/2019 7:59 pm
Bouri
(@bouri)
Trusted Member

Ano, "dtoverlay=pi3-miniuart-bt" tam má být.

Máte kdyžtak fotky, jak vypadá Vaše RPi ZeroW i s připájeným hřebínkem a jak je nasazen v desce elektroniky?

Posted : 20/08/2019 8:56 pm
Pavel Riedl
(@pavel-riedl)
Trusted Member

Mám takového tucha, že jsem v menu tiskárny nastavoval nějakou položku co souvisí s Octopi... jak budu doma, mrknu se.

Prasa i3 MK3S, Closed box, Fusion 360, PrusaSlicer, OctoPrint - Raspberry Pi 3 Model B+, Windoows 10...
Posted : 02/09/2019 7:38 am
jakub.michal
(@jakub-michal)
Active Member

Tak já už jsem to vyřešil. Špatně zapájené piny... :$ 

Po opravě se to hned chytlo a už tisknu rovnou ze Sliceru...

Každopádně díky za pomoc...

Posted : 03/09/2019 8:05 pm
Zdenda-ZN
(@zdenda-zn)
Estimable Member

Tak to je dulezity. Nicmene kdyby nekdo mel zajem, prodavam svuj RPi Zero W. Je mesic stary. Nevyhovuje mi to a vlastne jsem to prestal uplne pouzivat, protoze se na to nejsem schopny dostat zvenku (nemam verejnou IP a zadny jiny zpusob se mi nepovedlo rozchodit). Vic do SZ.

Posted : 04/09/2019 9:00 am
Robot
(@robot)
Active Member

Zdravím, bojuju s autoconnectem po startu tiskárny / octoprint serveru. Po bootu MK3S a tím pádem bootu RPI Zero se Octoprint nikdy nepřipojí k tiskárně automaticky. Pokaždé to skončí Timeoutem. Pokud, ale kliknu na connect tak se ihned připojí a pak už to jede normálně. Dokonce po restartu OctoServeru se to už připojí samo (pokud nedošlo k restartu tiskárny), ale k prvnímu spojení po zapnutí tiskárny ke spojení nedojde nikdy.

Mám tam Octoprint od Prusi. Zkoušel jsem i origo Octoprint, stejné chování. Zkoušel jsem prodlužovat timeouty, bez úspěchu.

Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Posted : 24/09/2019 9:03 am
Page 4 / 6
Share:

Please Login or Register