Notifications
Clear all

Nejde zkalibrovat osu Z  

  RSS
vladimir.s11
(@vladimir-s11)
Estimable Member
Nejde zkalibrovat osu Z

Tiskárna MK 3 má najeto cca 450 hod bez potíží a problémů. Instaloval jsem nový firmware 3.1.2. Po instalaci FW selftest selhal, špatný senzor filamentu. Ale bez senzoru filamentu jsem dál mohl tisknout. V záruce jsem od Průši dostal nový senzor a po jeho namontování je vše v pořádku. Opakoval jsem tedy i všechny testy a ty prošly. Ale při zahájení tisku se při testování podložky PINDA zastavila v poloze 3 s hláškou"Kalibrace Z selhala. Senzor nesepnul. Znečištěna tryska? Čekám na reset.

Pátral jsem, testoval, kontroloval konektory, kabely a hledal. Vynechávám podrobnosti a počet pokusů. Zjistil jsem následující: Problém je markantní při testu Kalibrace XYZ. Bod 1 PINDA sjede k podložce a testuje jak má, bod 2 sice testuje, ale nesjede k podložce, bod 3 přejede bez testování, bod 4 testuje jen lehce. Tváří se, že test projel v pořádku. Provedu pro kontrolu Mesh bed leveling a body 1,2, 4,5, 7,8 otestuje normálně. Extruder sjede k podložce zaklepe se a jede dál Tak jak to dělá vždy. Ale pozor. u bodů 3,6,9, tedy pravá strana, k podložce nesjede, drží se ve výšce cca 1 cm.
Nevím jak dál? Dělá to na mě dojem, že v této poslední řadě osa Z nedostane pokyn sjet dolů k podložce. A když chci tisknout tak při najetí na bod 3 zůstane PINDA vysoko a jeví se jí to, jako když je tryska zanesená a nemůže kvůli výtoku dojet dolů tak aby našla podložku. Následek: hláška "Kalibrace Z selhala. Senzor nesepnul. Znečištěna tryska? Čekám na reset." Vstanu a jdu si uvařit kávu. Nemám co dělat.

Posted : 07/03/2018 10:21 pm
312_Steev
(@312_steev)
Active Member
Re: Nejde zkalibrovat osu Z

Ahoj,
Zkusil bych znovu nainstalovat firmware 3.1.2.
Pokud nepomůže, vrátil bych poslední funkční firmware.
Další krok technická podpora.

...
Posted : 08/03/2018 7:50 am
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

Teď jsem to udělal i s resetem na tovární konfiguraci. Právě dělám popis problému, pošlu to k průšům s žádostí aby mě poslali starou verzi FW. Ona už na webu není. Příčina je jasná, už v kalibraci XYZ systém nepošle PINDU dolů a ta toho po čase nechá. Vpravo bod 1,4 ji dolů pouští a vlevo bod 2,3 ji nepouští.

Posted : 08/03/2018 10:27 am
miroslav.h4
(@miroslav-h4)
Reputable Member
Re: Nejde zkalibrovat osu Z

Všechny verze FW (i ty starší) by měly být k dispozici na Githubu.

Posted : 08/03/2018 10:39 am
jiři.h16
(@jiri-h16)
Eminent Member
Re: Nejde zkalibrovat osu Z

https://github.com/prusa3d/Prusa-Firmware/releases

Posted : 08/03/2018 10:57 am
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

Vyměnil jsem FW za předchozí verzi 3.1.1 a nepomohlo to. Takže se jedná buď o problém v HW nebo v SW. HW jsem prošel co jsem mohl a nic jsem nenašel. Musí tam být něco co způsobí, že když je extruder vpravo tak motory osy Z nedostávají signál k pohybu dolů. A oba. Kdyby to bylo jen u jednoho tak by se osa X měla začít klopit.

Posted : 08/03/2018 4:55 pm
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

Vyměnil jsem FW za předchozí verzi 3.1.1 a nepomohlo to. Takže se jedná buď o problém v HW nebo v SW. HW jsem prošel co jsem mohl a nic jsem nenašel. Musí tam být něco co způsobí, že když je extruder vlevo tak motory osy Z nedostávají signál k pohybu dolů. A oba. Kdyby to bylo jen u jednoho tak by se osa X měla začít klopit.

Posted : 08/03/2018 4:55 pm
miroslav.h4
(@miroslav-h4)
Reputable Member
Re: Nejde zkalibrovat osu Z

A co takhle zkontrolovat funkci PINDy? PINDA musí celou dobu svítit a zhasnout až těsně nad podložkou (kalibračním bodem). Já měl podobný problém a dělal to zlomený kablík PINDY.

Posted : 09/03/2018 9:14 am
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

PINDA svítí po celou dobu. Jakmile se přiblíží k podložce a indikuje ji tak začne blikat. Problém je v tom, že při testu XYZ když najede najede nad kalibrační bod 1 a 4 kličkuje sem tam a svítí. Hlavně ale začne pomaloučku klesat až kalibrační bod najde. To potom začne blikat. A data si asi zapíše do kalibrační mapy. Poté zajede nad kalibrační bod 2, chová se stejně, ale nezačne sjíždět dolů a tedy kalibrační bod nenajde. Až ji to přestane po delší době bavit přejede nad bod3. A předtím si tato další špatná data - že je vysoko - asi napíše do kalibrační mapy. Nad bodem 3 se zdrží jen krátce, nesjíždí a špatná data šup do mapy. Končí nad bodem 4 tam je to stejné jako u bodu 1, sjede dolů a začne blikat. Takto špatně zkalibrovaná podložka se asi jeví jako příliš šikmá, rozdíl v poloze osy Z mezi 1,4 a 2,3 je cca 1 cm. Pak přijde kalibrace první vrstvy tak body 1,2 projdou v pohodě. PINDA sjede dolů, zaklepe, zabliká a jede dál. U bodu 3 se hned zastaví a hlásí, že je znečištěná tryska. Přeloženo, zjistí že je příliš vysoko a že PINDA nenajde bod. A konec, šmytec. Po celou dobu do této chvíle všechny testy po skončení hlásí, že prošly v pořádku.
Problém je evidentně v kalibraci XYZ a špatném zmapování roviny podložka. Nepomohlo ani vrácení předchozího FW a tak hledám závadu nejdřív HW. Někde je něco co způsobí, že řídící deska, když je PINDA na pravé straně podložky, nedá ose Z pokyn ke klesání. Ta to nepozná a blbě zmapuje souřadnice bodu 2 a 4. Bez dokumentace to nezměřím, mohu jen hledat pokus - omyl. Někde je něco co přeruší signálovou cestu. Bude to nejspíš někde před řízením krokových motorů osy Z. Kdyby to bylo za nimi tak by asi jeden motor jel a to bych poznal. Kdyby to byla PINDA tak by vpravo přestala svítit. Chtělo by to začít proměřením PINDY když je vpravo. Ale jak?

Teď si dám na inspiraci ruma a budu hledat dál. Naštěstí jsem důchodce 74 let a místo toho abych si bez práce užíval důchodu mám před sebou tuto detektivku a dost času.
Tak ještě poslední pokus co jsem dělal. Najel jsem osou Z dolů, a PINDOU jsem jezdil vpravo-vlevo, nahoru - dolů. Při tom jsem dával pod PINDU kovový předmět a pořád se chovala správně. Po přiblížení kovu vždy zhasla. Tak to na poruchu kabelů PINDY nevypadá. Jdu hledat dál.

Ale musím poděkovat servisní podpoře Průši za radu a ochotu. V pondělí se stavím u nich a tam se na to podívají. Stejnou ochotu jsem zažil, když mě zkolaboval senzor filamentu. Ptal jsem se co s tím a hned mě poslali novou.

Posted : 09/03/2018 10:54 am
Pavel Riedl
(@pavel-riedl)
Trusted Member
Re: Nejde zkalibrovat osu Z

Úplná detektivka, hlavně napište, jak to dopadlo. Mě ještě MK3 neposlali a čtením si krátím čas, ale tak mi trochu trne, jestli to zvládnu.

Prasa i3 MK3S, Closed box, Fusion 360, PrusaSlicer, OctoPrint - Raspberry Pi 3 Model B+, Windoows 10...
Posted : 09/03/2018 8:33 pm
312_Steev
(@312_steev)
Active Member
Re: Nejde zkalibrovat osu Z

když pošleš tiskárnu na home pozici a přejedeš s osou X na pravou stranu, je stejná vzdálenost trysky od podložky?

...
Posted : 10/03/2018 8:36 am
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

To jsem zkoušel. Pošlu tiskárnu do home. Tiskárna Nastavím pojezd osy Z. Sjedu o jeden krok dolů a sonda zhasne, vrátím se o jeden dílek nahoru sonda se rozsvítí. Tento test udělám po celé ploše podložky se stejným výsledkem. To znamená, že sonda je po celé ploše stejně daleko od podložky. Dnes jsem nahrál FW 3.1.3 a stejný výsledek. Když je sonda zcela vpravo tak neposílá řídící signál impuls a ta ji nepošle o krok dolů.
Taky jsem zkoušel pod sondu dát kousek kovu a reaguje na něj ve všech polohách nad podložkou. Vypadá to jako by sonda kov chytela, zareagovala, na když je na pravé straně tak nepošle signál do řídící jednotky, ta neví a nedá pokyn krokovým motorům k poklesu osy Z. Jsem domluven u Průšů a v pondělí tiskárnu dovezu na test k nim.

Posted : 10/03/2018 1:02 pm
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

To jsem zkoušel. Pošlu tiskárnu do home. Tiskárna Nastavím pojezd osy Z. Sjedu o jeden krok dolů a sonda zhasne, vrátím se o jeden dílek nahoru sonda se rozsvítí. Tento test udělám po celé ploše podložky se stejným výsledkem. To znamená, že sonda je po celé ploše stejně daleko od podložky. Dnes jsem nahrál FW 3.1.3 a stejný výsledek. Když je sonda zcela vpravo tak neposílá řídící signál impuls a ta ji nepošle o krok dolů.
Taky jsem zkoušel pod sondu dát kousek kovu a reaguje na něj ve všech polohách nad podložkou. Vypadá to jako by sonda kov chytela, zareagovala, na když je na pravé straně tak nepošle signál do řídící jednotky, ta neví a nedá pokyn krokovým motorům k poklesu osy Z. Jsem domluven u Průšů a v pondělí tiskárnu dovezu na test k nim.

Posted : 10/03/2018 1:03 pm
vladimir.s11
(@vladimir-s11)
Estimable Member
Topic starter answered:
Re: Nejde zkalibrovat osu Z

VYŘEŠENO!!!! Byl to zlomený signálový vodič od PINDY. Napájení bylo v pořádku a proto PINDA svítila a blikala. Ale když byla zcela vpravo neposílala signál.
Musím poděkovat servisu u Průšů. Během minut našli závadu a za půl hodiny jsem odjížděl s novou PINDOU a provedenou kalibrací. DĚKUJI

Škoda jen, že mě horká linka nenavedla na indikátor stavu os X, Y, Z. Tam se to hned ukázalo, je to v menu.

Posted : 13/03/2018 2:51 pm
Share: