I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?
 
Notifications
Clear all

I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?  

  RSS
Spooner
(@spooner-2)
Active Member
I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?

Hallo zusammen , ich bin seit heute glücklicher Teil der Prusa Community und schon der erste post...

Ich habe heute meinen Drucker fertiggestellt und schon von der SD gedruck ... alles erste Sahne!

Aber beim Versuch den Drucker mit Octopie auf meinem Rpi (4) zu verbinden bricht die Verbindung nach ca 5 Sekunden ab. Das Setup läuft stabil mit meinem Anycubic i3 mega. Auch beim Versuch der connection mit Promterface kommen nur Sinnfreie Hieroglyphen bei der Verbindung zustande. ALso ein Print via USB ist mir leider noch nicht gelungen. 

Am liebsten wäre mir den USB in den Pie zu stecken Ohne grosses Kabel Gedöns ...

Was gibt es da zu wissen? oder besser was muss ich tun das der MK3 über den Pie läuft? 

ganz lieben Dank für die Infos schonmal .. 👍 

Spooner 

Best Answer by karl-herbert:

Posted by: @spooner-2

Hallo zusammen , ich bin seit heute glücklicher Teil der Prusa Community und schon der erste post...

Ich habe heute meinen Drucker fertiggestellt und schon von der SD gedruck ... alles erste Sahne!

Aber beim Versuch den Drucker mit Octopie auf meinem Rpi (4) zu verbinden bricht die Verbindung nach ca 5 Sekunden ab. Das Setup läuft stabil mit meinem Anycubic i3 mega. Auch beim Versuch der connection mit Promterface kommen nur Sinnfreie Hieroglyphen bei der Verbindung zustande. ALso ein Print via USB ist mir leider noch nicht gelungen. 

Am liebsten wäre mir den USB in den Pie zu stecken Ohne grosses Kabel Gedöns ...

Was gibt es da zu wissen? oder besser was muss ich tun das der MK3 über den Pie läuft? 

ganz lieben Dank für die Infos schonmal .. 👍 

Spooner 

Hallo und willkommen im Prusaforum!

Ich gehe davon aus, dass die Verbindung nicht abbricht, sondern gar nicht zustande kommt. Hast Du in Octoprint das richtige Device ud Baudrate eingestellt, das Pi über GPIO oder USB mit dem Drucker verbunden? Über GPIO muss im LCD RPI auf on eingestellt sein, über USB auf off. Bei der Nutzung von Pronterface ebenfalls off. Bei Beiden muss die Schnittstelle und Baudrate korrekt eingestellt sein.

Hier findest Du mal Grundlegendes: https://help.prusa3d.com/de/article/octoprint-konfiguration-und-installation_2182

und hier in der Octoprint Community: https://community.octoprint.org/t/unable-to-connect-to-prusa-mk3/12972/11

Es wäre sehr hilfreich, wenn Du genauer erklärst was Du gemacht hast und welcher Fehler dann genau aufgetreten ist. Eine .log Datei ist auch immer sehr hilfreich (octoprint.log, serial.log).

 
Posted : 06/02/2021 8:41 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?
Posted by: @spooner-2

Hallo zusammen , ich bin seit heute glücklicher Teil der Prusa Community und schon der erste post...

Ich habe heute meinen Drucker fertiggestellt und schon von der SD gedruck ... alles erste Sahne!

Aber beim Versuch den Drucker mit Octopie auf meinem Rpi (4) zu verbinden bricht die Verbindung nach ca 5 Sekunden ab. Das Setup läuft stabil mit meinem Anycubic i3 mega. Auch beim Versuch der connection mit Promterface kommen nur Sinnfreie Hieroglyphen bei der Verbindung zustande. ALso ein Print via USB ist mir leider noch nicht gelungen. 

Am liebsten wäre mir den USB in den Pie zu stecken Ohne grosses Kabel Gedöns ...

Was gibt es da zu wissen? oder besser was muss ich tun das der MK3 über den Pie läuft? 

ganz lieben Dank für die Infos schonmal .. 👍 

Spooner 

Hallo und willkommen im Prusaforum!

Ich gehe davon aus, dass die Verbindung nicht abbricht, sondern gar nicht zustande kommt. Hast Du in Octoprint das richtige Device ud Baudrate eingestellt, das Pi über GPIO oder USB mit dem Drucker verbunden? Über GPIO muss im LCD RPI auf on eingestellt sein, über USB auf off. Bei der Nutzung von Pronterface ebenfalls off. Bei Beiden muss die Schnittstelle und Baudrate korrekt eingestellt sein.

Hier findest Du mal Grundlegendes: https://help.prusa3d.com/de/article/octoprint-konfiguration-und-installation_2182

und hier in der Octoprint Community: https://community.octoprint.org/t/unable-to-connect-to-prusa-mk3/12972/11

Es wäre sehr hilfreich, wenn Du genauer erklärst was Du gemacht hast und welcher Fehler dann genau aufgetreten ist. Eine .log Datei ist auch immer sehr hilfreich (octoprint.log, serial.log).

 
Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 06/02/2021 9:41 pm
Spooner
(@spooner-2)
Active Member
Topic starter answered:
RE: I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?

Danke Dir für die Schnelle Antwort , also die Bautrate ist über AUTO auf 25000 gesprungen . Habe mit dem RPI port auf on und auf off geprüft.. keine Veränderung leider . Ich würde gerne den über eine feste IP im Heimnetz gebundenen und auch über VPN erreichbaren PI 4 via USB mit dem Printer verbinden. Das ganze funktioniert wie bereits gesagt einwandfrei mit dem Anycubic.  Bei dem Versuch mit Pronterface war der Port (RPI) auf "off" und es wurden beim Versuch des Verbindens nur Sinnfreie Zeichen ausgegeben ...Viele Sinnfreie Zeichen.. keine Codes oder ähnliches... auch die Bestätigung blieb aus.  Es war jedoch die Heatbed und extruder Temp auf Graphen sichtbar... kann aber auch sein dass das keine wirkliche echte aussage war. Auf welcher bautrate läuft er denn bei Dir ? 

Ich lese mich jetzt mal durch deine geschickten links ... Danke dafür 👍 👍 👍  

Ich halte Dich auf dem laufenden  Happy printing

Spooner

Posted : 06/02/2021 10:57 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?

@spooner-2

Der MK3 ist defaultmässig auf 115200 Baud eingestellt und derSerialport z.B. /dev/tty/USB0 oder /dev/tty/AMA0. In den Octoprint Einstellungen kannst Du einiges dazu einstellen.

Ich würde serielles Loggen aktivieren. Damit wird eine serial.log aufgezeichnet, welche Dir genauere Auskünfte zu Fehlern geben könnte.

Hier kannst Du dann die serial.log oder octoprint.log uploaden:

In die Einstellungen gelangst Du über dieses Symbol:

 
Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 06/02/2021 11:36 pm
Spooner liked
Spooner
(@spooner-2)
Active Member
Topic starter answered:
RE: I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?

Also das Rätsel ist gelöst... das Mitgelieferte Kabel war das Problem... das scheint eine Litze wohl nicht ganz mitspielen zu wollen. Hab probeweise das von meinem anderen Printer genommen und siehe da ... Alles Gut!!

Vielen Dank trotzdem für deine Mühen... jetzt kann es endlich Richtig losgehen

Spooner

PS das mit der .log datei ist ne Gute Idee ... da klemme ich mich gleich mal dahinter

This post was modified 10 months ago by Spooner
Posted : 08/02/2021 10:46 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: I3 MK3 S+ (Kit) an bestehendes Octopie setup (läuft spitze mit Anycubic i3 Mega) anschließen...möglich?

@spooner-2

Danke für die Rückmeldung! Und wieder mal die Hardware die uns einen Streich spielt 😋 

Nachdem es nun funktioniert - Viel Spaß und happy printing 👍 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 08/02/2021 12:49 pm
Share: