Bondtech Extruder Upgrade mit MMU2s bringt mich zum verzweifeln
 

Bondtech Extruder Upgrade mit MMU2s bringt mich zum verzweifeln  

  RSS
Drehzahl73
(@drehzahl73)
Eminent Member

Hallo Zusammen,

ich habe vor kurzen mein Extruder durch das Bondtech Upgrade ersetzt. Jetzt habe ich folgendes Problem mit Repetier und scheinbar auch mit dem Octoprint.

Es geht um den Single Color druck

ich bekomme nur sporadisch beim Repetierserver die Aufforderung ein Filament zu wählen, beim octoprint gar nicht mehr. Von SD Karte scheint es immer zu funtkioniernen.

Bisher hatte ich die Caribou FW versucht, das funktionierte gar nicht und nun die von Bondtech selber und auch die zickt, als wenn sie die MMU2s nicht immer erkennt.

Ab und zu wir pauschal das genommen wo der Selektor gerade steht, mal wird einfach irgendeiner genommen. Wirklich funktionieren tut es nur wenn ich im Gcode angeben welchen er nehmen soll.

Octoprint der sonst immer zuverlässig war startet nicht einmal mehr den Druck.

 

Spannend ist das er hin und wieder obwohl leer und auch die Sensoren sagen leer, der Meinung ist ein Filament entladen zu müssen und das ich weiterdrücken soll wenn ich es entfernt habe. als wenn die FW irgendwo Amok läuft.

 

Wer hat das Upgrade und MMU2s und welche FW nehmt ihr?

 

Gruss und Dank

Heiko

 

M3Ks + MMU2s...
Posted : 03/02/2021 1:06 pm
Holger
(@holger-2)
Honorable Member

Hallo Heiko,

wir verwenden inzwischen auch den R-Server mit Touch an mehreren MK3/S-Druckern, bis auf einen, alle mit BMG Extrudern.
Die von Dir beschriebenen Probleme sind soweit bekannt. Man muss aufpassen, dass die Firmware des Druckers mit der passenden Version vom R-Server zusammenspielt. Bisher bekannt ist bei uns:
1. Drucker MK3/s funktioniert mit FW 3.9.2, ori. Prusa und auch Bondtech ohne Probleme mit allen Druckern. FW3.9.3 funktioniert meistens nicht, es soll aber Ausnahmen geben. Das hat auch nichts mit mehrfacher Programmierung, Factory Reset, EEProm löschen, neuer Kalibrierung oder ähnlichem zu tun. Prusa ist derzeit selbst am Schwimmen und kann sich die Probleme nicht erklären, man arbeitet an dem Problem, es wird hoffentlich bald eine FW 3.9.4 erscheinen.
2. Das Image vom R-Server funktioniert in der Version 0.94.3 bei allen Druckern ohne Probleme mit den Druckern incl. MMU2S.
Vers. 1.0.0, 1.0.1, 1.0.2 sind nur mit Einschränkungen funktionsfähig, egal mit welcher Drucker FW. Ab Vers. 1.0.3. sollten einige Bugs wieder behoben sein.
Wegen dieser Problematik laufen bei uns alle Drucker, bis auf einen, zu Testzwecken mit MK3/S Firmware 3.8.1 oder 3.9.2 und R-Server 0.94.3, Testhalber mit Modifikationen im Start-GCode auch mit Vers. 1.0.2 und 1.0.3.
Derzeit also eine recht unbefriedigende Situation. Wir warten, auf das was kommt und testen erstmal nur mit einem einzelnen Drucker.

Ich hoffe, das hilft Dir etwas.

Grüße, Holger 🙂

hier noch ein Link zur Info auf das Repetier-Server Forum.

2x Personal MK3IR-BMG09 (Full) BEAR + MMU2S mod., ......
Posted : 03/02/2021 2:01 pm
karl-herbert
(@karl-herbert)
Illustrious Member
Posted by: @drehzahl73

Hallo Zusammen,

ich habe vor kurzen mein Extruder durch das Bondtech Upgrade ersetzt. Jetzt habe ich folgendes Problem mit Repetier und scheinbar auch mit dem Octoprint.

Es geht um den Single Color druck

ich bekomme nur sporadisch beim Repetierserver die Aufforderung ein Filament zu wählen, beim octoprint gar nicht mehr. Von SD Karte scheint es immer zu funtkioniernen.

Bisher hatte ich die Caribou FW versucht, das funktionierte gar nicht und nun die von Bondtech selber und auch die zickt, als wenn sie die MMU2s nicht immer erkennt.

Ab und zu wir pauschal das genommen wo der Selektor gerade steht, mal wird einfach irgendeiner genommen. Wirklich funktionieren tut es nur wenn ich im Gcode angeben welchen er nehmen soll.

Octoprint der sonst immer zuverlässig war startet nicht einmal mehr den Druck.

 

Spannend ist das er hin und wieder obwohl leer und auch die Sensoren sagen leer, der Meinung ist ein Filament entladen zu müssen und das ich weiterdrücken soll wenn ich es entfernt habe. als wenn die FW irgendwo Amok läuft.

 

Wer hat das Upgrade und MMU2s und welche FW nehmt ihr?

 

Gruss und Dank

Heiko

 

Ich habe auch ein Bondtech ähnliches Upgrade (selfmade BMG), die MMU2S verbaut und arbeite mit Octoprint (1.3.10). Allerdings verwende ich die originale, aber angepasste (Extrudersteps) Prusa FW. Bei einem im Prusaslicer im Singlemode generierten gcode wird immer das erste Filament (MMU2S Station 0 ganz links) verwendet bzw. geladen. Je nachdem was im gcode steht (T0, T1...) sollte der Selektor an die entsprechende Position fahren und das korrekte Filament laden.

Was auch ganz wichtig ist: die Sensoren /Extruder und MMU2S müssen exakt schalten. dies lässt sich leicht am LCD prüfen. Ich habe mir zu diesem Zweck Kontroll LED's eingebaut (einfach weil ich faul bin). Ja, und gelegentlich die MMU2S von Filament Resten/Fäden befreien.

Gutes Gelingen!

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 03/02/2021 2:17 pm
Drehzahl73
(@drehzahl73)
Eminent Member

@holger-3

der Thread Ersteller im RS Forum bin ich 😉

Danke Holger das hilft zumindest das es nicht nur mein Problem ist. Habe ja mit den Repetier Support auch schon geschrieben und mit 1.02 war es ja fast gut. 
FW Drucker werde ich wahrscheinlich nicht zurück.

1. Hab ich ewig Gebraucht bis alles wieder sauber gelevelt war und ich habe schon die SuperPinda dran. Meine die ist unter 3.9.2 nicht voll unterstützt.

leider habe ich das 7“ Gehäuse von Philipp3D und das muss ich zum neu flashen halb zerlegen. Vielleicht sollte ich mir gleich ein neues Gehäuse drucken.

 

This post was modified 3 months ago by Drehzahl73
M3Ks + MMU2s...
Posted : 03/02/2021 2:21 pm
Drehzahl73
(@drehzahl73)
Eminent Member

@karl-herbert

Hoi

im Single Mode sollte er doch fragen und nicht einfach 0 nehmen. Dafür gab es im Octoprint ein Filament addon und das poppte sogar auf der Webseite auf und man brauchte nicht zum Drucker.

scheinbar hat sich in 3.9.3 wirklich soviel verändert das 3rd Party SW das nicht mehr schnallt.

M3Ks + MMU2s...
Posted : 03/02/2021 2:26 pm
karl-herbert
(@karl-herbert)
Illustrious Member

@drehzahl73

Hast Du nähere Infos zum Octoprint Plugin (addon) zur Hand, welches die Abrage zur Filamentstation ausgibt? Das würde ich mir gerne mal anschauen.

Ich wähle beim SM Druck im MM Modus das gewünschte Material im Slicer, was sicherlich nicht viele so handhaben, aber gut funktioniert. Man darf halt nur nicht vergessen das richtige Material zu setzen, da der Slicer defaultmäßig immer das erste Filament selektiert.

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 03/02/2021 6:26 pm
Drehzahl73
(@drehzahl73)
Eminent Member

@karl-herbert

OctoPrint-Mmu2filamentselect, aber das hat bei mir mit 3.9.3 von Bondtech auch irgendwie nicht mehr funktioniert

https://plugins.octoprint.org/plugins/mmu2filamentselect/

Gruss Heiko

 

M3Ks + MMU2s...
Posted : 03/02/2021 7:44 pm
karl-herbert
(@karl-herbert)
Illustrious Member

@drehzahl73

Danke, sehr gut! Das schaue ich mir mal an, da das auf meinem etwas älteren System (Octoprint) funktionieren und man evtl. etwas Anpassen könnte. Ich kann mir jetzt aber nicht vorstellen, wie das Plugin im Zusammenhang mit der Firmware steht. Tx sollte eigentlich Tx bleiben.

Leider sind einige gute ältere Plugins nicht mehr mit den aktuellen Octoprint Installationen kompatibel (Python 3 check)

Gut, später werde ich mehr wissen und berichten 👍 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 03/02/2021 8:36 pm
Drehzahl73
(@drehzahl73)
Eminent Member

@karl-herbert

Kannst ja schreiben wenn es tut und was du machen musstest.

M3Ks + MMU2s...
Posted : 04/02/2021 7:40 pm
Share:

Please Login or Register