Mosquito / Bondtech Calibration Fail  

  RSS
keith.s
(@keith-s)
New Member

Apparent problem: Cannot calibrate the Z axis. Fails at Z=5mm.

  • I get the message "Calibration Failed! Check the axes and run again."

Another problem I've noticed: threaded rods from Z axis stepper motors shift position as the X carriage travels along the Z axis.

  • When the X carriage is all the way at the top, the threaded rods are centered in printed parts Z_axis_top_left and Z_axis_top_right
  • When the X carriage is all the way at the bottom, the threaded rods are not centered
    • The left rod touches the right side of the circle
    • The right rod is close to the back of the circle

Another problem I've noticed: after calibration fails (Z = 5mm), if I command the X axis to move right(after increasing to a Z of 7mm), the nozzle will eventually crash into the heated build plate (no steel sheet)

  • Happens about 1/2 to 3/4 of the way across the X axis

 

Context:

I started with a i3 Mk2s. Upgraded it to 2.5. Upgraded it to a Bondtech hotend.

Hotend started to jam frequently on multiple filaments. I replaced the hotend with another V6.

  • Experienced the same problems.

I became desperate and decided to change out my V6 hotend for a mosquito hot end.

  • Seeing as I already have the hardware for Bondtech, I didn't see the logic in purchasing the Bondtech i3Mk2.5s for Mosquito hot end kit from Bondtech.
  • Bondtech offers the step files for their parts so I downloaded it and modified it to use square nuts in place of threaded inserts
  • I printed my (very slightly) modified version of the Bondtech i3Mk2.5s for Mosquito hot end successfully
    • I assembled my modified bondtech extruder without problem
  • I also purchased the i3 Mk2.5 to i3 Mk2.5s kit from Prusa

When I assembled everything, loaded the new firmware and tried to calibrate it. I got the "Calibration Failed! Check the axes and run again" error when trying to calibrate the Z axis.

  • This is when I first noticed that the threaded rods for the Z axis were skewing
  • This is when I first noticed that the nozzle would touch the build plate if the X axis was commanded to move away from the home position

Still desperate, I figured that the Y axis was out of tune.

  • So I purchased the half-bear upgrade.
  • Assembled the half-bear upgrade.
  • Installed all the components on the half-bear upgrade.
  • Updated the firmware.
  • Ran the calibration.
    • Failed to calibrate the Z.
    • "Calibration Failed! Check the axes and run again."

I'm at my wit's end. I followed step 12 of the assembly guide to wiggle the Z motor holder ( https://help.prusa3d.com/en/guide/4-z-axis-assembly_90552 ).

I reprinted the motor holders (on my other printer) at 100% fill in PETG.

  • Still the same problems.

I disassembled and reassembled the X axis.

I made sure everything was level. The frame, build plate, table, Y axis rods.

Please help.

...
Posted : 22/06/2020 11:37 pm
keith.s
(@keith-s)
New Member

I ended up swapping the left Z axis for a new one from Prusa.

  • This did not solve the problem.

Next I upgraded the firmware in accordance with Bondtech's website.

  • This did solve the problem.

I've since run calibration and first layer calibration and printed a benchy.

All is well.

...
Posted : 09/07/2020 11:15 pm
Share:

Please Login or Register