MK2 to MK2.5S upgrade - Thermal Runaway problems  

  RSS
ryan.r
(@ryan-r)
Active Member

So, I'm pretty frustrated.  I have an MK3 and an MK2.  I was really happy with both printers; both printed perfectly.  However, I decided to upgrade my MK2 to the 2.5S simply for the flexible bed feature, and I am sad to say that I have barely used my MK2.5S since.  As the title states, I have had the thermal runaway problems ever since the upgrade. 

I chatted with support months ago, and the I didn't get much of a solution -- though I think they suggested I try a silicon sock or lowering the fan.  I did put a silicon sock on the heater block, and this did solve the problem, though temporarily and not very satisfactorily.  Not only does the solution feel like a hack, the sock runs uncomfortably close the the nozzle opening and in general interferes with things.

 

I haven't modded my printer.  I have done PID calibrations, lowered Fan speed.. and nothing is fixing this.  Do I need to re-print an older extruder design where the fan is blowing directly into the block??  What is the CORRECT solution here?  I now never use this printer as it's just a disappointment and I have an MK3 sitting next to it.  Grrrrr

I personally hate the new extruder design and I cant understand why it was switched if it admittedly cools the nozzle beyond the heater blocks ability to keep up.

...
Posted : 29/03/2020 11:46 pm
christopher.k3
(@christopher-k3)
Active Member

I, too, am experiencing the same problem when upgrading my Mk2 to the Mk2.5S: Fan cools the block too much. Lowered the min/max on the fan to 20%/30% and it still happens. I've wasted so much filament on jobs that stop halfway through that it's a crime. Unfortunately, I don't have another printer to go to. I'm surprised more 2.5 upgrade people aren't talking about this.

This post was modified 5 months ago by christopher.k3
...
Posted : 12/04/2020 12:56 pm
rgordon0
(@rgordon0)
Active Member

While I like the newer extruder design, after upgrading one of our Mk2.5 printers to an Mk2.5s - I now have nothing but problems with the thermal runaway issue. I thought it was the thermistor - the wires seemed a bit loose after a particularly nasty clog removal - but after replacing with a new Prusa-sourced thermistor - it continues. 

It works fine for the first layer, then the fan kicks on and it quickly drops 10C-12C. At some point it will drop even further and invoke Thermal Runaway. I've tried adjusting the fan shroud so that it's putting air more onto the print - but that thing moves a lot of air!

I've also tried reducing the fan speed manually, and that does help, but then it tries to do PLA bridging and does not always succeed.

I've done PID tuning a couple of times now, with no changes.

When it stops due to Thermal Runaway - it leaves the print fan running - so I tried doing PID tuning in that state too. No help there either.

I really don't want to roll this thing back to pre-S upgrade. I'm looking for a better solution - maybe a redesigned shroud that directs the air flow more directly down? 

Posted : 21/04/2020 1:43 am
ryan.r
(@ryan-r)
Active Member

I replaced my thermistor, and I have checked all my cables.  So far nothing.  I'm working with support again, but its extremely slow going through email.  Anyone else working with support on this issue?

...
Posted : 21/04/2020 2:42 am
joan.t
(@joantabb)
Veteran Member Moderator

Have you tried Live Chat? 

on the eShop page, bottom right hand corner (appears after about 5 seconds)

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 21/04/2020 2:56 pm
christopher.k3
(@christopher-k3)
Active Member

UPDATE: I lowered min and max fan speed to 25% which seemed to help with printing PLA, but I still had a couple of crashes that don't quite fit this profile. See this thread. So, I caved and ordered the E3D silicone socks (found them on Amazon). They're working for me now as I have not had any issues since then, even when running several long ABS jobs over the past week or so. I agree with ryan-r that it feels like a hack, especially because I thought I read in the assembly instructions that Prusa doesn't recommend them. I'm just surprised we haven't heard anything official from Prusa about it. It can't be that we're the only ones experiencing the issue.

As I'm typing this, it dawns on me that maybe this is an issue the stems from upgrading directly from Mk2 to Mk2.5S. I skipped the Mk2S upgrade step and it sounds like ryan-r did too. Is there something in that upgrade package that we missed that may be causing this?

...
Posted : 21/04/2020 4:30 pm
lee.g
(@lee-g)
Estimable Member

For me there are a couple of obvious flaws with the 2.5S (i currently have 2 of them)

1. Part cooling duct is poor

2. filament path not inline with extruder feed gears

3. Not really a problem but a big difference between the MK2S and MK2.5s is the heatbed has a lot more mass to heat up.

 

Most of my hotend printed parts are different from official Prusa parts because of the filament path issue.  I have bumped up the PSU voltage and insulated the bottom of the bed to compensate for the extra mass on the bed.  I have a different part cooling duct that is far more directional rather than the stock duct which is just like a scatter gun.

I have also suffered with the extruder clicking but seem to have that under control with some of the changes i've made.  Not sure what part of the changes resolved the clicking.  I still suffer the odd click when the intro line is printed but otherwise it seems ok.  I really wish i knew what Prusa changed because my MK2S was just abeast and worked no matter what but the draw of the magnetic bed, filament sensor and temperature sensitive pinda was to much for me to ignore.

...
Posted : 21/04/2020 10:03 pm
rgordon0
(@rgordon0)
Active Member

I tried the chat for a short while last night - but the wait time was longer than i had.

i was researching the fans - and realizing that this was originally an Mk2s printer that had been upgraded to an Mk2.5 and then to an Mk2.5s.

That means it uses an older mainboard, and uses a 12V fan with a higher flow than mk3 fans.  about 20% higher CFM. But - this should be the same mainboard that regular mk2.5 uses (w/o a print fan speed sensor) so presumably the design takes that into account. But - something is wrong in there somewhere!

Posted : 21/04/2020 10:11 pm
ryan.r
(@ryan-r)
Active Member

Lowering the fan speed should be a non starter as well.  Even if it did prevent the heating block from experiencing MINTEMP, you are no longer cooling the PLA as fast as you would normally like.  I assume this would negatively affect things like bridges at the very least.  I did skip the MK2S upgrade, but I think MK2 to MK2S was just some printed parts which have since been covered by the 2.5S upgrade (I could be wrong.)

...
Posted : 22/04/2020 2:35 am
keri7240
(@keri7240)
Active Member

I also had thermal runaway shutdown occur  after the 2S > 2.5S upgrade.

It seemed to shutdown shortly after the parts cooling fan starts.

Replacing the fan shroud with a different type seemed to help, and installing an E3D hotend sock seemed to cure it... for about a week.

Then yesterday the single beep signaled the shutdown on a PETG print and a restart failed to warm up!

A check of the heater resistance at the MiniRAMBO connector indicated 200 ohms or so.  Shouldn't it be only a couple of ohms?

So, out with the original 40w E3D heater and in with my spare E3D 40w heater and the printer now works correctly even with no sock.  When the parts fan starts up, the hotend initially cools down about 5º  then quickly recovers. So, I'm back to 3D printing!

A recheck of the failed heater indicated 20 ohms.  Huh? An order of magnitude lower by just removing the heater? Looking at it carefully revealed a burn spot in the red wiring sleeve, about 25mm away from where the wires enter the heater cartridge. Apparently the spot is molten PETG from the  bottom of the X carriage.

 As the high temperature sleeve is not heat shrunk, it pulls back away from the heater revealing a long brass crimping sleeve with a poorly executed crimp!  The other wire has a nicely formed crimp.  Wiggling the wires around at the crimp brought the resistance down to 4.7 ohms, apparently by temporarily cleaning the remaining contact area inside of the poorly formed and overheated crimp.

Apparently, removing and installing the hotend during the 2S > 2.5S upgrade loosened the crimp, causing high resistance, which in turn overheated the crimp and burned the sleeving while reducing the power available to the heater element, leading to thermal runaway... it was not the fan shroud after all!

 

So, if one has a thermal runaway on a PRUSA, it is probably a good idea to check the resistance of the heater element.  Cold, on a 40w 12v heater, it should be around 3.6 ohms,  on a 40w 24v heater, about 14.4 ohms.  If warm, the resistance will be higher.

 To do this, get or borrow an ohmmeter, unplug the hotend heater at the MiniRAMBO, and check resistance  at the connector plug.  After checking the resistance, tighten the little pinch screws in the connector plug and re-check.  Also, inspect the connector plug and socket on the MiniRAMBO for signs of overheating. 

[caption id="attachment_41164" align="alignnone" width="480"] Thermal Runaway caused by failed crimp[/caption]

 

Happy Printing!

¡no entiendo Español!
Nein! Nicht Versteh!
Я немного говорю по-русски но не очень хорошо, и...
I'm not very good at English either! Maybe someday I'll find a language I'm good at?...
Posted : 26/07/2020 5:22 pm
merrill.a
(@merrill-a)
Trusted Member

I appreciate the information and will check my printer out for any such problems. When I did the upgrade I completely replace the hot end and all components. I measured the ohms on both the heater and the sensor. All were OK but did not measure after all was completely reassembled.

On another discovery while chasing this one down, seems that when I do a pause and then a resume on both my 2.5S and 3S, I get a gap in the print. I have tried different time of pause with similar or larger gaps. The temp does come up to the proper temp before resuming the print but it looks like the printer does not start extruding right away. Working with prusa tech on this but so far no fix found. I have attached a photo of the print. It does it on any layer. The photo is layer 1 so it is more obvious.

...
Posted : 27/07/2020 2:15 am
Share:

Please Login or Register