Failing to extrude put only during print  

  RSS
tom.b11
(@tom-b11)
New Member

Hi all,

I have an issue that's driving me crazy and I've run out of ideas how to investigate.

A few weeks ago, the extruder stopped extruding mid-print. I can see that the gears are not slipping on the filament, but it's the stepper motor that is 'clicking' as it can't push the filament through. To fix it I would click 'Change filament', retract the whole lot and cut the end off (which sometimes had a misshapen blob at the end and sometimes didn't) and load it back. The print would carry on for an indeterminate amount of time before it all happened again. Obviously I'm losing a lot of prints as I can't watch it all the time.

I disassembled the hotend and replaced the PTFE tube, and it seems like it's fixed well (collet is up and it doesn't move at all when I push or pull it).

Now it won't extrude at all when running a print (whether from sd card or octopi), failing even to do the start g-code 'intro line' outside the print area. However if I manually tell it to extrude a set amount of filament (using octoprint of on printer controls), it extrudes fine.

I've tried changing the z-offset so there is lots of room below the nozzle in case it was too low, raised the temps, changed materials (PLA and PET), disabled the filament sensor and printed with / without enclosure and nothing is consistently working.
I've reinstalled slic3r and changed no settings, tried Simplify3D and Cura and all are failing.

Interestingly, if I take the gcode file that I generated in Slic3r PE, and paste the line into the terminal on octoprint manually it 'works'. I mean it looks terrible, but plastic comes out.

I've really run out of ideas for what to try next. Anyone got any ideas? It seems like the firmware is lowering the current to the steppers maybe? I'm not running in silent mode, so I don't know why it would be.

SOS!

Posted : 13/12/2018 4:34 pm
tom.b11
(@tom-b11)
New Member

Quick update,

THe major issue of not extruding at all appears to be that my Live-Z values is way out.
I'm assuming that I nudged the PINDA at some point and messed up my cal.

Either way. It's at least sort of working.

This doesn't explain the clogs I get mid print sometimes though. Any idea with that?

Tom

Posted : 13/12/2018 4:46 pm
matteo.a
(@matteo-a)
New Member

hi all, my name is Matteo,
I think is the corrrect place tu post a similar problem whit my MK25,
During the print the machine stop or go out from the picture and came back
i check for a lot of time the extruder , the gear and the cable but for me are all ok
I swich off the optical sensor, I change the nozzle but the problem are the same,
I refresh the firmware, I changed some different project, I check the gcode , my work is in the meccanical gear machine, and i work every day with gcode
but I haven't found any problem and any solution for this

if you have any idea to help me I woul be grateful
thanks so much

PS : sorry for my english 😀 😀

Matteo 🙄

...
Posted : 15/12/2018 4:11 pm
Hobb3s
(@hobb3s)
Active Member

Did you ever solve this? I'm having the same issue with clicking and appearing to be stuck, also not extruding. cleaned/tightened/loosened/temp changes, etc. No luck fixing it yet.

Posted : 25/03/2019 2:59 am
Unconquered
(@unconquered)
Active Member

Also, it looks like one of the reasons that slowing a print down and turning up the temperature can also reduce or eliminate clicking/under-extrusion issues is that the “custom” PRUSA e3D heatbreak changes bore size from 2.2 to 2 close to the heat zone. Proto-Pasta did a bunch of testing that showed that this was probably the major cause of the click (stepper slips) and under-extrusion sometimes leading to jams. If this is your problem, the solution is to by the non PRUSA custom e3D heatbreak

Posted : 29/03/2019 6:20 am
Share:

Please Login or Register