Stepper Motor Running Opposite Direction
 
Notifications
Clear all

Stepper Motor Running Opposite Direction  

  RSS
eric.s2
(@eric-s2)
Active Member
Stepper Motor Running Opposite Direction

Hello. I am looking to this learned group of people for some guidance. We bought an i3 MK2 about a year ago for our son (and me 😉 ). We bought the assembled model and have been printing without any real issues. The unit has been updated to Firmware 3.1.0. The other day, we moved the unit across the room and unloaded the PLA we had been using. We attempted to load a new ColorFabb XT and that's when it happened...

For no apparent reason, the stepper motor is running in reverse. When we tried to "load" the new filament, the motor spins counter-clockwise as though it were unloading. Conversely, when we use the LCD to "unload", it spins clockwise as though loading. Even with filament loaded in this reversed manner, it will not print...even the calibration print. We have since removed the XT and attempted to replace the PLA with no luck.

I have done a factory reset. I have read a number of posts about incorrect wiring causing this issue when assembling a kit, but this unit has been running fine for a year and suddenly revered itself. Any help the group could provide would be appreciated. Thank you.

...
Posted : 25/02/2018 12:12 am
alexander.s27
(@alexander-s27)
Estimable Member
Re: Stepper Motor Running Opposite Direction

Did it work correctly between the firmware update and the relocation?
If no, I would try to flash the firmware again.

If this has nothing to do with the firmware I would guess a short due to some broken wires...

Posted : 25/02/2018 1:34 pm
eric.s2
(@eric-s2)
Active Member
Topic starter answered:
Re: Stepper Motor Running Opposite Direction

Thank you for the response. Yes...it was running fine after the firmware update.

...
Posted : 03/03/2018 12:34 pm
alexander.s27
(@alexander-s27)
Estimable Member
Re: Stepper Motor Running Opposite Direction

Happy to hear that and thank you for keeping us all informed!
Always happy printing.

Posted : 04/03/2018 5:34 pm
eric.s2
(@eric-s2)
Active Member
Topic starter answered:
Re: Stepper Motor Running Opposite Direction

alexander.s27...I apologize, I think my answer to your question was misleading. The firmware was installed some time ago and afterward the printer worked fine. After the recent move across the room (done carefully) and filament change , the printer began having the problem. The issue persists.

We have used the printer very little. I hope it's not a short or broken wire, but I will explore those possibilities. Thank you

...
Posted : 09/03/2018 1:06 pm
eric.k4
(@eric-k4)
Reputable Member
Re: Stepper Motor Running Opposite Direction


alexander.s27...I apologize, I think my answer to your question was misleading. The firmware was installed some time ago and afterward the printer worked fine. After the recent move across the room (done carefully) and filament change , the printer began having the problem. The issue persists.

We have used the printer very little. I hope it's not a short or broken wire, but I will explore those possibilities. Thank you

I have no clue how it would run backwards with a firmware change, unless it's the wrong firmware or printer. Take a picture of the printer, and exact firmware link..... if you physically didn't re-wire it that is. you can flip the stepper cables and it would go the right way, but that's not right.

Posted : 09/03/2018 6:26 pm
kevin.r5
(@kevin-r5)
Estimable Member
Re: Stepper Motor Running Opposite Direction

I have no clue how it would run backwards with a firmware change, unless it's the wrong firmware or printer...

...The firmware was installed some time ago and afterward the printer worked fine. After the recent move across the room (done carefully) and filament change , the printer began having the problem. The issue persists...

Puzzling how moving the printer could cause this to happen. I think you'll need to look closely at your wiring.

...you can flip the stepper cables and it would go the right way, but that's not right...

The connectors for these stepper motors are keyed, so I don't think you will be able to "flip" it.

From the RepPap wiki ( http://reprap.org/wiki/Stepper_wiring ):

Might be worth re-flashing your firmware if you haven't done it yet. Possibly a static glitch when you were moving it? Seems unlikely but anything is possible.

If it comes to changing the wiring, I think you'll have to get the pins out of the connector and move them or clip and re-connect wires. Still it doesn't seem like this should be necessary if you can find what was disturbed when you moved the printer.

Interesting problem. I'm curious to hear what you find.

-Kevin...
Posted : 10/03/2018 4:35 pm
eric.s2
(@eric-s2)
Active Member
Topic starter answered:
Re: Stepper Motor Running Opposite Direction

Thank you all for putting thought into the problem and for the suggestions. I'll let you know if I get the problem resolved.

...
Posted : 17/03/2018 3:37 pm
eric.k4
(@eric-k4)
Reputable Member
Re: Stepper Motor Running Opposite Direction

the MK3 firmware on MK2 would do it since trinamics are reversed from the standard drivers. or wrong motherboard version perhaps (there is different rambo versions).

Posted : 17/03/2018 4:43 pm
eric.s2
(@eric-s2)
Active Member
Topic starter answered:
Re: Stepper Motor Running Opposite Direction

I finally got around to addressing the problem. Updated drivers and re-flashed firmware (1_75mm_MK2-RAMBo13a-E3Dv6full.hex). That seemed to solve the problem. Thank you all for your input. It is appreciated.

...
Posted : 28/06/2018 6:39 pm
Share: