OctoPrint firmware upgrades  

  RSS
stephen.e3
(@stephen-e3)
Estimable Member

After struggling to get the Mac FirmwareUpdater to work for an hour, I decided to try the Firmware Update plugin for OctoPrint and it worked a charm.

If anyone else is interested, just follow the setup instructions here:

https://github.com/OctoPrint/OctoPrint-FirmwareUpdater

I had to do the SSH commands, then install the plugin by specifying the URL.

...
Posted : 24/02/2017 3:26 pm
dustin.s
(@dustin-s)
Eminent Member

Awesome! Thanks for the advice.

...
Posted : 24/02/2017 6:26 pm
brian.s5
(@brian-s5)
Eminent Member

Excellent! I was just getting ready to upgrade the firmware but wasn't certain if the Octoprint plugin worked with the mk2. Very easy process now!

...
Posted : 25/02/2017 5:07 pm
individ
(@individ)
New Member

The FirmwareUpdater plugin works like a charm! Just remember to install the avrdude dependency and setup the path in the plugin UI.

...
Posted : 25/09/2017 10:10 am
andrew.e9
(@andrew-e9)
Active Member

For anyone else stressing over which are the correct settings for a Prusa i3 MK3, here's what I just used and the update completed OK:

Posted : 21/06/2018 8:36 pm
PaulSonger
(@paulsonger)
Eminent Member

Now my printer is in an enclosure and my laptop running linux I am having helluva job updating to 3.3.0.

Got slic3r installed (after some real wrangling with permissions) but the update firmware option gives a permission denied error on comms. ( I am guessing this is due to some sudo type shenanighans)

Decided to go to Octoprint Firmware Updater but that seems to hang and do nothing (disconnected the printer, says starting flash then Nada)

Is it me or does the updater not like 3.3.0?

Really I am looking for a solution that doesnt involve removing my printer from the enclosure every time i need to update firware and taking it to a room on the other side of the house!

I am new to linux and am a bit worried that if I try to fudge AVRdude via command line I could be sending my printer to bricksville. As a business that could be a disaster.

My ideal solution is getting firmware updater working but I cant, for the life of me work out why it isnt (avrdude is installed and confirmed)

...
Posted : 11/07/2018 12:59 pm
rbojanssen
(@rbojanssen)
Eminent Member

I just tested it and it works like a charm for me!

Posted : 15/07/2018 6:54 pm
rbojanssen
(@rbojanssen)
Eminent Member



I am new to linux and am a bit worried that if I try to fudge AVRdude via command line I could be sending my printer to bricksville. As a business that could be a disaster.

Using a raspberry pi? If so, make an image of the SD card so that you can try freely and if you mess up just restore the image to the SD card.

Posted : 15/07/2018 6:56 pm
moshe.d
(@moshe-d)
New Member

I unfortunately have not had much success with this...
I have an MK3. it was running FW v3.3.0 and seeing this topic I installed all the components properly and configured OctoPrint as listed above (with avrdude installed over SSH). I just downloaded FW v3.3.1 that was just released and it failed!

I have OctoPi setup on a Pi Zero with the PrusaPrint image connected directly to the Einsy board. I also had OctoPrint updated to the latest stable release (1.3.8) and the Raspbian OS updated with all the latest updates.

It kept failing with connection issues, though PrusaPrint itself was properly connected to the the printer.
I did end up installing with Slic3r connecting with a USB cable with no issues.

Thoughts??

Posted : 17/07/2018 3:26 am
tim.b26
(@tim-b26)
New Member

Same result. No luck with the 3.3.1 firmware. I've never applied the firmware this way before, so I'm not totally sure it's not my fault. Thought I would come here to find out!

Posted : 22/07/2018 12:43 am
Kissman
(@kissman)
Eminent Member

This tool working perfectly with MK3 and FW 3.3.1 😉

...
Posted : 12/08/2018 10:56 pm
william.m26
(@william-m26)
Active Member

Hi there.

If you are having issues please follow these steps:

1) Use PuTTY or similar tool to connect to your pi
2) Once in terminal input sudo apt-get install avrdude
3) Restart Pi
4) Connect to Octoprint and install the firmware updater plugin
5) Restart Octoprint
6) Open firmware update tool from menu (under wrench in top right corner)
7) Select Firmware updater from Plugins section (bottom left hand of the screen)
8) Click plugin configuration (wrench icon) top right
9) See below - set accordingly and save

Posted : 02/03/2019 6:23 pm
Share:

Please Login or Register