[Solved] Printer can't see SD Card after Firmware update to 3.8.0  

New Member

I have just updated the firmware on my Mk III + MMU to version 3.8.0 (1.0.6) and I was told by Slicer 2.1 that this update vent well.

Great, so I take the SD Card out of the printer and puts it into my PC where I copy the file I just created onto it, told the system to "eject" the card.

I then put it into the printer and after a short while, the LCD shows no files, but just a "return to root" sign - press that, and I'm told that there's no SD Card in the menu 🙁

This is the original SD Card that came with the printer, and putting it back into the card-reader on the PC, shows me the files on the card and I can read them ...!

Anybody who knows what went wrong here ?

Posted : 15/10/2019 9:15 pm
New Member

OK - this is weird !!!!
I tried restarting the printer many times before writing the entry above and haven't had time to read ant answers (if any) or look at the problem again, until today. So I grabbed the printer and moved it to the room with the PC, so I could try to re-flash the Firmware again. Turned the printer on, and just out of curiosity, looked at the menu screen on the LCD and to my surprise it now reads the SD Card, after being left alone for some days without power ..!..?..?   and No, I haven't got a clue, why this made a difference, as I removed the power several times the first time, to ensure a guaranteed cold-boot.

YES, I can print again 🙂 .... well NO, because the top of the heater (not the Nozzle itself) is jammed up with filament I can't get out, and heating it for many minutes to 260 C does not do anything  🙁    I'm sure this happened because I was so frustrated about the printer not being willing to read the SD Card, I just removed the power without it being allowed to cool down in the proper fashion 🙁

Posted : 19/10/2019 6:48 pm
Active Member

So the problem with the SD card was solved by itself?

Posted : 28/10/2019 6:18 am

Please Login or Register