Firmware 3.2.3 for MK2S with E3D PT100 mod  

  RSS
Patricia-3s
(@patricia-3s)
New Member

Hello together,

I just bought a used MK2S as my first 3D Printer. It worked fine for a couple of prints.

It had an outdated firmware so I updated with the prusa slicer to version 3.2.3. That was a bad idea, after the update I now have preheating errors for the nozzle. As I found out an mod with the E3D PT100 + Amplifier is installed. Now I cant find an apropriate firmware for that. I have the RAMBo 13a board.

I tried with the github MK2 fork but I'm not experienced eough to compile me a hex-File on my own. Does someone know where to get the hex file?

Best regards,

Patricia

Posted : 12/07/2020 12:08 am
Karl Herbert
(@karl-herbert)
Famed Member
Posted by: @patricia-3s

Hello together,

I just bought a used MK2S as my first 3D Printer. It worked fine for a couple of prints.

It had an outdated firmware so I updated with the prusa slicer to version 3.2.3. That was a bad idea, after the update I now have preheating errors for the nozzle. As I found out an mod with the E3D PT100 + Amplifier is installed. Now I cant find an apropriate firmware for that. I have the RAMBo 13a board.

I tried with the github MK2 fork but I'm not experienced eough to compile me a hex-File on my own. Does someone know where to get the hex file?

Best regards,

Patricia

Hello and welcome in Prusaforum!

I think the easiest way would be to remove the PT100 mod and install the original thermistor.

https://shop.prusa3d.com/en/mk3mk3s/205-hotend-thermistor-e3d.html

If you don't want to print PEEK or similar materials, you don't need higher temperatures to 400 degrees and more.

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 12/07/2020 2:19 am
Karl Herbert
(@karl-herbert)
Famed Member

...or try this FW: 1_75mm_MK2-RAMBo13a-E3Dv6full_PT100

I compiled this with the source "1_75mm_MK2-RAMBo13a-E3Dv6full" and defined -> #define E3D_PT100_EXTRUDER_WITH_AMP in Configuration_prusa.h

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 12/07/2020 3:00 am
Patricia-3s
(@patricia-3s)
New Member

Hello Karl-Herbert,

many thanks, that worked!

Best regards,

Patricia

 

ps: Ich bin gestern fast verzweifelt! Ich hatte mir fast gedacht, das es so einfach ist. Habe es aber nicht geschafft scheinbar den Andurino Compiler richtig aufzusetzen! Die Anleitung auf Github dazu ist Mist? 

Hast du unter Windows compiliert?

Danke nochmal,

Patricia

 

 

Posted : 12/07/2020 10:17 am
Karl Herbert
(@karl-herbert)
Famed Member

Hello @patricia-3s,

use this Version of Arduino IDE https://www.arduino.cc/download_handler.php?f=/arduino-1.6.13-windows.exe and select the right board. The prusa instructions (read.me) does partly no longer work in any cases. Copy the right FW source from the variants folder to the root folder and rename it : Configuration_prusa.h - make changes - compile - flash.

Important - select the right board (Rambo) - verify/compile - export.

PS: die Anleitungen dazu sind teilw. veraltet. Installier einfach die v 1.6.13. Läuft auf W7 Pro, 64bit. Die MK2 Quellen (FW Source Daten findest Du auf den Prusa Seiten (Driver, Hardware). Wichtig - immer darauf achten, dass Du die richtige Version selektierst, in Deinem Fall die ohne MMU2S.

Hier nochmal die Version, welche ich verwendet habe und welche für Deinen Drucker passen sollte: Prusa-Firmware-3.2.3 

Happy printing!

 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 12/07/2020 2:42 pm
Share:

Please Login or Register