Firmware confusion, please help.  

  RSS
Sherri
(@sherri)
Eminent Member

Hi.  I bought my MK2 a few years ago, just before the MK3 came out.  For the last 2 years I have been moving, building a house and the printer has been packed away until this month.  I never upgraded firmware or the slicer until now.  I just downloaded and installed the latest slicer and firmware (v 3.2.3)  Now, I get the "upgrade to 3.9" bug anytime I start a print. 

Additionally, I'm not real happy with the new firmware.  Twice now a print has halted for some reason with an error message like "Load new filament" or something like that, I don't recall exactly.  Anyway, the hotend stays hot during this entire time!  I had one quit in the middle of the night and was probably in this error state for 4  hours.

 

Posted : 15/01/2021 4:14 pm
JustMe3D
(@justme3d)
Estimable Member

Check whether you have installed the correct firmware for your printer.

Check whether you have selected the correct printer in the slicer - if you slice for a MK3s, it should already tell you that you sliced for a different model when inserting the SD card, but it may result in the recommendation to update your (non-existing) MK3s to that model´s newest firmware.

Halting with an error for unloading/loading filament sounds like a badly adjusted filament sensor, not like a firmware bug.

Cheers

I try to give answers to the best of my ability, but I am not a 3D printing pro by any means, and anything you do you do at your own risk....
Posted : 15/01/2021 7:18 pm
Share:

Please Login or Register