Notifications
Clear all

Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU  

Page 2 / 3
  RSS
alan
 alan
(@alan-2)
Eminent Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

fw 3.1.0 is a big upgrade

i have had stay with 3.0.12 because i use Repeteir server and 3.1.0 is not compatable

if or when prusa address this and make 3.1.0 compatable i will upgrade to it

hope this is being looked in to

...
Posted : 02/12/2017 9:26 am
freedom2000
(@freedom2000)
Active Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU


That strikes me odd. I have been with RC1, and RC2 and now the final version which works pretty well.
I already used "pause" and even "stop printing" without any issues.
I take it you are printing from SD-Card?
I would crap my previous download-file, download it anew and flash it again.
MK1 according to here https://www.prusa3d.com/drivers/ seems not to be supported.

Hi,

Yes I am printing with SD card.
I have a mk2s, my previous version of the firmware was one already implementing LIN advance and produced by the coder.
It worked. I did reinstal it.

I will check again with the new firmware

JP

...
Posted : 02/12/2017 4:16 pm
freedom2000
(@freedom2000)
Active Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Hi,

I have reflashed the firmware and it works.
I don't know what happened with the previous flash...

Thanks
JP

...
Posted : 03/12/2017 4:32 pm
alexander.s27
(@alexander-s27)
Estimable Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

No matter what.
What is impotant is that your printer now works!
Have fun and success...

Posted : 03/12/2017 5:16 pm
Knickohr
(@knickohr)
Moderator
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

- Linear Advance

Is this feature always enabled ? Or must I set the K-Parameter for every new gcode file new ?

How to enable/disable it ?

Thomas

Posted : 03/12/2017 5:27 pm
alexander.s27
(@alexander-s27)
Estimable Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Just put the M900 (K45 for PETG e.g.)
in the start script of S3D and it works pretty well....

You maybe want to have a look on my .fff file here...
https://shop.prusa3d.com/forum/original-prusa-i3-mk2-f23/simplify3d-print-settings-august-30-2016--t938-s290.html
It already includes those M900 commands for different materials.

Posted : 03/12/2017 5:52 pm
Jakub Dolezal
(@jakub-dolezal-2)
Admin
Topic starter answered:
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Guys as for now, you need to do two steps to have Linear Advance activated with higher speeds:
1) Use latest FW 3.1.0
2) Use latest drivers and print profile with Linear Advance

You can also play with it and experiment:
1) Set speeds in Slic3r PE
2) Add M900 Kxx value to the first rows of your G-code

Though I recommend to start with the "official" way, see the values we've tested and recommended to you and then if you want to push forward, start experimenting.

In case you have issues with the firmware, please start an "issue" on our Github to let the devs know 😉
https://github.com/prusa3d/Prusa-Firmware/issues

Assembly manuals / Knowledge Base
The guy behind Prusa assembly manuals......
Posted : 03/12/2017 10:26 pm
dapug
(@dapug)
Eminent Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Does this version firmware fix the issue where it halts prints to show "new firmware available" message?

While I certainly welcome being notified about new firmware, the way this is implemented absolutely MUST change. I hate it! When printing remotely with OctoPrint, I kick off a print, and cannot see that this message is sitting there waiting for physical input HALTING the print, and times out and disconnects. REALLY annoying. There has to be a better way to notify about new firmware, perhaps auto-dismiss the message if not response for a minute. Something... for the love of sanity, please!

...
Posted : 07/12/2017 5:25 pm
richard.l
(@richard-l)
Moderator
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU


Does this version firmware fix the issue where it halts prints to show "new firmware available" message?

While I certainly welcome being notified about new firmware, the way this is implemented absolutely MUST change. I hate it! When printing remotely with OctoPrint, I kick off a print, and cannot see that this message is sitting there waiting for physical input HALTING the print, and times out and disconnects. REALLY annoying. There has to be a better way to notify about new firmware, perhaps auto-dismiss the message if not response for a minute. Something... for the love of sanity, please!

There is a M115 gcode command on the first line of the Printer Settings Start G-Code that tells the printer what the latest firmware version is. Comment that line out with a semi-colon and you will have no more problems.

...
Posted : 08/12/2017 2:54 pm
spark
(@spark)
Reputable Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Don't know where else to post this so here goes.
I recently updated everything. Cura 3.1, Sli3r PE, Firmware 3.1, Simplify3D 4.0. Prints are all off and strange, all temp values and speeds are odd, temps are always lower than set and speeds are always 30% too fast. Happens for same gcode that worked fine with prior firmware so it isn't the software.
Also, printer makes audible coil whine like noise when booting up and sorting SD card. Never heard whine before with prior firmware.

Will report once reflash is done as that seems to solve other peoples problems.

MK2S kit owner since 8/15/2017...
Posted : 09/12/2017 7:06 am
Sherri
(@sherri)
Eminent Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Josef indicated on the download page that there is a known issue with Repetier SERVER, but he doesn't mention what the "known issue" is. Anyone know? I'm trying to setup communication between Repetier HOST and my new MK2 (first printer) on a Ubuntu (new to Linux too) and it is only throwing errors. I can connect, and I can receive the hardware information from the printer, but RepetierHost then automatically sends an M110 command followed by a "last line number not followed by last number +1" (or something like that). I have the same problem trying to communicate with the MK2 using the Arduino serial monitor. Is that the same "known" problem as the server version?

Posted : 18/12/2017 5:29 pm
Chad
 Chad
(@chad-2)
Trusted Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU


Josef indicated on the download page that there is a known issue with Repetier SERVER, but he doesn't mention what the "known issue" is. Anyone know? I'm trying to setup communication between Repetier HOST and my new MK2 (first printer) on a Ubuntu (new to Linux too) and it is only throwing errors. I can connect, and I can receive the hardware information from the printer, but RepetierHost then automatically sends an M110 command followed by a "last line number not followed by last number +1" (or something like that). I have the same problem trying to communicate with the MK2 using the Arduino serial monitor. Is that the same "known" problem as the server version?

The issue is the M110 not working with Repetier. The communication fails and you get the errors. You can do like mentioned earlier and use the previous RC2. Or you can use an updated 3.1.0 from another source that has the M110 fix. Unfortunately I can't remember where that one is, but I use it and it works. Hoping a new firmware is released soon to address Repetier issues.

...
Posted : 22/12/2017 5:40 am
Chad
 Chad
(@chad-2)
Trusted Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

I posted a thread about this, but wanted to get it in the Firmware post.

Since the firmware upgrade and changing nozzles, my nozzle pushes the bed down in the front left corner. The screen says it should be at 0.15, but obviously if its pushing my bed down, its not there. I have done multiple calibrations from just doing Z calibration to the whole XYZ process. Still hasn't fixed the problem.

However, when I start a print, it moves up and does the mesh bed leveling and prints at my stl files first layer height correctly. So this doesn't appear to be an issue with hardware. For some reason, the firmware is lowering too much during the home process.

...
Posted : 22/12/2017 5:44 am
Chad
 Chad
(@chad-2)
Trusted Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Update: So I think I may have found the problem and it may not be the firmware. Apparently the power source I switched the printer too may not be able to support the amps it needs. Voltage is at 120, but since I changed it to go through an external power switch with fuse, that seems to have caused a drop somewhere. I put it back on a main power source and its running correctly now. I guess time will tell if it fails on that power source or not.

Another note with this firmware that I've been encountering... hadn't had any problems until this release

I did a Calibrate Z, it went fine until I tried to print. Now it garbles the screen after it does the first point in the mesh bed leveling. I've lowered the PINDA and that seemed to help for a short while. I can run all the other calibrations including the Mesh Bed Leveling manually. All of them work just fine. It's only when the print job starts and calls out for the Mesh Bed Leveling.

This isn't a problem with the gcode either. I've used the included gcode, gcode from S3D and from Slic3rPE. All do the same thing at the same point.

Any ideas would be great, but I am mostly certain this is a bug in the firmware.

...
Posted : 31/12/2017 4:05 am
spark
(@spark)
Reputable Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Have you tried reflashing your firmware? Have you tried hard reset?

MK2S kit owner since 8/15/2017...
Posted : 31/12/2017 12:34 pm
quinn.r
(@quinn-r)
New Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

I made a seperate post in the build/maintainence forum, but since i see the thread here is for firmware 3.1.0 i'd do a repost.

I did the firmware update, and when i slid in a SD card to print something the printer has gone belly up.

Prior to updating the firmware, I had found a Russian nesting doll maze puzzle from thingverse. Used slic3r for the Gcode and ran it to the machine via the provided SD card. It said a new firmware is out. 3.1.0 so i stopped the print, hopped on my computer and used the firmware uploader program.

Looked all nice and good. Plugged back in the SD card. The LCD goes WWWWWWWWWWWWWWWWWWWWWWWWWWWWWWWW until the screen fills, and then can't tell anything else is going on.

So i tried the nob.. tried the X button below the nob. no response. Turned off the unit. Upon comming back and turning the printer back on. Screen is lit, but showing 2 rows of Blank boxes. non responsive to input it seems.

I tried booting it up again after 2 hours of being unplugged. still just lighting up and show blank blocks

Posted : 04/01/2018 1:30 am
Alexander Shchukin
(@alexander-shchukin)
Active Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Hi !

It seems to be a bug in this firmware (3.1.0): when doing a first layer calibration (either from the first-time wizard or from the menu-calibration-first layer cal.) - z value is not saved to the memory after finishing the procedure. It shows 0.000 mm when printing something right after the calibration.

[Feature request] Also it would be great when selecting Load filament to move extruder to the middle of X axis and rise it at Z axis (say 80% of Z height) to easily see how new filament is extruding.

Posted : 09/01/2018 2:42 pm
hiroaki.m
(@hiroaki-m)
Active Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Does this final version fixes the issue with Repetier server? ( https://shop.prusa3d.com/forum/original-prusa-i3-mk2-f23/firmware-3-1-0-and-repetier-server-t6745.html#p46999 ). I'm still on 3.0.12 version due to issue with printing with repetier server after upgrading the firmware to 3.1.0

...
Posted : 10/01/2018 2:48 am
alain.b6
(@alain-b6)
New Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Hey Guys

Does anybody know if the Repetier Bug has been fixed or when a new firmware will be released which fixes the M110 Bug so we can use the Repetier Server again?

Thank you for any feedback!

Posted : 08/02/2018 11:01 pm
EHeapes
(@eheapes)
New Member
Re: Firmware 3.1.0 FINAL for Prusa i3 MK2/S/MMU

Hello, I just updated to 3.1.0 on my mk2 and since then when i try to print it starts off fine but a few moments into the print the nozzle and bed temp just drops. The set temp stays but the actual temp drops until it gets too cool and the print stops. If I watch for it and pause the print before it gets too cool and hit preheat then resume the print it will usually finish just fine. Any Ideas? I am new at this and have limited knowledge any help would be greatly appreciated. 🙁

...
Posted : 06/03/2018 4:32 am
Page 2 / 3
Share: