Notifications
Clear all

Problème carriage de l'axe Z qui se décalent tout seul  

  RSS
Benoistriel
(@benoistriel)
New Member
Problème carriage de l'axe Z qui se décalent tout seul

Bonjour , je mets ce petit post au bon endroit j'espère, car j'ai découvert un problème que je ne sais pas régler. En ce moment, mes impressions sont de très mauvaises qualités, du coup je me suis dit qu'un petit calibrage ne pourrait pas faire de mal  j'ai alors remarquer que lors de la recherche des points du bed un des deux carriage de l'axe Z bougeait ce qui provoque un décalage entre les deux et qui fait qu'au final l'axe X est de traviole. J'aimerais savoir si quelqu'un saurait m'indiquer comment régler ce problème ? ( PS : je suis débutant dans l'impression et ma Prusa est d'occasion je ne l'ai donc pas montée moi-même) 

Posted : 11/09/2021 8:29 pm
adesir
(@adesir)
Reputable Member

Bonjour et bienvenue,

Est-ce que le plateau est bien plat ? Car si le calibrage peut décaler sur l'axe Z pour compenser un plateau de travers.

Posted : 12/09/2021 11:07 am
Myf
 Myf
(@myf)
Eminent Member
Atteindre le calibrage parfait du plateau.

Bonjour Benoistriel,

Ma réponse rejoint celle d'Adesir.

Je suppose que tu fais le calibrage du plateau en suivant la matrice 7x7 à 49 points. Si le plateau est bien plat et horizontal les 2 axes de Z tournent un tout petit peu pour faire clignoter la diode de la sonde pinda. Si au contraire le plateau n'est pas parfaitement plat, par exemple si une particule de filament fondu est glissée entre la plaque chauffante et le plateau amovible, l'axe X se déplace bien plus, le calibrage de ce point prend beaucoup plus de temps, et à l'habitude le bruit est moins régulier. Quand le défaut est encore plus important le panneau affiche "re-calibration de l'axe Z à faire" : il me semble que c'est automatique, sinon il faut aller les menus... 

Si le plateau est bien plat, les deux axes Z tournent en même temps, dans un sens puis dans l'autre, autour de la position d'équilibre. Tu vois cette vibration sur les tiges filetées ou tu poses doucement deux doigts (un de chaque main) sur chaque tige fileté et tu ressens cette petite vibration. Si une des deux tiges ne tourne pas alors il y a un problème électrique ou électronique en amont : moteur, contacts électriques, commande électronique. 

Si au contraire l'impression se passe ensuite a peu près bien alors les deux moteurs de l'axe Z doivent bien fonctionner.

J'espère que ces pistes te permettront directement ou indirectement de cerner le problème.

Bien cordialement.

 

F.

Posted : 12/09/2021 12:14 pm
Benoistriel
(@benoistriel)
New Member
Topic starter answered:
merci de vos réponses

Bonjour adesir et Myf du coup, je pense avoir cerné le problème, je ne pense pas que ce soit le plateau, mais j'ai essayé ce que  Myf m'a conseillé.

"Tu vois cette vibration sur les tiges filetées où tu poses doucement deux doigts (un de chaque main) sur chaque tige filetée et tu ressens cette petite vibration. Si une des deux tiges ne tourne pas alors il y a un problème électrique ou électronique en amont : moteur, contacts électriques, commande électronique. "

J'ai donc pendant le calibrage mis mes petits doigts sur les tiges filetées et j'ai remarqué que la tige gauche faisait une petite vibration comme tu l'as dit, mais la tige droite tournait tout doucement je pense donc que le problème vient de là, je vais donc essayer de trouver une solution si jamais vous avez des suggestions, je suis tout ouïe.

 

Ps: Merci pour vos réponses  

Posted : 12/09/2021 12:42 pm
Myf
 Myf
(@myf)
Eminent Member
Panne du moteur ou de l'électronique.

Bonsoir,

La panne que tu décris est plus une panne "côté informatique" que "côté moteur". Le plus probable est, je pense, la panne de l'interface du moteur, et pas la panne du moteur car le moteur tourne, mais il ne tourne que dans un sens. (A)Tu peux avant tout autre test le confirmer en échangeant les connecteurs électriques de ces deux moteurs à l'intérieur de la carte électronique. Si l'autre moteur tourne mal, tu es sur que la panne vient bien de la carte électronique. 

Il est éventuellement possible, avec un fer à souder, de recâbler un moteur pas-à-pas pour faire tourner, avec une seule interface, les deux moteurs, mais la puissance disponible est moitié moins forte. Tu trouveras sur aliexpress des connecteurs pour brancher en parallèle deux moteurs pas-à-pas. Je te déconseille très fortement ce montage, car un montage de deux moteurs pas-à-pas en série est beaucoup plus logique

Cette page te montre le bon branchement en série. https://www.tubefr.com/cablage-de-votre-stepper-z-moteurs-en-serie.html Je l'ai fait sur une imprimante 3d construite à la main avec une seule interface pour deux moteurs sur l'axe Z. (B)-Un branchement très propre avec de gaine thermo-rétractable (de 1mm ou 2mm) rendra ton montage beaucoup plus durable. Couper le câble est simple, faire tenir les 6=3x2 soudures sans court-circuit plus pénible ! Le montage précédent te montre que chaque bobine des deux moteurs sont en série, dans le même sens pour qu'ils tournent dans le même sens. S'ils tournent en sens inverse je crois qu'il suffit d'échanger les deux cables d'une des 4 bobines (sans certitude).

(C)-Enfin, une fois que tu es sur que le problème vient de la carte, tu peux par ailleurs regarder si cette carte n'est pas encore en vente sur le site prusa. Elle peut être changée, a toi de voir si cela vaut le coup... 

(D)-Par ailleurs sur cnckitchen.com je crois qu'une video montre le changement d'une carte de prusa par une carte "haut de gamme" huet.

Bon courage, bonne continuation pour relever ce défi.

Posted : 12/09/2021 8:26 pm
Benoistriel
(@benoistriel)
New Member
Topic starter answered:
C'est bon

Je te remercie pour ta réponse heureusement, je n'ai pas eux à tout refaire, suite à ton message (qui m'a fait peur XD) j'ai échangé les connecteurs de l'axe z et là comme par magie ça re fonctionne plus de problème de décalage durant la calibration.

 

J'ai lancé une impression pour voir si tout va bien si je ne reposte pas, c'est que les problèmes sont réglés.

 

Merci pour tes réponses détaillées a+

Posted : 15/09/2021 8:23 pm
Myf
 Myf
(@myf)
Eminent Member
Conséquences surprenantes d'un mauvais contact.

Bonjour Benoistriel,

Je suis heureux que mes indications t'ai aidé, mais la chance a beaucoup joué !

En définitive tu décris un partiel mauvais contact qui limite la puissance du moteur : il pouvais tourner dans un sens, certainement celui de la descente du portique et n'avait pas assez de puissance pour remonter ce même portique. Le mauvais contact ajoute une résistance (en série avec le moteur) qui consomme une partie de la puissance (par effet joule) et empêche le moteur d'avoir toute la puissance (et l'intensité) nécessaire pour tourner dans l'autre sens.

Ta description de la panne a été un vrai plaisir à lire pour cerner le problème.

Bonne impression !

F., désolé d'avoir mis en avant une grosse panne avant de vérifier les plus petites causes...

Posted : 18/09/2021 12:53 pm
Share: