Clear all

MMU2 never really works  

Active Member
MMU2 never really works


first I have to say I'm really pissed. This MMU2 upgrade did not once worked as it should. I've got a few problems and I don't get any response from Prusa itself and the chat is useless. So here it goes.


- The PTFE always deforms on the intake side. I changed it since i got the MMU2 and the Mk3s update a least 4 times.

(If you can't see anything don't worry its just a small dent. But it wouldn't load properly with the MMU. If I heat the nozzle and put some filament directly in the Extruder and use the motor control by my self it works fine)


- Since I have the MMU, and this is over half a year I did not once printed something without a load error. Even after fiddling with the settings in PrusaSlicer the tip is apparently never good enough even if it looks how it should. But mostly after the first change it will not load again.


- I think two or three Firmware versions back I had the problem like many other people that the filament is loaded to the Extruder, the IR-Sensor triggers correctly but after a few more millimeter into the Extruder the filament is retracted. This was mostly fixed (see point two) but the f****** feature is back.


- And now totally new it creates a blob in the wipe tower if the a MMU load fail occurs. But not only it creates a blob which of course ruins another print, it retracts the filament at some point a throws another load error.


- I have yet to see a successful print with BVOH or PVA+ which always fails with a load error or the print quality is just to bad so it doesn't bind properly.

If someone has any idea how to fix these issues I would be grateful. The wasted plastic gets slowly expensive.


All Parts I use are original if I print only with one color and if I get it loaded everything work as it should. I use PrusaSlicer and have all up to date Firmware and Software.

Posted : 20/11/2019 3:18 pm
Trusted Member
RE: MMU2 never really works

Yes, the chat is useless.

The support from Prusa is poor, I agree.

I have written some emails, without response. - Poor

My MMU2S is working. But unloading the filament is not possible, because the first PTFE-tubes are too small for the tips of the filament. I tried to solve the problem with IGO3D from germany, where I have bought my printer this month. Until today no solution.

The MMU2S is not a product for everybody ...

My goal was to print, as you, soluble materials.

I tried PLA, 49 EUR PLA+ 49EUR  and BVOH 99EUR -> 200EUR for useless, and also in my case, layer adhesion is too poor, with low force you can break prints in two. I am not interested in printing colorful useless figures (for me useless) My goal is technical precise printings. Therefor I own a Ultixaxer (another printer from another company). I have bought the Prusa for using different filaments in one printed object.

I am using purge volumes up to 200 load and 200 unload, but nothing helps with layer adhesion.

The MMU2S is working in my case only with the same materials.

This post was modified 2 years ago 2 times by PPRRUUSSAA
Posted : 20/11/2019 4:24 pm
Illustrious Member
RE: MMU2 never really works

I'm also using one filament for one print, and have 5 different loaded (I don't use colorprints for my mechanical parts). I had the same Problems as you described. Try to change all MMU2 PTFE tubes (also the tubes from Filament roll to MMU2) from 4/2 to 4/2.5. In my case it helped a lot. If green and red leds are flashing during load/unload process, maybe your cable connections from MMU2 to Einsy are not 100%. The MMU2 is a beast, precision is nesessary, but when it works, then it works good.

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/11/2019 8:08 pm