Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error
Clear all

[Solved] Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error  

New Member
Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error

Hey all, buckle up and get ready to read an extended essay on the XYZ calibration crap I've been through trying to get my printer to work.

I upgraded from a Mk2 to a Mk2.5 in march, had an XYZ calibration error then but noticed that the auto-home position was placing the PINDA about 5mm back from the dotted circle, adjusting the Y axis to 105mm (instead of the recommended 100mm) solved this and printer worked fine for a few months.

In August I moved to a new place, taking my 3D printer with me, and had XYZ calibration errors again (XYZ Calibration Failed, Please Consult Manual). It will always scan the first two points fully (spiral-scan, back-and-forth-scan, and x-scan are what I've been calling them, probably better names for them though), the third point occasionally fails (maybe 1 in every 20 calibration attempts, in which case it gives "XYZ Calibration Failed, bed calibration point was not found"), and the "please consult manual" message always comes up after finishing the 4th point (spiral, back-and-forth, and x-scans always complete on this point). It will never go into the "improving bed calibration" screen.

Of note is the fact that the auto-home and the XYZ calibration home are different: when at the factory default 100mm spacing, the PINDA auto-homes to about 5mm behind the dotted circle (in line in X dimension), and when running XYZ calibration it homes about 5mm to the left of the dotted circle (in line in the Y dimension)

So far I have tried a laundry list of things to try and fix this (in rough order, its been a month of trying things):

  • Upgraded Firmware to 3.7.2
  • Downgraded Firmware to 3.2.0
  • Upgraded to 3.7.0 (what my printer had on it when it was working)
  • Removing power supply from frame (thought it might be interfering with the third point)
  • Moving the Y axis back to 100mm
  • Factory reset
  • Got the measured skew down to 0.08˚
  • Adjusting PINDA height to factory recommended (~1mm)
  • Upgraded to 3.8.0 (current firmware)
  • Tensioning X-axis belt (moving in august left it a little loose)
  • dropping PINDA to just above level with the nozzle (to try and pick up a warped heatbed)
  • applying light oil to the smooth rods on all axis
  • replaced PINDA probe (on recommendation of PRUSA shop support)
  • Moved rods back 5mm (to original 105mm spacing when it was working)
  • Elevated printer's Y-axis feet (was worried it might be rocking on the X/Z frame)
  • Moved rods back to 100mm (current configuration)

There were a few things I was considering, mainly to do with the PINDA being 5mm to the left when running XYZ calibration, namely adding in a spacer to hit the endstop earlier, or double-checking to see if my Y-axis is square (the bed seems to be square to the X-rods, using a ruler placed against the X-rods and lining up the bottom edge of it against the lines on the bed)... neither of these seem like the best solution though.

My Firmware is definitely 3.8.0 for the Mk2.5 and NOT the Mk 2.5S (unless the file I flashed, and the printer type loaded on the screen are named wrong)... I think the Mk2.5S and the Mk3 have a different x-axis endstop configuration, and I was worried that the code might have been copy-pasted from them to the Mk2.5 incorrectly... but I'm not great at looking though massive piles of code to find the one (maybe) error, and it doesn't sound like everyone else is having the same issue. I'm also worried that it could be my RAMBO somehow saving some parameter that cannot be reset with factory reset... don't know how I could avoid that though.

I've talked with the PRUSA shop chat twice now, both times they were helpful and pointed out things I had not thought of, but its hard to have an ongoing discussion for my issue on the shop chat over several days.

So PRUSA forums... any thoughts on fixes? things to try? I can provide photos/ videos of the printer's issues on request.

Posted : 19/09/2019 1:34 am
New Member
Topic starter answered:
RE: Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error

Little update: I was curious to see if there was some mechanical fault in how the PINDA was reading the bed, so I ran an M45 through Pronterface to see what the pad detection looked like.


As seen (let me know if you have issues seeing it), all 4 locations are higher than center (axis too far backward I would think, they're currently at 100mm), pads 2 and 3 are significantly to the left of center (I would presume this would be how the X-axis is moving... don't know if thats a fault in the tension of the belt, the stepper motor, the shape of the bed/ pads, or maybe the gcode calibration code pushing it too far), and pads 1, 2, and 3 show lots of interference (I would guess this is the PINDA picking up other artifacts in the bed, like the magnets and such, don't know if that means the PINDA or the bed needs to be adjusted up or down around those corners).

I can fix the Y-axis position for the forward/ backward, and I have an idea on how to adjust the PINDA to filter out some of the interference. That said, I have no ideas on how to check what the issue is with the X-axis pushing the PINDA over the edge of the bed during calibration (or even if that is actually an issue).

Secondly, since its been a week w/o responses, I was curious if I posted this in the right forum, or if I need to move it to the hardware, firmware, and software help section?

Posted : 29/09/2019 11:24 pm
New Member
Topic starter answered:
RE: Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error

I had a little epiphany today, if the X-axis belt was the issue, then flipping the belt around (so the end closer to the idler was closer to the stepper and vice versa) could resolve it, as the teeth engaging on a stretched belt would result in a movement like that seen/ described above.

Sure enough, the calibration ran fine (aside from some height/ bed issues, but just need some tweaks there to fix it), so new belt is on order (I'm guessing a stretched belt would create for an imperfect surface finish, even without the stretched part engaging on the stepper), and I'll be back to printing soon.


Posted : 02/10/2019 2:11 am
Francois D
New Member
RE: Mk2.5 "XYZ Calibration Failed, Please Consult Manual" error


I think i’m Having the same issue. The calibration keeps failing on the 3rd of 4th point after I updated to MK2.5s. Really annoying.

I also tried different tweak like removing the rods to grease them or using different height of the PINDA without success. I will try to get the output of the calibration as you did, sounds like a good start. I’m not much help here but hope you tell us what result you got after updating  the belt!

good luck. Thanks for sharing!

Posted : 08/11/2019 12:38 am