Notifications
Clear all

USB stick not reading/fails midread  

  RSS
atomicalex
(@atomicalex)
New Member
USB stick not reading/fails midread

Hello, complete n00b here. 

I've just got my Mini kit built and went to do a test print. The Z test worked fine. However.... 

I'm unable to load any files from the USB stick to the printer. The printer starts to read the file, but can't complete it and freezes. Unplugging the USB stick and plugging it back in seems to reboot things. I'm planning to try to move everything to a fresh stick drive and see how that goes. Some files will load the file image, others not. Nothing will enter the print cycle. 

The firmware is up to date.

Has anyone experienced this? Is there a workaround?

Posted : 09/06/2021 12:59 am
BogdanH
(@bogdanh)
Honorable Member
RE: USB stick not reading/fails midread

Hello,

Are you talking about USB stick that comes with Prusa Mini or is that some of your sticks? -I'm just curious. Anyway, what I recommend is the following...

Find a stick that is recognized by Mini. I believe chances are better if you try some older USB 2.0 stick with low capacity (only few GBytes) and format it in FAT32 on your PC.
Then you download this v4.3.2-RC1 firmware (bbf file at the end of the article), copy it to USB stick and update firmware on your Mini - Here is tutorial how to do it.

That new firmware solved all my USB troubles and now I can use any of my USB sticks.

[Mini+] [MK3S+BEAR]...
Posted : 09/06/2021 7:20 am
atomicalex
(@atomicalex)
New Member
Topic starter answered:
RE: USB stick not reading/fails midread

@bogdanh

Thank you! I did exactly that and it worked. So I am off to the printing pad...

Posted : 09/06/2021 8:51 pm
Share: