Notifications
Clear all

[Solved] Problems connecting OctoPrint/Raspberry Pi  

  RSS
ms1963
(@ms1963)
Active Member
Problems connecting OctoPrint/Raspberry Pi

I am experiencing serious problems when trying to connect OctoPrint with my Mini+.

Prusa even exchanged the Buddy board - the first one had a broken micro usb connector. The problem is that the Raspberry Pi hosting OctoPi/OctoPrint  (most current release) won’t connect to my printer. To figure out the problem I used two Raspberry Pi 4 boards  (4GB resp. 2GB) and one Raspberry Pi 3B+ board. In addition, there were different USB cables used, in particular seven data cables from cheap to premium quality, trying out all 4  USB connectors of the boards. But every configuration failed.

To rule out hardware defects, I installed Pronterface which is targeting i3 MK3 printers, but also can connect to a Mini/Mini+. Every time the connection succeeded and Pronterface showed me the correct temperatures of the bed and the nozzle. Thus, the serial connection via USB obviously works.

I ran out of ideas what could be the root cause of the problem. Did anyone else have similar issues and could solve them. If yes, what could I do next?

All hints and ideas highly appreciated

This topic was modified 5 months ago 2 times by ms1963
Posted : 07/07/2021 9:23 am
ms1963
(@ms1963)
Active Member
Topic starter answered:
Solution found

After narrowing the solution space I figured out that the defect Buddy board and then the OctoPi/OctoPrint installation caused the problems, in particular it was of the plugins fault. After reinstallation everything works fine now. 

Posted : 20/07/2021 8:02 am
Share: