Notifications
Clear all

Pause (M601) Not Working  

  RSS
alancart
(@alancart)
New Member
Pause (M601) Not Working

I am trying to pause a print to insert some nuts in a print but after 8 hours the print just kept going. I made a small test part with the same nut void and the pause after to verify the functionality and noticed the same issue. Checked the code (screenshot below) and the M601 command is there but the Mini just skips over it. Anyone have any ideas? Does the Mini fw support this command?

Prusa Mini running 4.0.4 fw

ps. from googling around I also saw some old posts that most peoples problems were with the print not being able to be restarted after the pause and the issue was that the resume M602 command and a brief pause was missing from the code. Didnt see those on my gcode so anticipating this could be the next problem.

Posted : 04/04/2020 5:48 pm
Robee Shepherd
(@robee-shepherd)
Estimable Member
RE: Pause (M601) Not Working

It isn't supported in the firmware for the mini yet 🙁

I have an issue open on Github for it: https://github.com/prusa3d/Prusa-Firmware-Buddy/issues/283

Sorry for the bad news. I have been using a wait instead, which is supported but not as convenient.

Posted : 05/04/2020 8:00 am
alancart liked
SaddamCZ
(@saddamcz)
New Member
RE: Pause (M601) Not Working

I have the same experience with 4.0.5 fw, the printer ignores M601 in the gcode even though the PrusaSlicer 2.2.0 as its insertion as a function now even when mini is selected as a printer. This is quite a disappointing incompatibility. It almost ruined a print for me, but I was lucky to be around at the right time.

Posted : 11/04/2020 7:19 pm
julian
(@julian)
Active Member
RE: Pause (M601) Not Working

I just ran into a problem with this.

The M601 paused my print, but everytime I went to resume, it would heat up, get ready to print and then go back to the pause state. I tried multiple times, and it was just stuck in a loop - very frustrating.

 

Back to M0 for me!

Posted : 15/05/2020 9:16 am
JJ
 JJ
(@jj-5)
Active Member
RE: Pause (M601) Not Working

I just learned this same lesson tonight and it ruined a 4.5 hr print. In my Octoprint serial.log, M601 and M602 return as unknown commands. It would have been nice if that were documented somewhere.

Posted : 16/05/2020 5:31 am
David K
(@david-k-3)
Active Member
RE: Pause (M601) Not Working

BTW on the FIRMWARE 4.2.1 M601 works, BUT only for prints from flash disk. Doesn't work with Octoprint 🙁
Pause message is displayed on Octoprint web page, BUT MINI is ignoring M601 command in serial data....

Posted : 12/11/2020 6:49 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Pause (M601) Not Working

@julian

maybe in this way with M0:

; pause ?
{if layer_z==xxx}; set pause-z-coordinate (replace xxx with value; close insert)
M117 pause printing
M300 S1000 P500; beep
G91
G1 Z30; pause, move print head up (check max_z)
M104 S170; reduce nozzle temp
M0 pause - press knob to continue
M109 S[first_layer_temperature]; set nozzle temp
G1 Z-30; continue, move print head down
M400; wait finishing moves
G90
M117 continue printing
{endif}

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 12/11/2020 7:49 pm
salsa
(@salsa)
Eminent Member
RE: Pause (M601) Not Working

I just ran into this on a MK3 running the latest firmware (3.9.3), slicing from PrusaSlicer 2.3.0, printing from OctoPrint. It just kept going 🙁

When I add filament changes in the slicer, they work fine. I'd rather not unload and reload the same filament when I really just want a pause so I can stick something in my model.

Any tips would be appreciated!

Posted : 10/03/2021 9:14 pm
Robee Shepherd
(@robee-shepherd)
Estimable Member
RE: Pause (M601) Not Working

Oh well, at least you Mk3 owners are having the same problem as us Mini owners! But you also use Octoprint so you can use that to notice a pause instead, which is handy! I'm sure someone on the Mk3 forum can give you the GCode you need to add to Octoprint when it's paused.

To make sure Octoprint notices the pause Gcode, open settings and go to Printer -> Serial Connection -> Firmware & Protocol then make sure the GCode command is in the pause section.

Posted : 10/03/2021 9:23 pm
salsa liked
Share: