MINI keeps changing filament for no reason  

  RSS
Rob
 Rob
(@rob-13)
New Member

1st Gen MINI with filament sensor, approx 1 year old.

Recently it keeps changing the filament for no reason. I'll check on my print and the filament will be spit out and it's sitting there, nozzle cooled off, waiting for me to re-load filament.

Where should I start in troubleshooting?

Posted : 09/12/2020 9:23 pm
örkelprint
(@orkelprint)
Eminent Member

Maybe accidentally clicked at the change colour at layer X in the slicer? It happened to me before.

For real troubleshooting check the gcode of an affected print and rule out that the filament change code is in there. Open the file with notepad or similiar and search for "M600" (code for colorchange). If is in there without a ";"  beforehand it comes from the slicer.

If not..well something is fucky then.

Posted : 10/12/2020 9:32 am
Rob liked
Neophyl
(@neophyl)
Noble Member

Don't have a mini but do have a mk3, I think the change filament is the same process / code logic as the filament run out, at least it is on the mk3.  First place I would check is the filament sensor which you say you have. 

Its my understanding that the mini uses the simple microswitch with lever arm that many of the cheaper printers use to detect filament presence.  These have a tendency to bend the arm over time which can lead to erratic operation.  That triggers a change filament process. 

There is a similar one on my Cr10 and I have to periodically disassemble and bend the arm back to shape to get it working for awhile.  At some point I'll replace the entire microswitch with a new one when metal fatigue sets in and the arm bends too easily.  Or I'll design something better.  

Posted : 10/12/2020 9:50 am
Rob liked
karl-herbert
(@karl-herbert)
Illustrious Member
Posted by: @rob-13

1st Gen MINI with filament sensor, approx 1 year old.

Recently it keeps changing the filament for no reason. I'll check on my print and the filament will be spit out and it's sitting there, nozzle cooled off, waiting for me to re-load filament.

Where should I start in troubleshooting?

The Mini is equipped with a hybrid filament sensor variant, which is also used in the MK3S. It is possible that the sensor is misaligned. If necessary, you could also deactivate the sensor.

https://forum.prusaprinters.org/forum/hardware-firmware-and-software-help/prusa-mini-ir-sensor/

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 10/12/2020 10:56 am
Rob liked
Share:

Please Login or Register