Immediately after successful print, Mini goes into mesh bed leveling procedure
 

Immediately after successful print, Mini goes into mesh bed leveling procedure  

Page 2 / 2
  RSS
malcmcm
(@malcmcm)
Trusted Member

Ah my mistake, I must have saved the 3mf before removing the G80, take it out if you wish

Posted : 06/08/2020 9:30 am
zoltan
(@zoltan)
Member Moderator

Hi I am back with update 

seems we have few other reports with similar consequence, when user used custom code M92 - could be the suspect.

Developers working on it. Stay tuned !!!

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.9.1, no closed box, sketchup , fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.2.1, technical background...
Posted : 06/08/2020 2:11 pm
randy.b4
(@randy-b4)
New Member

I googled my way to this thread because I had the intermittent bed leveling end-of-gcode problem show up a half-dozen times starting this week as well. I 'XYZ span calibrated' my two-month-old stock FW 4.2.1 MINI by printing 100mm long flat test blocks and a 100mm z cylinder, and then added to the top of the 'start gcode' section.

 

A half-dozen small test prints (lego blocks) were fine when I only used M92 X & Y: 

M92 X100.4 Y100.6 ; calibrated with coffee pla 2020-10-05 

 

Then it messed up a half dozen times when I added Z:

M92 X100.4 Y100.6 Z100.8 ; calibrated with coffee pla 2020-10-05 

 

I tried a bunch of combinations and have now printed over a dozen blocks OK after splitting the axes and the comment onto separate lines:

M92 X100.4
M92 Y100.6
M92 Z400.8
; calibrated with coffee pla 2020-10-05

I'm wondering if my Z tuning value being greater than the default 400 is leaving the printer confused about where it is at the end? I had a car once that wouldn't shift properly at exactly 0 degrees Celcius outside but was fine above or below that. Or maybe it is the parsing of the inline comment and/or the three parameters plus comment on one line? And my daughter wrecked that car, so now both problems seem to be solved!

FWIW, my stock MK3 with latest firmware accepted:          M92 X100 Y100.2 Z399.2 ; calibration 2020-10-06         just fine.

Randy Burnet (LegoTrainNut)

Posted : 07/10/2020 7:36 pm
Tim
(@tim-m30)
Illustrious Member

As for the printer running past the end of gcode -- anyone try inserting an M112 as the last command?

It is always wise to get more than one opinion......
Posted : 07/10/2020 7:43 pm
Page 2 / 2
Share:

Please Login or Register