Notifications
Clear all

After flashing fw 4.0.4 problem LAN detect  

  RSS
smarda
(@smarda)
New Member
After flashing fw 4.0.4 problem LAN detect

after I upload new fw 4.0.4 my printer does not show LAN connection symbol on my display and I have the same 0 in LAN Stings menu even after connecting to DHCP

Posted : 08/03/2020 8:00 am
Lichtjaeger
(@lichtjaeger)
Noble Member
RE: After flashing fw 4.0.4 problem LAN detect

LAN is now deactivated till they solve the problems with the http server.

Shouldn't take too long. Just be a bit patient.

Posted : 08/03/2020 11:03 am
Olef
 Olef
(@olef)
Honorable Member
RE: After flashing fw 4.0.4 problem LAN detect

Yes, network connectivity was disabled from firmware 4.0.3 -

Ethernet instability

In some scenarios, the Ethernet connection of the MINI 3D printer can be overloaded with requests, which may lead to a system crash. The fix will be available in the next version of the firmware along with a new web interface. In the meantime, we have decided to block the Ethernet networking service in order to ensure a safer experience.

Posted : 08/03/2020 9:50 pm
sebastien.v
(@sebastien-v)
New Member
RE: After flashing fw 4.0.4 problem LAN detect

Hi all,

I 've got the same issue with fw 4.0.4.

Is there some news about the problem whit the http server ?

thanks.

...
Posted : 25/03/2020 9:28 pm
bobc
 bobc
(@bobc)
Reputable Member
RE: After flashing fw 4.0.4 problem LAN detect

The web server is restored in 4.0.5, but it's only beta so far. However, I have been running it for a few days without any issues.

Posted : 25/03/2020 9:57 pm
sebastien.v
(@sebastien-v)
New Member
RE: After flashing fw 4.0.4 problem LAN detect

@bobcousins

Thanks, but where to get 4.0.5 ?

...
Posted : 26/03/2020 6:49 am
Lichtjaeger
(@lichtjaeger)
Noble Member
RE: After flashing fw 4.0.4 problem LAN detect
Posted by: @sebastien-v

@bobcousins

Thanks, but where to get 4.0.5 ?

Github.

Posted : 26/03/2020 7:25 am
sebastien.v
(@sebastien-v)
New Member
RE: After flashing fw 4.0.4 problem LAN detect

So, now it's ok with fw 4.0.5

But next step is how to transfert Gcode on it ?

 

...
Posted : 26/03/2020 8:03 am
bobc
 bobc
(@bobc)
Reputable Member
RE: After flashing fw 4.0.4 problem LAN detect
Posted by: @sebastien-v

So, now it's ok with fw 4.0.5

But next step is how to transfert Gcode on it ?

 

The web connection does not support GCode transfer yet AFAIK, if that's what you mean. Perhaps in a future release?

Posted : 26/03/2020 11:34 am
SaddamCZ
(@saddamcz)
New Member
RE: After flashing fw 4.0.4 problem LAN detect

I have a similar LAN issue that persists from 4.0.4 to the recently released 4.0.5. The printer seems to have trouble accepting IP address from DHCP. It its settings, is shows a blank TCP/IP configuration (all zeros), while in my router's stats, I see it the MINI being assigned one IP address after another, until it stops at the end of the DHCP server range. There it remains and is even accessible through its web interface, however the LAN indicator on the printer's display is still grey and the settings still show all zeros.

Posted : 10/04/2020 7:46 pm
Matteo Cristini
(@matteo-cristini)
Reputable Member
RE: After flashing fw 4.0.4 problem LAN detect
Posted by: @hosoman

I have a similar LAN issue that persists from 4.0.4 to the recently released 4.0.5. The printer seems to have trouble accepting IP address from DHCP. It its settings, is shows a blank TCP/IP configuration (all zeros), while in my router's stats, I see it the MINI being assigned one IP address after another, until it stops at the end of the DHCP server range. There it remains and is even accessible through its web interface, however the LAN indicator on the printer's display is still grey and the settings still show all zeros.

Try setting up as static, I find it to be more convenient anyway. You can do it via the lan_settings.ini file on your usb drive.

Posted : 11/04/2020 8:58 am
SaddamCZ
(@saddamcz)
New Member
RE: After flashing fw 4.0.4 problem LAN detect

@matteo-cristini

Thanks, I knew, I tried and it works, it's obviously the way to use it in a permanent setup (there's no reason to use the ethernet yet beyond just trying it IMO), however it's weird how the DHCP client misbehaves.

Posted : 11/04/2020 8:19 pm
eduardolatorresm
(@eduardolatorresm)
New Member
RE: After flashing fw 4.0.5 problem LAN detect

He instalado el FW 4.0.5, definitivamente no es posible conectar a la red, ni con el Archivo .ini, al cargar dice que cargó correctamente pero todos se mantiene en -0-.

??

Eduardo

Posted : 17/04/2020 11:28 pm
Share: